Y Can't I Install 4.3.5 on my 3G?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Eager Beaver, Oct 2, 2011.

  1. Eager Beaver macrumors 6502a

    Eager Beaver

    Joined:
    Sep 28, 2011
    Location:
    Chicago, IL
    #1
    I cannot restore my 3G to a recent backup because itunes says it has old software.
    So I click on update, and it updates to 4.2.1, (not 4.3.5)
    I then try and restore it to my most recent backup, and same message, old software.

    I click on update again, and itunes tells me I am up to date, (even though it says 4.2.1 on both itunes and "settings" on the 3G.

    Does anyone know how I can get 4.3.5 on my 3G, (hoping this will allow me to restore to my latest backup and retrieve my super important business contacts).

    thanks to any suggestions :)
     
  2. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #2
    Anything higher than 4.2.1 isn't supported on the 3G.
     
  3. Eager Beaver thread starter macrumors 6502a

    Eager Beaver

    Joined:
    Sep 28, 2011
    Location:
    Chicago, IL
    #3
    Thanks, do u have any ideas on how to retrieve my business contacts? :eek:
     

Share This Page