Yahoo email not pushing

gianqui89

macrumors newbie
Original poster
May 22, 2015
4
0
Hello all,

My Yahoo email has stopped pushing to my iPhone. I have the iPhone 6 running iOS 8.3. The problem started about a week and a half ago. To receive new emails I have to open the mail app and refresh it.

I have tried deleting the account and adding it again, toggling the push option in settings on and off, and manually setting up the mail account. Nothing has worked.

Is anyone else experiencing the same issue? Or any other ideas of what may fix this issue?

Thanks in advance!
 

Goaliegeek

macrumors 6502a
Apr 13, 2009
564
203
Colorado
Interesting. My girlfriend has had the same issue with her Yahoo. She removed the account from her phone and re added it like you. I set it to what the settings should be to get an email as soon as it comes in, but it still wouldn't work. I tried a few more setting changes last night. I sent her an email today and it still didn't push straight to her phone...
 

snsking

macrumors 6502
Jun 10, 2013
363
74
This has been an on-going issue with Yahoo email services.

Earlier this week Yahoo had/still is having issues. The solution I found was to do the following:

Go into Settings
Then to Mail, Contacts, Calendars,
Go into your Yahoo account
Click Account
Click SMPT
Click Yahoo! SMPT Server
Turn Server OFF
Click Done
and back out

This seem to solve all the issues of emails hanging as "sending", non refreshing feeds, and constant errors while trying to receive new emails.
 
  • Like
Reactions: blkjedi954

gianqui89

macrumors newbie
Original poster
May 22, 2015
4
0
This has been an on-going issue with Yahoo email services.

Earlier this week Yahoo had/still is having issues. The solution I found was to do the following:

Go into Settings
Then to Mail, Contacts, Calendars,
Go into your Yahoo account
Click Account
Click SMPT
Click Yahoo! SMPT Server
Turn Server OFF
Click Done
and back out

This seem to solve all the issues of emails hanging as "sending", non refreshing feeds, and constant errors while trying to receive new emails.
Going to try it out, thank you for the suggestion. Hopefully yahoo gets this resolved soon, it's driving me crazy!
 

gianqui89

macrumors newbie
Original poster
May 22, 2015
4
0
I did the following and the mail seems to be pushing on its own now.

1) Delete the Yahoo account from your iPhone and close the settings app
2) Login to Yahoo mail on your desktop browser
3) Change your password
4) Manually add the Yahoo account to your iPhone using your new password and imap.mail.yahoo.com and smtp.mail.yahoo.com as the servers

Hopefully it'll continue to work
 

Bladery

macrumors 6502
Apr 12, 2015
390
106
I have the same annoying problem!
Thought it was just me...
Called Apple regarding this problem but they couldn't help...

Did you already find an answer?

By the way, it seems to work on my iPad Air 2, 8.3 though!
 

gianqui89

macrumors newbie
Original poster
May 22, 2015
4
0
I have the same annoying problem!
Thought it was just me...
Called Apple regarding this problem but they couldn't help...

Did you already find an answer?

By the way, it seems to work on my iPad Air 2, 8.3 though!
Bladery, try the steps I listed in the post above. It's the only thing that has seemed to fix the issue. It's worked fine for 2 days now. Let me know if it works for you too
 

Bladery

macrumors 6502
Apr 12, 2015
390
106
I tried it except the password change.
Not in the mood to change my password ;-)

However, hopefully they will fix it with iOS 8.4.
 

Afotek

macrumors newbie
Nov 15, 2015
2
0
Canada
I did the following and the mail seems to be pushing on its own now.

1) Delete the Yahoo account from your iPhone and close the settings app
2) Login to Yahoo mail on your desktop browser
3) Change your password
4) Manually add the Yahoo account to your iPhone using your new password and imap.mail.yahoo.com and smtp.mail.yahoo.com as the servers

Hopefully it'll continue to work
hey gianqui,
I am having this problem too! Just started, but I am on the iPhone 4, iOS7.

snsking said we should turn the smtp 'off' but you say something different

you gave 2 server addresses but I am only seeing the option on my phone to enter the smtp
where do i enter the imap address?

This is so unfortunate because it was working fine up to two days ago! Please help
 

rockingrick

macrumors member
Mar 9, 2014
37
5
I having the same problem on iPhone 6s plus, iOS 9.1. Tried to deleting mail account and adding the email account back in, didn't solve the problem. Had to install the yahoo mail app, really don't want to since the iOS mail app does the same thing. Now I get annoying alerts when i get mail. I don't know if its yahoo mail problem or iOS problem.
 

Afotek

macrumors newbie
Nov 15, 2015
2
0
Canada
I having the same problem on iPhone 6s plus, iOS 9.1. Tried to deleting mail account and adding the email account back in, didn't solve the problem. Had to install the yahoo mail app, really don't want to since the iOS mail app does the same thing. Now I get annoying alerts when i get mail. I don't know if its yahoo mail problem or iOS problem.
Yea, mine was working fine. I deleted my account reinstalled, changed password, did a bunch of other stuff but still no luck.
Hopefully someone who knows what's the problem will be kind and share some info. Anyone!
 

missymw

macrumors newbie
Dec 1, 2015
1
0
Same here. I don't know what happened because it was working fine up until a few days ago. I tried deleting the account and re-adding through Yahoo, and also "Other." When I tried other, it couldn't even verify my account. I don't know what the deal is. It didn't *just* start happening with 9.1. It was working just fine up until a few days ago. I have a feeling that Yahoo and iOS just aren't "talking" to each other properly right now. Who knows which end is to blame. I had some intermittent issues with this same thing happening with my iPad (didn't have my iPhone at the time). Hopefully everything will come back online soon.

Also, the "Fetch" setting is for only when "Push" can't be done. I don't remember if I read it here or somewhere else, but some folks were saying it wasn't working (notifications) because "Fetch" was set to "Manually." As long as "Push" is on - and working like it's supposed to - the "Fetch" time won't make a difference. However, in this case, since "Push" obviously isn't working, I guess the phone is defaulting back to the "Fetch" setting.

Hopefully they'll have "Push" working soon - fingers crossed!!
 

Morac

macrumors 65816
Dec 30, 2009
1,285
205
Push just stopped working on my iPhone and iPad this past Friday evening. Prior to that it was working fine. Now most of the time it doesn't push, but occasionally mail will push, but it takes at least 15 minutes to do so. As such mail currently pushes anywhere from 15 minutes after it arrives anywhere up to so long after that it effectively never pushes.

I've tried fixing this, but from past experience I know it requires Yahoo to fix it. The problem is Yahoo no longer has support. There is literally no way to report problems to Yahoo anymore.

In the mean time, I've installed the Yahoo Mail iOS app, which works most of the time, though sometimes that doesn't push either.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.