Yahoo! has hijacked my internet browsers! Help!

UwizK

macrumors newbie
Original poster
Feb 24, 2013
2
0
Saginaw, MI
I get a Yahoo! search homepage for all three of my browsers (Safari, Firefox and Chrome) now. Probably too much porn, idk. But I need help. Tried changing the homepage on Chrome and it does nothing, Firefox will change the homepage on one reboot but then goes back to Yahoo!. HALP MEEEEE!
 

GGJstudios

macrumors Westmere
May 16, 2008
44,436
800
I get a Yahoo! search homepage for all three of my browsers (Safari, Firefox and Chrome) now. Probably too much porn, idk. But I need help. Tried changing the homepage on Chrome and it does nothing, Firefox will change the homepage on one reboot but then goes back to Yahoo!. HALP MEEEEE!
Clear your browser's cache and cookies. Then set your homepage as desired. Also make sure you don't have any add-ons, plug-ins or extensions that could change your homepage. For example, check to see if you've installed the Yahoo! toolbar or other Yahoo! components.
 

UwizK

macrumors newbie
Original poster
Feb 24, 2013
2
0
Saginaw, MI
Clear Recent History is grayed out for me. Don't see any other way to clear history on Firefox. Removed all unnecessary Extensions, had no Add-ons. Still there. It's for multiple browsers so I'm assuming this is a deeper problem that doesn't apply to one browser or each separately because I didn't download any Yahoo! ****. I do use their site though sometimes for Yahoo! Answers.
 

davidlv

macrumors 65816
Apr 5, 2009
1,293
32
Kyoto, Japan
Clear Recent History is grayed out for me. Don't see any other way to clear history on Firefox. Removed all unnecessary Extensions, had no Add-ons. Still there. It's for multiple browsers so I'm assuming this is a deeper problem that doesn't apply to one browser or each separately because I didn't download any Yahoo! ****. I do use their site though sometimes for Yahoo! Answers.
You can "Clear your browser's cache and cookies" and history as suggested above using Onyx (make sure you get the version for your OS) available here. That should work for all browsers. I haven't tested Onyx on Chrome, but it works for Camino, Firefox and Safari.
Set up the prefs first, and then using the automatic pane is effortless. Hope that helps.
 

Rich Gibson

macrumors member
Sep 19, 2009
30
0
Annandale, VA
Clear your browser's cache and cookies. Then set your homepage as desired. Also make sure you don't have any add-ons, plug-ins or extensions that could change your homepage. For example, check to see if you've installed the Yahoo! toolbar or other Yahoo! components.
I feel his pain. I searched the problem on then internet and haven't found any successful solution. I removed the add-ons, then used help to identify the files associated with Yahoo. Nothing works. Some say to click on the pencil icon in the Yahoo menu bar but there is none. That is also noted by some questioners. It's as bad as Symantec's bloatware was on my old PCs. On my MacPro running 10.8.3 Firefox Safe hangs.
 

AnonymousJosh

macrumors newbie
May 4, 2014
8
3
YAHOO hijack

Did we ever get to the bottom of this YAHOO hijack? i'd like to feel clean again. i trashed and reinstalled chrome and YAHOO still comes up as a second tab. i'm also concerned about what other malware may have been installed.

i'm also really irritated with Apple. why have they not found a way to fix this in the security updates? also, why has Google not come up with an easy solution? i've been wasting the last hour reading about this and trying to find solutions.
 

Trvlngnrs

macrumors 6502
Jun 8, 2010
340
26
I've been having the same problem with Firefox being redirected to Yahoo when I click on my bookmarks.
 

kelly Johnson

macrumors newbie
Jan 17, 2016
2
2
YAHOO hijack

Did we ever get to the bottom of this YAHOO hijack? i'd like to feel clean again. i trashed and reinstalled chrome and YAHOO still comes up as a second tab. i'm also concerned about what other malware may have been installed.

i'm also really irritated with Apple. why have they not found a way to fix this in the security updates? also, why has Google not come up with an easy solution? i've been wasting the last hour reading about this and trying to find solutions.
[doublepost=1453078882][/doublepost]I know the thread was a while ago however I have come across another place the invading yahoo can lodge itself if you go to your chrome preferences an take a look at the sub heading (On Start Up) click where the blue text comes up (set pages) this is where i found yahoo was hiding to get rid of just click on the x. hope this works for some
 
Last edited:
  • Like
Reactions: idunn and vanwegen

bunglebonse

macrumors newbie
Dec 7, 2016
1
0
[doublepost=1453078882][/doublepost]I know the thread was a while ago however I have come across another place the invading yahoo can lodge itself if you go to your chrome preferences an take a look at the sub heading (On Start Up) click where the blue text comes up (set pages) this is where i found yahoo was hiding to get rid of just click on the x. hope this works for some

Thanks! this actually worked. I'm going to restart and see if it's still gone
[doublepost=1481177538][/doublepost]
Thanks! this actually worked. I'm going to restart and see if it's still gone
Yep still gone, this solution works!
 

RMH1879

macrumors newbie
May 11, 2019
1
0
Thanks! this actually worked. I'm going to restart and see if it's still gone
[doublepost=1481177538][/doublepost]

Yep still gone, this solution works!

I searched for over an hour before I came here - and it does work! Created an account here just to make this comment. I tried numerous other things, but this was the only one that did the trick. Not allowing my 7 year old to 'play' on my computer anymore!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.