Yahoo has stopped Pushing completely

Discussion in 'iPhone Tips, Help and Troubleshooting' started by rhomsy, Sep 21, 2007.

  1. rhomsy macrumors regular

    Joined:
    Jul 6, 2007
    #1
    I was hoping someone would help me. My yahoo mail has completely stopping pushing to my iPhone. It was always crappy and intermittent, but now it just never works. I deleted the account from the phone and re-created it, but it hasn't fixed the problem.

    What the hell do I do?

    I don't want to just create a new yahoo mail account either because I paid $20 to yahoo to get rid of the stupid ads that they attach to regular yahoo mail.
     
  2. calvy macrumors 65816

    Joined:
    Sep 17, 2007
    #2
    complain to yahoo and thank your lucky stars that at least you have email funcionality, albeit without the instant notification you hoped for. my sbcglobal account, which is like you paid yahoo account, was unable to send email for nearly 4 weeks through the iPhone with the Yahoo account setup. That was frustrating as heck. I went to yahoo's support, as well as Apple's, and finally yahoo came through on Sep 13th with a fix for me (and all other sbcglobal users I guess)
     
  3. rhomsy thread starter macrumors regular

    Joined:
    Jul 6, 2007
    #3
    So I clicked on the online chat help with a Yahoo tech support agent, and this is the transcript from the chat:

    Chat InformationPlease wait for a Yahoo! agent to respond.

    Chat InformationAll Yahoo! agents are currently assisting others. Thank you for your patience. A Yahoo! agent will be with you shortly.

    Chat InformationAll Yahoo! agents are currently assisting others. Thank you for your patience. A Yahoo! agent will be with you shortly.

    Chat InformationAll Yahoo! agents are currently assisting others. Thank you for your patience. A Yahoo! agent will be with you shortly.

    Chat InformationYou are now chatting with Chris

    Chris: Hi! Welcome to our Yahoo! Mail Live Chat service. I'm glad you've joined us.

    Chris: Thank you for providing us the details of your issue.

    Russell Homsy: i can't get it to work

    Chris: I understand that you are having a problem with your POP settings with your iPhone, am I right?

    Russell Homsy: No... It's not POP... It's Push IMAP

    Russell Homsy: hello?

    Chris: Unfortunately, I cannot support you further since this is happening in your iPhone.

    Chris: My support is limited for Yahoo! Mail.

    Chris: But I'll give you some information needded for setting up your iPhone.

    Russell Homsy: you're telling me that it's not Yahoo's problem?

    Chris: It is on the way you setup your iPhone. It is just an incorrect settings.

    Chris: For your reference, your POP3 settings are:

    Russell Homsy: ok.. what should I have done? Because the iPhone doesn't have settings for Yahoo except for email and password.

    Chris: Incoming Mail Server (POP3): pop.mail.yahoo.com

    Chris: Outgoing Mail Server (SMTP): smtp.mail.yahoo.com - or your ISP's SMTP server address

    Chris: Account Name/Username: Yahoo! ID

    Chris: Email address: you@yahoo.com

    Chris: Password: Your Yahoo! Mail password

    Russell Homsy: It's NOT POP. It's Push IMAP.

    Chris: For help in setting this up. I suggest that you contact your iPhone vendor for further assistance.

    Chris: Yahoo! uses POP for mobile settings or mail programs settings.

    Chris: You can check that information in the Yahoo! Help pages.

    Chris: For iPhone support.

    Chris: Click here for iPhone support.

    Russell Homsy: Considering how the CEO of Yahoo was on stage at the last Macworld to announce Yahoo Push for the iPhone, I can't believe Yahoo's tech support doesn't even know that it uses IMAP and not POP.

    Chris: Click here for iPhone support.

    Chris: To setup Push for your iPhone the servers that you need are pop.mail.yahoo.com and smtp.mail.yahoo.com

    Chris: That are the mail servers that Yahoo! uses.

    Chris: I'll be giving you the help page for this information.

    Chris: Please hold on for a moment.


    THEY DON'T EVEN KNOW THAT IT USES PUSH IMAP.
     
  4. d21mike macrumors 68040

    d21mike

    Joined:
    Jul 11, 2007
    Location:
    Torrance, CA
    #4
    I have been using Yahoo Push since 7/12/2007. I have intermitant problems.

    Here is what I do.

    1. Determine what is going on. Are you getting mail but no Push?

    Go into your iPhone mail client. Select a folder other then InBox. Like Sent or Drafts. You should see the following:

    a. Connecting...
    b. Checking for Mail...
    c. Updated

    Remember you MUST go into a different folder each time for this to happen.

    Assuming that works then go into the InBox Folder. What do you see. Does it stop at "b.". If that happens, I find that there is a problem with my InBox on Yahoo. Normally it has some OLD MAIL RE-APPEAR that need to be deleted. Once I delete it then it starts Pushing again.

    If you search this forum you will see some other tricks to try.
     
  5. d21mike macrumors 68040

    d21mike

    Joined:
    Jul 11, 2007
    Location:
    Torrance, CA
    #5
    MORE on my last Post.

    Since you paid the $20 (I did as well). I believe you could setup a POP Account on your iPhone if you want and have it check every 15 min. You would just need to use the "Other" settings. I have not tried this but I don't know why it would not work. The iPhone "Yahoo" settings is for the Yahoo Push Email that you and most others are using. The POP does NOT work for FREE Yahoo Mail.
     
  6. jecapaga macrumors 601

    jecapaga

    Joined:
    Jul 1, 2007
    Location:
    Southern California
    #6
    uh...how are you seeing multiple folders? in my yahoo acct I only have 'inbox' and 'trash' folders to choose from. No 'sent', no 'drafts'. Any ideas?
     
  7. d21mike macrumors 68040

    d21mike

    Joined:
    Jul 11, 2007
    Location:
    Torrance, CA
    #7
    In Mail setup remove the IMAP Path Prefix. You probably put something there because of another thread. Should be the default "/". You should be using all the default settings when you created your Yahoo Account on the iPhone.
     
  8. jecapaga macrumors 601

    jecapaga

    Joined:
    Jul 1, 2007
    Location:
    Southern California
    #8
    ah yes...that's the problem. i deleted imap.apple.mail.yahoo.com and folders appear. so this box just remains blank..just the '/' ?
     
  9. d21mike macrumors 68040

    d21mike

    Joined:
    Jul 11, 2007
    Location:
    Torrance, CA
    #9
    Right. I just use the default setting excpet for "Remove" Delete Messages "After one day". This is in Advanced for the Yahoo Account.

    Other things to remember. If it is working properly per my prior post but still not getting Push to work (only works manually). I have tried the following:

    1. Power Reset the phone.
    2. Place Phone in Airplane mode for 15 seconds and then back on and then Power Reset. This was recommend by Apple to someone else on this forum. Apple said it was a ATT Network Problem.

    I have some concerns about there being a problem going back and forth between using WiFi and EDGE. Normally I am on EDGE. But I have noticed this problem when just on EDGE.

    My experience has been that it will work good for say 3 days and then stop working. This usually means OLD Mail has RE-APPEARED.

    I am going to continue to fight this until the first major update happens. If they (Apple or Yahoo) have still not fixed this problem I may go a different direction. Maybe try using a POP Account. Or maybe add a dummy POP account that wakes up the Mail Client which then may also check Yahoo. Again, going to give the 1st major update a try. Just hope it happens soon.
     
  10. kssw macrumors newbie

    Joined:
    Sep 26, 2007
    Location:
    Chicago
    #10
    iPhone and Yahoo Push

    My Yahoo email with the "standard" configuration settings that are applied when I set up the Y! option also stopped working about 3 weeks ago. It would not get past the "Checking mail..." step. This would last for a day or two, then I would get a dump of emails all at once... Checking every hour never seemed to work for me...
    I followed the instructions that Mike posted, and I also completely cleared by Yahoo Inbox before starting...

    1. Power Reset the phone.
    2. Place Phone in Airplane mode for 15 seconds and then back on and then Power Reset. This was recommend by Apple to someone else on this forum. Apple said it was a ATT Network Problem.


    I sent an email from work to my Yahoo address and it was downloaded immediately upon checking my Inbox.

    I'll wait and see if the scheduled email check works now.

    Thanks for the info Mike.
    Scott
     
  11. d21mike macrumors 68040

    d21mike

    Joined:
    Jul 11, 2007
    Location:
    Torrance, CA
    #11
    Good to hear Scott....

    Just a reminder. This is not a one time fix. I usually have problems on average about every 3-4 days. However, this proceedure can be used to get it working again.

    Would be good to know if you notice the problem with MAIL RE-APPEARING after you delete it. This seems to be the problem I notice the most. Maybe after the 6 week conversion that Yahoo is currently doing (moving to new email servers) will fix this problem.

    Good Luck.
     

Share This Page