Yahoo mail push stopped working unless I add a 2nd mail account

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Morac, May 17, 2012.

  1. Morac macrumors 6502a

    Morac

    Joined:
    Dec 30, 2009
    #1
    At some point today, Yahoo Mail stopped pushing to my iPhone and iPad. I can go into the Mail app and trigger a manual sync, but push is no longer working. I tried all the basic troubleshooting (removing and re-adding account, rebooting, resetting, etc) and nothing worked.

    I added a dummy Yahoo account and push worked for that account, but what's odd is that when I did that push started working for my normal account as well. Thinking things were fixed I removed the dummy account and push stopped working for my real account. I added the dummy account back and push started working again for my main account. I added the dummy account to my iPad and that fixed my main account on that device as well. I tried leaving the dummy account on the phone, but turning off mail and then push stopped working for my real account. For fun I removed my real Yahoo account and push still worked for the dummy account.

    So basically to get push Yahoo mail working for my real Yahoo account, I need to leave a dummy Yahoo account on my phone which makes absolutely no sense.

    I know Yahoo sends notification to Apple when new mail arrives and then Apple pushes down a new mail notification which triggers the Mail app on the device to check for and download the new mail, but I don't know what part of this process is broken. Yahoo appears to be sending the new mail notification to Apple since I will get a push notification for my main Yahoo mail account, but only when a dummy account is added. That makes me think that maybe Apple is ignoring the registration of my real account (or something is locked up on the server) and not actually sending the push notification received from Yahoo to my device. Then again I also know that Yahoo registers the UUID id when an account is added to an iOS device so it's possible that that's the reason it's working when the dummy account is added since both accounts would be using the same UUID and Yahoo might be keeping a list of active UUID to send to, but that doesn't make sense either since Yahoo knows to send a push notification for my real account when my dummy account is added even though they aren't at all related.

    I tried calling Apple Care and they are pretty much as confused as I am. I got all the way up to the step where a restore was recommended, but the person help off on me doing so since it's affecting multiple devices. The person believes it's a Yahoo server issue, but if I to escalate it on Apple's side, I'd need to do a restore first.

    I've sent an email to Yahoo, but they tend to take their time responding to things or understanding anything.

    So basically currently I have a dummy Yahoo account on my phone and set up filters to block all mail to that account. That works, but I don't want to have to do that.

    Anyone have any idea how to fix this besides using the dumb work around I have now?
     
  2. davidr9434 macrumors newbie

    Joined:
    May 18, 2012
    #2
    Mine stopped pushing 2 days ago, have spoken to apple several times but they believe it is a yahoo issue. I am awaiting a response from yahoo, so we'll see how that goes, but going by other forums yahoo push email doesn't seem to be very stable.
     

Share This Page