Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Yahoo mail will not verify on iPhone 5 help

meridiusuk

macrumors member
Original poster
Jun 25, 2010
49
2
Hi all did a restore from my old iPhone 4S iOS 5 device and I can not get the iPhone to verify my password it just keeps saying try later.

My gmail worked. Tried deleting it and re entering it but it just will not go

I removed yahoo mail from my settings and then rebooted the iphone and then entered the details in by using the iphones new mail option and it still did not work ?

just says yahoo server unavailable try again later. but on my old iphone 4s and ipad i just tried it and it checks my yahoo email no problems.

i just dont get what is going on

can anyone help
 

meridiusuk

macrumors member
Original poster
Jun 25, 2010
49
2
Same thing for me

yep, i thing i can fix it by doing a new install of the phone but i really wanted to avoid that so i was hoping if someone know how to fix it.

have you tried a new install yet or just the backup from your old phone
 
Comment

pozzy

macrumors newbie
Sep 22, 2012
1
0
On my iPhone, I shut off Private Browsing in Safari and all of a sudden it worked.

On my wife's phone, she never had Private Browsing enabled, so I'm still stuck on fixing Yahoo mail on that phone.
 
Comment

Voodoophone

macrumors member
Oct 17, 2007
39
0
Glasgow
My wife's new iPhone5 (jealous) had the same problem.

Fixed it be deleting the mail account, creating a new one.
Don'r select Yahoo, but choose other and type in your details manually.

It means you'll have a POP3 account, but it seems IMAP is playing silly buggers on the iPhone5

Hope that helps.

Seth
 
Comment

meridiusuk

macrumors member
Original poster
Jun 25, 2010
49
2
well i just tried it again and now it works the only thing i did different was i did not fill in the name option and it worked then i saved it went back to the name and filled it in and now all ok

what a strange one
 
Comment

meiphonelover

macrumors newbie
Sep 22, 2012
1
0
Yahoo mail will not verify on iPhone 5

That's it! I turned on Private Browsing in Safari and it worked! So if it is on turn it off and if its off turn it on. It's worth a try.;)
 
Comment

jayjp1

macrumors newbie
Sep 22, 2012
1
0
iphone 5 yahoo mail verification nightmare

I tried almost all of these solutions except a total new install of everything, i'm really hoping someone else figures some other solution before i do that.
 
Comment

specops

macrumors regular
Jun 29, 2007
244
0
last night i had the same problem

my fix:
1) i deleted my old yahoo mail account off of my iphone 4
2) i deleted my old iphone 4 icloud backup file after backing up my new iphone 5

that fixed it as soon as i did step 2, i figured it had something to do with a setting saved in the icloud backup.
 
Comment

Snotboogie

macrumors newbie
Sep 22, 2012
5
0
Yea i tried that too. Wow this is so annoying. Thanks for those that tried to help though
 
Comment

ohio.emt

macrumors 6502a
Jul 18, 2008
805
155
Ohio
I had that problem my IM app on my pc couldn't log in either and stated I needed to log in on yahoo.com due to security reasons. Went to yahoo logged in it asked me about password recovery. Then tried my iPhone again and yahoo mail worked.
 
Comment

i-John

macrumors 6502a
Jul 14, 2008
668
49
The Republic of Texas
Yahoo has a security "feature" where if there is suspicious activity or failed logins, it will lock the account for POP or IMAP.

In most cases, these can be cleared via a login at yahoo.com. There is a situation though, where IMAP failures will cause a hard lock on the account for 24 hours.
 
Comment

Snotboogie

macrumors newbie
Sep 22, 2012
5
0
I tried logging on yahoo.com andwas succesful but again not on iphone 5 mail app and hopefully its just a 24 hour lock
 
Comment

twogunz

macrumors newbie
Sep 22, 2012
2
0
I got my yahoo account to work by removing it from the list of email accounts, closing the mail application, and then adding my Yahoo email account back in.

Hopefully that process works for some others.
 
Comment

Snotboogie

macrumors newbie
Sep 22, 2012
5
0
^^ wow thanks this finally worked for me. I deleted mail account in the settings and then closed out the mail app, went to restore it again, in the settings menu but it still wouldnt work, but i closed out both the mail icon and settings icon and this time I decided to input the setup information by pressing the mail app icon instead of going into the settings.
 
Comment

stacybean

macrumors newbie
Sep 26, 2012
1
0
That's it! I turned on Private Browsing in Safari and it worked! So if it is on turn it off and if its off turn it on. It's worth a try.;)

This worked for me too! I just got my iPhone 5 yesterday and couldn't get into Yahoo mail until finding this forum. I turned on private browsing then entered my Yahoo password and it works. Turned off private browsing afterward (since that is my preferred setting) and it still works. Easy (but weird) fix!
 
Comment

ViciousRap

macrumors newbie
Sep 30, 2012
2
0
I cant get 3 of my yahoo accounts to work!!!!!

:mad::mad: I tried everything that has been posted here with no success. Whats weird is that one of my yahoo accounts that automatically transferred when I activated my new iPhone 5 is working, but not my other 3 yahoo accounts. I did have to go to yahoo on my computer to unlock the 3 accounts, but they still wont work from my phone.
 
Comment

ViciousRap

macrumors newbie
Sep 30, 2012
2
0
Maybe a fluke or a fix..........

Ok, I have tried everything listed in this forum. I was reading some other forums and alot of people were mentioning the push function. So I turned off the push and set my mail to fetch every 15 minutes. Then I re-entered the 3 emails that had quit working for me, and now they all work. I did turn the phone off and back on after every email I entered. So happy its working now, hope this works for some of you.:D
 
Comment

lagibson1

macrumors newbie
Dec 8, 2012
1
0
Got it to work (finally!)

I watched this video as well as tried many of the things mentioned above (fetch instead of push and private browsing turned on safari) and finally got it to work. I did have to use the "Other" email option and then used this video, http://tinyurl.com/bzkubkf, and input everything as the tutorial indicated. I can't believe I finally got it to work - been working on this for hours. :D
 
Comment

tigress73

macrumors newbie
Dec 25, 2012
2
0
Got it to work - thank you!!!

Just got my 5 (Merry Christmas!) and also could not load my main yahoo accnt...another yahoo accnt loaded without a problem. I also did everything, but then loaded the problem one using "Other" under the Add Account options.... worked like a charm! Thank you everyone! :)
 
Comment

mysys

macrumors newbie
Dec 27, 2012
1
0
finally its work for my new iphone 5

A few people are having problems having their Yahoo mail account set up so heres the fastest way to fix the problem.
1. Go to Settings
2. Then select "Mails, Contacts,and Calenders"
3. Add account
4. Select "Other" and select "Add Mail Account"
5. add this
To set up Internet Message Access Protocol (IMAP) on your mobile device, please use the following settings:
Incoming Server -
Host Name: imap.mail.yahoo.com
User name: (what comes BEFORE '@yahoo.com')
Password: (Your email password)

Outgoing Server -
Host Name: smtp.mail.yahoo.com
User Name: (what comes BEFORE '@yahoo.com')
Password: (Your email password)

hope all got that to:)
 
Comment

gotmulch

macrumors newbie
Dec 28, 2012
1
0
A few people are having problems having their Yahoo mail account set up so heres the fastest way to fix the problem.
1. Go to Settings
2. Then select "Mails, Contacts,and Calenders"
3. Add account
4. Select "Other" and select "Add Mail Account"
5. add this
To set up Internet Message Access Protocol (IMAP) on your mobile device, please use the following settings:
Incoming Server -
Host Name: imap.mail.yahoo.com
User name: (what comes BEFORE '@yahoo.com')
Password: (Your email password)

Outgoing Server -
Host Name: smtp.mail.yahoo.com
User Name: (what comes BEFORE '@yahoo.com')
Password: (Your email password)

hope all got that to:)

FINALLY got this to work using this method. Be sure to enter your password in every field that asks for it. I left the Outgoing Server User Name field blank.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.