Yahoo! Push

Discussion in 'iPhone' started by macDonalds, Jul 12, 2008.

  1. macDonalds macrumors 6502

    Joined:
    Jun 8, 2007
    #1
    I just signed up for Yahoo! mail hoping to achieve push... but it's not working for me. Is this a known issue? How's it working for others?
     
  2. bstpierre macrumors 6502

    Joined:
    Mar 28, 2008
    #2
    I just sent myself an email at my Yahoo account and it pushed right on through to the phone. It is working for me.

    The only thing I can recommend off the top of my head is to check your Settings -> Fetch New Data is On.
    Go in there and go to advanced at the bottom and make sure your Yahoo account is set to push. Good Luck.
     
  3. sibruk macrumors 6502a

    Joined:
    Sep 17, 2007
    Location:
    UK+US
    #3
    Just tried it for the first time earlier this evening as well, and the Push side is working for me just fine.
     
  4. macDonalds thread starter macrumors 6502

    Joined:
    Jun 8, 2007
    #4
    Thanks guys.

    That's weird because I have my settings like yours.

    It is a free service right?
     
  5. aforty macrumors 65816

    aforty

    Joined:
    Nov 27, 2007
    Location:
    Brooklyn, NY
    #5
    How is Yahoo achieving push email on the iPhone?

    Is this through MobileMe you guys are talking about?
     
  6. macDonalds thread starter macrumors 6502

    Joined:
    Jun 8, 2007
    #6
    No apparently Yahoo has had this for a while now. I've only looked into since the MobileMe launch debacle.
     
  7. Jestered macrumors 6502

    Joined:
    Oct 13, 2005
    Location:
    Austin, Texas
    #7
    Yahoo has been "pushing" their emails since the first iPhone.
     
  8. srent5 macrumors member

    srent5

    Joined:
    Aug 10, 2007
    Location:
    CA
    #8
    When I first started using Yahoo Push for the iPhone I could never rely on it sending or receiving messages. For a few months I found that if I logged onto the account while on a computer it made things worse. It used to be that yahoo would have an email confirmation box to verify you were not an automated sender before a message was sent (not sure if they still do), and I was thinking that could have been the problem. However, this was for only a few months after I first started using the service, and for the past 6 or 7 months the push feature has worked perfect.
     
  9. macDonalds thread starter macrumors 6502

    Joined:
    Jun 8, 2007
    #9
    Any options on yahoo web that I have to set? I have all the push settings fine on the iPhone... not sure why it isn't working.
     
  10. macDonalds thread starter macrumors 6502

    Joined:
    Jun 8, 2007
    #10
    Thought:

    I signed up for an account with "@ymail". I doubt that would be it but who knows.
     
  11. danny_w macrumors 601

    Joined:
    Mar 8, 2005
    Location:
    Austin, TX
    #11
    I assume that Yahoo push email is IMAP, but they only seem to support POP for your desktop client. Doesn't this mean that you can only see on your iPhone messages that have not been received by the desktop client, since the messages are then deleted on the server? Surely you aren't expected to use Yahoo email on your phone only, or your phone + web.
     
  12. ClemTiger0408 macrumors 6502

    Joined:
    Jun 30, 2007
    #12
    Now if only Gmail would incorporate this feature!
     
  13. srent5 macrumors member

    srent5

    Joined:
    Aug 10, 2007
    Location:
    CA
    #13
    @ymail is fine on my girlfiend's iPhone, and there was no setting on yahoo.com that I had to make. Try logging onto the account online and then log off, then delete the account from the iPhone and re-add it. This used to be a temporary fix for me, but like I said, one day it all just started to work.
     
  14. macDonalds thread starter macrumors 6502

    Joined:
    Jun 8, 2007
    #14
  15. macDonalds thread starter macrumors 6502

    Joined:
    Jun 8, 2007
    #15
    DING DING DING! WE HAVE A WINNER!

    So I logged off the web, deleted my iPhone account and then recreated it on the iPhone. Works like a charm.

    Thanks so much.
     
  16. Warpdrv macrumors member

    Joined:
    Jul 9, 2008
    #16
    I can't say its using push, but I setup my gmail accounts on my phone and just have it fetch, I did once an hour, but I have had no problems whatsoever...
     
  17. srent5 macrumors member

    srent5

    Joined:
    Aug 10, 2007
    Location:
    CA
    #17
    Glad I could help. I don't know if you have problems sending emails as well, but I found that not only were my messages not being pushed but they were not sending right away either (even though it made the send noise, and showed in the sent folder). I used to send myself the email as well, not a BC or CC, to verify that it was actually sent. Try sending yourself an email to make sure everything works.
     
  18. lakaiordie macrumors 65816

    Joined:
    Jun 17, 2008
    #18
    for yahoo i tried what you said above and my emails are getting sent out most of the time, my gf still isnt getting them sometimes though even though it says it was sent. is this a yahoo problem, or a software problem?

    maybe itll fix when the next update comes around?
     
  19. srent5 macrumors member

    srent5

    Joined:
    Aug 10, 2007
    Location:
    CA
    #19
    When it happened in the past (no longer is an issue for me) it seemed to be a timing issue. I noticed when in the inbox the message would have a time received or sent that was an hour less than what time it showed on the message when it was open.

    Image one would have been exactly one hour earlier or one hour later than the second image. It happened when my messages where not being sent, and when I was having issues with the push feature.
     

    Attached Files:

Share This Page