yeah, so lion broke my iMac

Discussion in 'Mac OS X Lion (10.7)' started by tommy060289, Jul 21, 2011.

  1. tommy060289 macrumors regular

    Joined:
    Jun 20, 2011
    #1
    Ok so maybe it's not quivering box of silicon but as much as I love some of the new features, there are three very obvious problems, one of which could have serious consequences if your unlucky.

    1. The most serious problem, Apple has changed the permissions required for a NAS to work with time machine so quite a large portion of NAS drives don't work with time machine until a firmware update is published to bring them up to date! This is one of the most annoying things as a. If something goes wrong I'm screwed and b. I can't move back in the time machine to recover something that will be explained after the break...

    2. I was completely unaware that once you've updated to lion, you can't get the the files required to make a bootable USB drive so I'm going to have to have another 8 hour download session, joy...

    3. When my time machine first error'd I thought Id try repairing the disk permissions and it seems all hell has broke loose in there. I repair a great chunk of error that appear to be:

    Permissions differ on “System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Support/Remote Desktop Message.app/Contents/Resources/pl.lproj/UIAgent.nib”; should be -rw-r--r-- ; they are drw-r--r-- .

    Repaired “System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Support/Remote Desktop Message.app/Contents/Resources/pl.lproj/UIAgent.nib”

    and similar things except that at the end I get this:

    Warning: SUID file “System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent” has been modified and will not be repaired.

    and if I run repair disk permission again it just fixes the same errors over again so it is clearly not repairing them, I'm not sure what problem these are creating yet but no doubt something will crop up soon that is related...
     
  2. APtalent macrumors regular

    Joined:
    Jun 5, 2010
  3. tommy060289 thread starter macrumors regular

    Joined:
    Jun 20, 2011
    #3
    I would for now if my back ups worked...

    right now I'm debating wether to run the snow leopard disks that came and then restoring from back up or just waiting it out for the bugs to be ironed out.

    Im trying to figure out what errors the remote management is causing but I can't right now:(
     
  4. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #4
    The main errors I see are Apple Remote Desktop errors, not TM errors.
    I don't know what else to say on your other points. There is the repair partition that will work for most users. The power users all seemed to know to make a copy of the installer before installing. Or at the vary least a bootable USB drive. Sorry your install is not working. The NAS was a known issue as well.
     
  5. tommy060289 thread starter macrumors regular

    Joined:
    Jun 20, 2011
    #5
    mine are remote desktop errors to. Has anyone found a fix yet or is it just awaiting patching from apple?

    As for the time machine errors I'm surprised the manufacturers haven't got new firmware out already as they must have known this for a while!
     
  6. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #6
    Oh, sorry, I meant I see from your post. I had no install issues.
     
  7. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #7
    I think they have known.
    http://forums.macrumors.com/showthread.php?t=1186508&highlight=lacie
     
  8. tommy060289 thread starter macrumors regular

    Joined:
    Jun 20, 2011
    #8
    ahhh, no worries, anyone got any idea on a fix for the remote desktop error?
     
  9. Grabauski macrumors newbie

    Joined:
    Jul 21, 2011
    Location:
    Harrison, Arkansas
    #9
    No 'problem'

    There's not really anything 'wrong'; the

    Warning: SUID file “System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent” has been modified and will not be repaired.

    has been happening since Leopard and the only thing to do is ignore it; everything still works, and Apple knows about it and doesn't consider it a priority.

    The other ones, you'll note, are all .nib files, which might actually be considered directories, since they are interface builder 'archives'...so Disk Utility is seeing them as directories and trying to set new permissions for them, but can't really do so, because it can't really declare them *not* to be directories (you'll note in your example that the only difference in -rw-r--r-- and drw-r--r-- is that 'd' for 'directory' at the beginning; thus, the permissions were already correct, but Disk Utility isn't 'getting it'; Disk Utility, it seems, has not been fully updated, either, to reflect the fact that you can now repair the startup disk without having to boot from the non-existent Lion install disk).

    I hope this is helpful. I am not really a UNIX guy, nor do I play one on TV...but I've had to play one in various rooms of the house over the last few years trying to fix things (and often breaking them far worse before the fix becomes apparent!).

    Eric
     
  10. Gabbelito macrumors newbie

    Joined:
    Jun 11, 2011
    #10
    I just noticed this too while checking my permissions.
    Is there anything I can do to fix this?
     
  11. beemerrider macrumors newbie

    Joined:
    Aug 4, 2011
    #11
    This was a non problem several versions back also

    I think it was Tiger that had this issue for some time before Apple updated the disk utility. Here is a link from Apples website explaining these are not errors. You will note a couple of things. It's referring to these error's in 10.5 and 10.6, but the article was updated with new examples in June of 2011, so Apple has added some Lion errors to the list by the look of things.

    http://support.apple.com/kb/ts1448
     
  12. hayesk macrumors 65816

    Joined:
    May 20, 2003
    #12
    So what did the NAS vendor say when you contacted them and asked them when they would update their firmware? You did contact them, right?
     
  13. blackomega31 macrumors member

    blackomega31

    Joined:
    Aug 6, 2011
    #13
    Dude no. Going from lion to snow leopard is upgrade.
     
  14. Moccasin macrumors 6502a

    Moccasin

    Joined:
    Mar 21, 2011
    Location:
    Newcastle, UK
    #14
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_5 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8L1 Safari/6533.18.5)

    What NAS do you have? ReadyNAS firmware has been upgraded for Lion so it can be done. They only released a beta version for the Duo series but it's been fine. I delayed upgrading for a month or so

    I'm now looking at further upgrading my backup routine with an external drive to store off site.
     
  15. Lykos1986 macrumors member

    Joined:
    Jul 4, 2010
    #15
    Yes it is!!! So many crashes with Lion. A few minutes ago I just restart my MBP because Lion freeze at Safari!
     

Share This Page