Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

sniffies

macrumors 603
Original poster
Jul 31, 2005
5,688
15,720
somewhere warm, dark, and cozy
I live in a spotty location. So, Wi-Fi Calling is crucial to me. However, every time I'm on a call, iPhone for some reason decides to use cellular connection, which results in bad audio or dropped calls. One of the workarounds is to put iPhone in Airplane Mode, then make a call. That way, iPhone will be forced to use Wi-Fi Calling only.

But why do I have to use such awkward workarounds?

I tested on three different carriers, with five different iPhones, on four different iOS versions (14, 13, 12, and 11).

Is anyone else experiencing this?
 
  • Like
Reactions: macintoshmac

lordhamster

macrumors 68000
Jan 23, 2008
1,644
1,644
I live in a spotty location. So, Wi-Fi Calling is crucial to me. However, every time I'm on a call, iPhone for some reason decides to use cellular connection, which results in bad audio or dropped calls. One of the workarounds is to put iPhone in Airplane Mode, then make a call. That way, iPhone will be forced to use Wi-Fi Calling only.

But why do I have to use such awkward workarounds?

I tested on three different carriers, with five different iPhones, on four different iOS versions (14, 13, 12, and 11).

Is anyone else experiencing this?
I think it is carrier dependent. Some carriers have the wifi calling to prefer cellular while others don't I've been experimenting with different carriers this year... some even have a toggle to "Prefer Wifi" in the wifi calling settings while others don't.

That said, I find that both Visible (Verizon MVNO) and T-Mobile both glom onto wifi calling when available.

IMG_B4582B94163A-1.jpeg
 

macintoshmac

Suspended
May 13, 2010
6,089
6,992
I live in a spotty location. So, Wi-Fi Calling is crucial to me. However, every time I'm on a call, iPhone for some reason decides to use cellular connection, which results in bad audio or dropped calls. One of the workarounds is to put iPhone in Airplane Mode, then make a call. That way, iPhone will be forced to use Wi-Fi Calling only.

But why do I have to use such awkward workarounds?

I tested on three different carriers, with five different iPhones, on four different iOS versions (14, 13, 12, and 11).

Is anyone else experiencing this?

What I find is that if I have Wi-Fi Calling enabled on my iPhone 7/ 8, calls occasionally fail to go out. Incoming always works. Outgoing never fails if the phone is not on Wi-Fi Calling. I am yet to deep-dive into the details of this to figure out if this is when I make calls to a specific network or if that's a blanket issue that occasionally crops up. I blame my network provider for this right now, but it is possible that after diagnosing it I find that it is only with a certain network, at which point it would be either an agreement issue between my network and the other network or a technical issue with the other network.
 

jahall05

macrumors 6502
Jul 30, 2013
370
129
I have issues with AT&T WiFi calling. I’ve complained all the way to the top (as far as I could get) and just ended up with a “live with it”
 

bransoj

macrumors 68000
Jul 31, 2013
1,551
733
Verizon has the messages app that I believe can be used for VOIP calls.
Three in the UK used to have one but it was dropped when Wi-fi calling came along. Think O2 was the same, had an app that did it but it was dropped.
 

lordhamster

macrumors 68000
Jan 23, 2008
1,644
1,644
I live in a spotty location. So, Wi-Fi Calling is crucial to me. However, every time I'm on a call, iPhone for some reason decides to use cellular connection, which results in bad audio or dropped calls. One of the workarounds is to put iPhone in Airplane Mode, then make a call. That way, iPhone will be forced to use Wi-Fi Calling only.

But why do I have to use such awkward workarounds?

I tested on three different carriers, with five different iPhones, on four different iOS versions (14, 13, 12, and 11).

Is anyone else experiencing this?
FYI... you probably know this, but you can FORCE wifi calling while at home by switching to airplane mode with wifi on. It sucks, but it is a trick I used in the past when traveling to avoid any chance of the phone using the local cell network for calls.
 

NoGood@Usernames

macrumors regular
Dec 3, 2020
238
287
United States
I live in a spotty signal area as well, and my wife and I rely on WiFi calling too. We are on AT&T and don’t see what you are describing. All our calls and SMS/MMS are routed over WiFi and the only way to force them to use cellular (a bad idea haha) is to disconnect from WiFi. The only issue we run into is that sending MMS over WiFi calling is hit or miss. Many attempts to do so end up with a “Not Delivered!” error where we have to disconnect from WiFi and set the phone in the windowsill of our guest bedroom where we can get 1-2 bars and it’ll send.

I’m surprised that it’s happened to you across different phones and carriers. Out of curiosity, were all the phones you tried your own that you set up by restoring from backup? Have you tried to see if the behavior is the same in a phone that is reset and set up as new?
 

RealJC123

macrumors newbie
Apr 21, 2021
7
1
I live in a spotty signal area as well, and my wife and I rely on WiFi calling too. We are on AT&T and don’t see what you are describing. All our calls and SMS/MMS are routed over WiFi and the only way to force them to use cellular (a bad idea haha) is to disconnect from WiFi. The only issue we run into is that sending MMS over WiFi calling is hit or miss. Many attempts to do so end up with a “Not Delivered!” error where we have to disconnect from WiFi and set the phone in the windowsill of our guest bedroom where we can get 1-2 bars and it’ll send.

I’m surprised that it’s happened to you across different phones and carriers. Out of curiosity, were all the phones you tried your own that you set up by restoring from backup? Have you tried to see if the behavior is the same in a phone that is reset and set up as new?
Hello all. I am having a rough time with my 12 Pro since I got it in November. I can not use the phone in my home office and other areas in the house or close to the house like the drive way without it disconnecting. It appears to be an issue when I get just far enough from WiFi. I do use WiFi calling most of the time because I have weak signal in the house, but not outside. I have been through 6 months of back and forth with the carrier (AT&T) and Apple and my ISP. I have done every imaginable step, Sim change, resets, updates, new router, even a new 12 Pro etc. Apple says it’s everyone but them and everyone else says it’s an iPhone issue. My X, 11, and 11 Pro DO NOT have this issue at all. The common denominator is this 12 Pro. I see all kind of issues like this across the internet, but Apple won’t fix. This has been the worst iPhone experience I have ever had. I am on 14.4.2 and I really believe this is a phone issue not juggling between cell and WiFi well.
 

TheDetective

macrumors newbie
Sep 16, 2021
4
0
I live in a spotty location. So, Wi-Fi Calling is crucial to me. However, every time I'm on a call, iPhone for some reason decides to use cellular connection, which results in bad audio or dropped calls. One of the workarounds is to put iPhone in Airplane Mode, then make a call. That way, iPhone will be forced to use Wi-Fi Calling only.

But why do I have to use such awkward workarounds?

I tested on three different carriers, with five different iPhones, on four different iOS versions (14, 13, 12, and 11).

Is anyone else experiencing this?
I really think this is an iOS issue. It could be carrier related, but I have Visible, which is a phone service that ONLY allowed iPhones for about the first 2 years of its existence. It operates on Verizon's towers. WiFi calling has been consistently unreliable on my iPhone 8 Plus, but it works perfectly fine on my Moto G Power and Pixel 5a. It will just randomly try to switch back to cell even if I'm in the same room with my router and drop the call. As someone who makes a lot of voice calls, this has caused me to seriously consider switching back to Android.
 

macsound1

macrumors 6502a
May 17, 2007
827
855
SF Bay Area
If you know you're going to only be using Wifi calling, why not disable cellular?
I used to work 1 floor underground and I had this same issue with the iPhone 6s and 7. If cellular wasn't disabled, it would try and pickup cellular.
 

TheDetective

macrumors newbie
Sep 16, 2021
4
0
If you know you're going to only be using Wifi calling, why not disable cellular?
I used to work 1 floor underground and I had this same issue with the iPhone 6s and 7. If cellular wasn't disabled, it would try and pickup cellular.
Yes you can definitely do that but the thing is, it's ridiculous that this is still a problem on iPhones. WiFi calling is supposed to be automatic. You're not supposed to have to manually turn off your cell radio and turn it back on as needed. I have had countless dropped calls simply because the iPhone randomly decides to switch in the middle of a call and kill the call, even though you've got a strong Wi-Fi signal. I know it's possible for Wi-Fi calling to function as intended because as I mentioned in my previous post, both of my androids, the Moto G Power and Pixel 5a, have almost zero issues with Wi-Fi calling. No need to manually turn cell on or off, and if they do switch in the middle of the call they almost never drop the call.
 

macsound1

macrumors 6502a
May 17, 2007
827
855
SF Bay Area
Something I've noticed is Wifi-Calling doesn't show up if I'm on a 2.4ghz wifi, only 5ghz.
At home I have 2 separately named networks but until I had it forget the 2.4, I couldn't make wifi calls starting like 2 years ago and couldn't figure out why.
At work I designed the UniFi network to "prefer 5g" and wifi calling never stopped appearing on the same phone that didn't show it at home.

Maybe you have a unified network - 2.4 and 5ghz together and when your call fails its because the phone determined the 5ghz signal was too weak.

Just a theory.
 

TheDetective

macrumors newbie
Sep 16, 2021
4
0
Something I've noticed is Wifi-Calling doesn't show up if I'm on a 2.4ghz wifi, only 5ghz.
At home I have 2 separately named networks but until I had it forget the 2.4, I couldn't make wifi calls starting like 2 years ago and couldn't figure out why.
At work I designed the UniFi network to "prefer 5g" and wifi calling never stopped appearing on the same phone that didn't show it at home.

Maybe you have a unified network - 2.4 and 5ghz together and when your call fails its because the phone determined the 5ghz signal was too weak.

Just a theory.
My network's are separated on my router and I have the same issues regardless of whether I use 2.4 Ghz or 5 Ghz. Again, no problem with my Androids. Pretty sure this is an iOS problem.
 

jahall05

macrumors 6502
Jul 30, 2013
370
129
Most androids have a setting for Wi-Fi calling to prefer either Wi-Fi or a cellular network. iOS lacks this and I think they need to implement it.
 

TheDetective

macrumors newbie
Sep 16, 2021
4
0
Most androids have a setting for Wi-Fi calling to prefer either Wi-Fi or a cellular network. iOS lacks this and I think they need to implement it.
In my case my Androids don't seem to even have that particular option. They just do a much better job of handling the situation automatically.
 

lennyeiger

macrumors member
Jan 6, 2015
90
80
Santa Cruz, CA
This is something that needs to be fixed. I think its Apple's responsibility.... I have low cell service, usually one or two bars. When I use wi-fi calling it often takes 4 tries to make a call. If I have enough cell service, I can turn off wi-fi calling to make the call, but then I have to turn it on to keep it.... it's ridiculous. Easy to blame it on ATT, which their lousy service, but it appears that it will only make a call when there is a red dot above the bars, indicating that the microphone is on. I have a 13 Pro Max....
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.