YellowSn0w with Tmobile

Discussion in 'Jailbreaks and iOS Hacks' started by Dextor143, Jan 1, 2009.

  1. Dextor143 macrumors 6502

    Joined:
    Oct 28, 2008
    Location:
    USA
    #1
    Guys,
    Happy New Year, I am here to make it easier for the people using Tmobile and wants to software unlock their iphone 3g..Follow the steps,

    well first of all you do have to update your baseband and firmware to latest version 2.28 and 2.2 respectively,
    then

    after installing yellowsnow
    I found it to work , follow this

    go to general>setting> reset? reset all network setting
    then take the sim out (give it 1 min)
    and put it back on
    after that go to airplane mode and turn it on for 10 sec
    then turn it off.. it should work..
    if still doesn't work then just take the sim out and put it back in

    should work.... see the Tmobile sign now
     
  2. Dextor143 thread starter macrumors 6502

    Joined:
    Oct 28, 2008
    Location:
    USA
    #2
    Guys, I have Tmobile and uptill now it is working just fine.
    I have software unlocked it , edge is working fine with tzone hack as well.

    The only problem I am having is that I cant make outgoing calls. Let me know if someone has figured it out yet.

    peace!
     
  3. alejovh1 macrumors regular

    Joined:
    Apr 24, 2008
    #3
    I have tried everything for two days now and I can't get mine to work on tmobile.
    the only one time i got the tmobile logo, it just disappeared after trying to make a call.
    any suggestions?
     
  4. lavrishevo macrumors 68000

    lavrishevo

    Joined:
    Jan 9, 2007
    Location:
    NJ
    #4
    this is what finally worked for me on at&t as of now.

    1. Install BossPrefs and Yellowsn0w from Cydia

    2. Disable everything in BossPrefs

    3. Reboot your iPhone using BossPrefs

    4. Wait 1.30 min when you see lockscreen

    5. Take your sim out and insert it

    6. Wait a moment

    7. In settings turn on Fly Mode

    8. Turn off Fly Mode

    9. Your iPhone 3G should be working now!
     
  5. alejovh1 macrumors regular

    Joined:
    Apr 24, 2008
    #5
    Thanks but still not working. Will try again over the weekend or when the dev team gets more apdates. Anyone else with succes in the us using tmobile please post your findings. Thaanks
     
  6. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #6
    I have full capabilities on my iPhone. Calls, texts, internet etc. Once I got Yellowsn0w running it has worked perfectly for me in all regards .:D
     
  7. Dextor143 thread starter macrumors 6502

    Joined:
    Oct 28, 2008
    Location:
    USA
    #7
    OK, I have spent the last 2 days working solid trying to get this to work on the UK Three (3) carrier on a iPhone that was locked to o2. Follow these steps, each one is pretty important:

    1. Restore your iPhone with itunes to 2.2 firmware (if you haven’t already)

    2. Jailbreak with QuickPwn (if you haven’t already)

    3. Open installer and add the source Dev Team provided and download yellowsn0w 0.9.4 (if you haven’t already)

    4. Download BigBoss Prefs (if you haven’t already)

    5. Download Mobile Terminal (if you haven’t already)

    6. Go into Settings -> Phone -> show My Caller ID Turn this ON
    ** Although it maybe greyed out and say OFF, you can still turn it ON**

    7. Go into BigBoss Prefs and click Reboot

    8. Once phone is on, go into Terminal

    9. OK, now the timing of this next part in important.
    There are 4 lines that need to be entered. You need to type;
    - yellowsn0w –r
    - yellowsn0w –c
    - These two commands need to be entered between 2-4 seconds within each other. They way you do that is type in one of the commands (yellowsn0w –r) on the terminal screen (but don’t press enter) then if you click the top right corner (hit the battery symbol) another terminal will appear, type the second command (yellowsn0w –c) but don’t press enter. Now, hit the battery twice more and you’ll be back at the first terminal screen. Press enter, quickly press move to the second screen and press enter again. As long as “open: Resource Busy” does not appear, move to the next step, otherwise repeat the above, make sure you quick enough entering the commands.

    10. Next do the same as the above but enter these two commands:
    - yellowsn0w –r
    - yellowsn0w –l
    - Again, make sure they are entered within 2-4 seconds of each other. And AGAIN, you will know if this worked by waiting 20 seconds after you’ve entered “yellowsn0w –l” and “open: Resource Busy” does not appear. (You should also see “Searching...” where your signal should be..,”

    11. OK, nearly done, press home button to get out of terminal, go into Settings and turn on Aeroplane mode...turn it off...it’ll probably say “Searching...” again, if after another 20 seconds it’s still saying it, turn it on and off again and NOW it should find your network. **You’ll know if it’s working after this step as the “Carrier” bar will appear under WiFi.


    NOTES – I’ve done this 3 times now to my own phone, seems to require it after each reboot. And don’t worry, it never worked the first time I tried it on each of the 3 occasions. I had WiFi on, Edge on, doesn’t seem to matter, it all seems to be about the terminal commands and having your Caller ID Showing...

    OW, and BIG PROPS goes out to deli_gt who advised me through these hard times
     
  8. Dextor143 thread starter macrumors 6502

    Joined:
    Oct 28, 2008
    Location:
    USA
    #8
    Dude, I just unlocked 2 phones and one of them it is functioning 100% but the other one outgoing calls are not working...May be you should try changing your simcard..

    Please post results.
     
  9. Nicholas.C macrumors 6502a

    Joined:
    Jun 24, 2008
    #9
    I tried unlocking for Virgin UK, but with no luck, kept bring the 5 five I waited all night, and I never got any signal.
     
  10. maltje macrumors newbie

    Joined:
    Oct 19, 2006
    #10
    I tried the new release off yellowsn0w but the -l returns an error.
     
  11. maltje macrumors newbie

    Joined:
    Oct 19, 2006
    #11
    When I do yellowsn0w -l I get "illegal option --l "
    What does this mean?
     
  12. Nicholas.C macrumors 6502a

    Joined:
    Jun 24, 2008
    #12
    Followed that, and it works!!! 100% all my sims now work!

    [​IMG]

    [​IMG]
     
  13. sam10685 macrumors 68000

    sam10685

    Joined:
    Feb 2, 2006
    Location:
    Portland, OR
    #13
    I have t-mobile and want to get an iPhone REALLY REALLY bad but i don't know where i can get one that is relatively cheap and where I don't need to also buy an at&t contract and i don't know what yellowsnow is. Please help?
     
  14. MikePA macrumors 68020

    MikePA

    Joined:
    Aug 17, 2008
    #14
    Apparently, you do not want an iPhone bad enough to invest time in reading this forum. Why should anyone help you?
     
  15. revildab macrumors newbie

    Joined:
    Jun 18, 2008
  16. alejovh1 macrumors regular

    Joined:
    Apr 24, 2008
  17. sam10685 macrumors 68000

    sam10685

    Joined:
    Feb 2, 2006
    Location:
    Portland, OR
    #17
    This is why I don't post here any more. To many rude people like you. This forum doesn't tell what yellowsnow is either. It just says to download it.
     
  18. MikePA macrumors 68020

    MikePA

    Joined:
    Aug 17, 2008
    #18
    Yes, it does, because I know what it is, what it does and how to install it and I learned it here.
     
  19. bk120 macrumors newbie

    Joined:
    Jan 3, 2009
    #19
    Does anyone know if I will be able to you use pre-paid sim cards once I unlock my iphone? Thanks.
     
  20. Dextor143 thread starter macrumors 6502

    Joined:
    Oct 28, 2008
    Location:
    USA
    #20
    Dude.....Now I see Yellowsn0w 0.95.....I am having only problem with outgoing txt messaging
     
  21. TtOrMaMnY macrumors member

    Joined:
    Jun 10, 2008
    #21

    I quote above how far I only had to go before it started working.. After you type in the last two commands above in terminal then wait about 1-2 minutes.. it then will automatically pop up with Tmobile or whatever your carrier is.

    We have T-Mobile USA in Dallas, TX with a brand new sim card i got from the store today.
     
  22. The General macrumors 601

    Joined:
    Jul 7, 2006
    #22
  23. Inconsequential macrumors 68000

    Joined:
    Sep 12, 2007
    #23
    Sadly, your in the wrong here.

    I know all about yellowsn0w and I dont even have a 3G iPhone or an interest in getting one.
     
  24. uicandrew macrumors 6502a

    Joined:
    Jan 19, 2006
    #24
    unfortunately, i'd actually encourage it if you DIDN'T post. you can read, or highlight text, right-click, and select "Search Google for <blank>"

    it may sound mean, but if you are clogging up the forums expecting people to spoon feed you, when 4 easy mouse clicks can yield you an answer. it is a bit of an extreme, but what if someone was posting "what is an iphone?" every 10 posts? the thread would get much longer and finding useful information gets lost more easily.

    my 2 cents to actually CONTRIBUTE to the forums, is that keep checking the devteam's website. They have had several updates (keep in mind it is still an update).

    Since New Years, they've moved from 0.9.0 to 0.9.1 to 0.9.4 to 0.9.5

    Many revisions, many new chances to work. good luck!
     
  25. Neobond macrumors regular

    Joined:
    Feb 10, 2008
    Location:
    Minneapolis
    #25
    It seems to be working with my T-Mobile SIM and no wonky procedures, just put the SIM in and it works. It didn't work 2 days ago, but everything seems good now.

    Only thing I have noticed is that when I restart the phone I have to remove and reinsert the SIM card... I'll stick with my 2G phone until this gets fixed.
     

Share This Page