Yes another Hard Drive Question

Discussion in 'Buying Tips and Advice' started by DJMastaWes, Nov 12, 2006.

  1. DJMastaWes macrumors 65816


    Jan 14, 2006
    Montreal, Quebec
    Okay, this is my 3rd problem. So, I've figured out why it doesn't mount. I downloaded all of my files to it (40GB) and it worked fine. a day later, I added 1 file, and it wouldn't mount. I went crazy, I made a thread with no reply, I didn't know what to do. so I plugged it into a PC and it read it, and I deleted the last file I put on. I plugged it back into my mac and it worked. So, I used it for a few hours, then my friend send me a picture and I put it into the hard drive, and I restarted my computer and again... it didn't read it, so once again i plugged it into a PC, deleted the file and it works... My question is, why is this happening? and how can I fix it... without formating it.

    Any help would be great.
    Once this is fixed, I hope I won't have to make a thread about it again. I spent $200.00 andi've only had it for 3 days, and I have had to make 3 threads.

  2. bokdol macrumors 6502a


    Jul 23, 2002

    what format is your drive? is it fat 32? it seems to be if a pc an read it.also what mac are you putting it on.. is it the one in your sig? if it is i think that mac is only a usb 1.0 and if it is then that explains your slowness with the drive. i have a few usb drives. and they sort of suck.. alot of times they stall when copying a large about of data. over 10gigs. i have to drop stuff on their in batches. other then that your best bet is to reformat. sorry i know you dont want to but it might be your only option. good luck.

Share This Page