Yet another tethering problem

Discussion in 'Jailbreaks and iOS Hacks' started by kusburu, Jul 25, 2008.

  1. kusburu macrumors newbie

    Joined:
    Jul 25, 2008
    #1
    I followed the guide at http://cre.ations.net/blog/post/how-to-tether-your-iphone-3g-and-browse-the-web-using-your-3g-co, but I'm having problems with the "
    Step 6: Open Safari on the iPhone and open a web page

    Any page will do. I recommend cre.ations.net:

    This step is important. The page will take a while to load. When Safari realizes it can't get to the Internet using the ad-hoc Wifi, it will do some internal magic to switch back to 3G for Internet while still on your ad-hoc network. That lets the proxy do its thing.
    "
    When I load a page, the dialog that says "Safari can't open this page because it is not connected to the Internet" pops up, and it goes no farther than that. When I close the dialog and click refresh, the dialog pops back up.

    Help please
     
  2. riyadc macrumors member

    Joined:
    Dec 31, 2004
    #2
    Are you loading the page on your phone or your mac? You need open a page on mobile safari, using your iphone. Not on your mac.
     
  3. kusburu thread starter macrumors newbie

    Joined:
    Jul 25, 2008
    #3
    I did open the page on my iPhone. But that stupid "Safari can't open the page..." dialog shows up and stops anything from happening in the background
     
  4. riyadc macrumors member

    Joined:
    Dec 31, 2004
    #4
    And its 3G working fine when WiFi is turned off? Your iphone is trying to connect to the internet though WiFi instead of 3G for some reason.

    I'd make sure your iphone is connected to the Ad-Hoc Wireless network created by your mac and also make sure you maunally configure the wifi ip-address to something like 191.168.1.2
     
  5. kusburu thread starter macrumors newbie

    Joined:
    Jul 25, 2008
    #5
    The 3G works fine when Wifi is off. The iPhone is connected to the Ad-Hoc Wireless network created by my (Windows). I'm not sure what you mean by "manually configure the wifi ip-address to something like ..."

    How will that help?

    Thanks for your input btw
     
  6. riyadc macrumors member

    Joined:
    Dec 31, 2004
    #6
    After you're connected to the Ad-Hoc network, on your Iphone hit settings, then Wi-Fi, then tap on the Arrow next to the name of the Ad-Hoc network, tap on static, and under IP address type in 192.168.1.1

    After that make sure you step up a static ip on your windows too, for that go to Control Panel, Nextwork Connections, Right Click on Properties on the name of your wireless connection, Double click on "TCP/IP Settings" then click on "choose the follwing IP:" and type in 192.168.1.2, subnet should be 255.255.255.0 and the gateway should be 192.168.1.1 (the ip address of your phone)
     
  7. kusburu thread starter macrumors newbie

    Joined:
    Jul 25, 2008
    #7
    Tried all that, but same problem. The "internal magic" described on cre.ations.net is not happening for me...

     
  8. riyadc macrumors member

    Joined:
    Dec 31, 2004
    #8
    Hmm no idea what the problem might be, sorry.
     

Share This Page