Yikes! Dock magnification/menus/hot corners aren't working!

Discussion in 'MacBook Pro' started by kingofkolt, Jun 30, 2007.

  1. kingofkolt macrumors 6502

    Joined:
    May 2, 2007
    Location:
    Boston, MA
    #1
    Guys, I'm kinda freaked out about this. Yesterday I was using the Vista side of my 2.4Ghz 15" MBP most of the day, and then I switched over to the Mac side last night. I don't know if being in Vista for that long is what caused this -- probably not -- but I do know that I usually don't use Vista that long at once. But anyways, here's my problem:

    When I got into Mac OS X yesterday, it started getting all funky on me. First of all, my dock. When I roll my mouse over the dock, it doesn't magnify at all. I have dock magnification turned on about 1/2 of the way over, and yet it doesn't react to my mouse at all. Also, when I click on an icon to open it, it DOES magnify that icon (and the ones around it) temporarily as it "bounces" to indicate the program is opening. Then I move my mouse away, and the magnification stays there for a few seconds! So my mouse is back in the middle of the screen but the icon is still frozen as enlarged. It goes away after a few seconds, but not with the usual smooth shrinking animation (it just instantly is smaller). Lastly, the program I open from the dock does NOT come to the forefront. For example, I just opened TextEdit from the dock to remind myself of what happens, and it opened behind Firefox, not in front of it. So to actually go get TextEdit, I have to Command+Tab and get it. So those are my dock problems.

    Also, my menus are acting funny. You know how, usually, when you open a menu from the bar at the top of your screen (sorry, not sure what it's called, I haven't been a Mac user for long), and you move your mouse over the options, each individual option highlights in blue? And when you move your mouse over an option that has an arrow to its right to indicate a sub-menu, the sub-menu pops out on its own? Well, neither of those are happening anymore. In fact, when I click the option that has an arrow, the whole menu just goes away as if I had clicked away from it or something.

    Lastly, my hot corners aren't working. Simple as that. I have bottom left set for Dashboard, and bottom right for Expose, and neither respond at all.

    To recap: a lot of the very basic functions I rely on in the Mac OS X side of my computer just stopped working for me and I have absolutely no idea why. And as a side note, I had not downloaded the MacBook Pro Software Update before this started happening. When it started, I immediately downloaded the update but it didn't fix it.

    Help!! :(
     
  2. CrzyCanuck72 macrumors 6502a

    Joined:
    Jun 10, 2003
    #2
    I've been having a lot of your issues lately as well, specifically the dock magnification and menus problems. I narrowed the cause down to my wireless mouse - some combination of waking my MB from sleep and plugging in the USB dongle causes those problems.

    I don't know if that's of any use to you... but at least you're not the only one dealing with those annoyances!
     
  3. kingofkolt thread starter macrumors 6502

    Joined:
    May 2, 2007
    Location:
    Boston, MA
    #3
    Oh. My. God. I just unplugged my wireless mouse (not the Apple Mighty Mouse) and everything works now. Plugged it back in and it still works. Maybe I'll have to unplug and re-plug my mouse every time I restart Mac OS X? Very weird... Geez, I could buy you an iPhone right now... Thanks!!! :D This is a big load off my chest.
     
  4. CrzyCanuck72 macrumors 6502a

    Joined:
    Jun 10, 2003
    #4
    I grudgingly accept your offer


    lol glad I could help - it definitely freaked me out when it started happening (2 months after I started using that mouse) as well
     

Share This Page