Yosemite 10.10.2 WiFi network not found on Wake Up

Discussion in 'OS X Yosemite (10.10)' started by codeoverride, Jan 31, 2015.

  1. codeoverride macrumors member

    Joined:
    Jun 26, 2008
    #1
    Everything was fine until I updated to 10.10.2 now there have been several times when I wake up my iMac from sleep and it does not find my wifi network or has to search for it for a long time. I'm using time capsule. Before everything was fine. Anyone else experiencing this?
     
  2. jlusk99 macrumors member

    Joined:
    Apr 17, 2013
    #2
    I was having this issue when originally upgrading to Yosemite. 10.10.1 fixed this for me, now IT IS BROKE AGAIN thanks to 10.10.2. Why is it so difficult for Apple to fix Wifi issues? Seems like they really need to simplify the power saving features because that screws things up for a lot of people.
     
  3. Marbles1 macrumors member

    Joined:
    Nov 27, 2011
    #3
    Exact same problem here.

    I had to remove all references to my wifi network in key chain.

    Try to connect to another network.

    Retart the machine.

    Try 4-5 times to connect; and then it finally worked.

    It seems to be beyond the skills of the current OS X team to iron out these bugs.
     
  4. iBlazed macrumors 68000

    iBlazed

    Joined:
    Feb 27, 2014
    Location:
    New Jersey, United States
    #4
    This happens to me every single time I wake my Macbook Air after the 10.10.2 update. Honestly my patience with Apple is decreasing by the minute at this point.
     
  5. Redsfan macrumors regular

    Joined:
    Oct 26, 2012
    Location:
    Greater Toronto Area
    #5
    does it often since original Yosemite on my MBP..have to turn wi-fi off, back on and it works..didn't think there would be all these little annoyances
     
  6. Sheza macrumors 65816

    Sheza

    Joined:
    Aug 14, 2010
    Location:
    Croydon & London At The Same Time
    #6
    Similar-ish problem here. Often the WiFi connects but with a 'self assigned IP address that cannot connect to the internet' according to the network preferences window, so the icon still looks like it's trying to connect.

    Usually turning WiFi on and off again solves the problem. It's annoying though because my iPhone and iPad don't suffer this problem at all.

    Wish there was a small background app that could toggle the WiFi on and off automatically if it gets into difficulty.
     
  7. dav1dd macrumors regular

    dav1dd

    Joined:
    Oct 25, 2013
    Location:
    Oz
    #7
    I had this problem when I was on 10.10.2 (for a day). Rolled back using Time Machine. There are plenty of people out there singing that they have no problems but I think this goes deeper than just OSX. It is also hardware related. I have late 2013 MBPr 15" and I think the wifi is dodge. Even on 10.10.1 it goes real slow sometimes, for no reason. On 10.10.2 it was straight up crippled - as soon as the page was at the point where it would be loaded the wifi would just start re-scanning and then return a no-IP address problem. It was a fiasco while it lasted. I gave up and rolled back to 10.10.1.

    Not that it would be worth taking my machine back - they just f'd up the parts chain. It's kind of like the yellow screen issue. I have a slight tinge in one part but don't bother taking it back because the new one would have it too. QC is shot to ***** now that Apple are big shots.

    Queue the white knights... :rolleyes:
     
  8. mrwatson.de macrumors newbie

    Joined:
    Feb 3, 2015
    #8
    On Wakeup wifi is frozen, apps freeze, after restart it is even worse

    I have at last updated to Yosemite - straight in at 10.10.2. Everything was fine until I closed my laptop and moved from my home to my office (other network) and reopened the laptop => BANG! Chaos!

    • The wifi icon is frozen in it's previous state.
    • Everything that seems to need the internet freezes up.
    • The CPU is cyclicly peaking.
    • Everything is slow - although the CPU does not seem to be under great pressure.

    To restart the computer I need to shoot down one app after the other.

    • Restart takes unusually long (Apple logo + progress bar)
    • After restart the wifi symbol is grey and has a little x in it.
    • The spotlight symbol is missing.

    Furthermore I have app-troubles:

    System preferences hangs after reopening so I had to force quit it - then start it again. A dialog gives the possibility to not reopen the windows, which I click. Nothing appears to happen, so I start system preferences again, and this time it opens normally.

    • Changing to the Network panel I am presented with an empty wlan list
    • and the message "No services in this location…" ... great! ...
    • oh and a spinning ball.

    I want to start a process analysis, but spotlight is missing and - although I can change to finder with Command+Tab System preferences does not let go of the menu bar and I cannot use Finder.

    I have to force quit system preferences.

    I relaunch Finder ... takes a while, but is still not usable, because now Stickies has got hold of the menu bar. Then I realise I CAN start the activity monitor from the apple menu recent items, and do this.

    • The CPU is still showing cyclic peaks - about every 45 seconds.

    I open the console log, which at last provides some evidence of the source of the problem.

    • configd is bombarding the log (something like): configd: <0x7fcab0d097f0> target 0x7fcab0d097f0 watcher not added, c=0x7fcab0d097f0, "serverWatchers" key exists
    • configd is crashing and being respawned every 10 seconds.
    • Further log entries show problems in processes that need the network: from cloudd, bird, ApplePushService, com.apple.iCloudHelper, digest-service, com.apple.xpc.launchd

    It has happened twice now. Yesterday I restarted in Safe mode and turned many (but not all) icloud services off. After restarting the laptop seemed to have cured itself.

    Today I have just had exactly the same problem. :mad:

    • HELP! Does anybody know if this is a known Problem?
    • Any suggestions?
    • I can't spend two hours everyday getting my laptop working every time it goes to sleep!
    Thanking you all in advance

    Russell Watson
     
  9. mrwatson.de macrumors newbie

    Joined:
    Feb 3, 2015
    #9
    Some workarounds - maybe

    Turn the wlan off before you put the computer to sleep seems to help.

    Restarting the computer in safe mode

    • everything works ok
    • I could connect to WLAN
    • I could connect internet by cable

    Restarting the computer normally

    • Still has problems when I connect to the office by cable
    • Connecting by WLAN seems to be ok now

    Strange, strange, strange - and SCARY!
     
  10. AndreSt macrumors member

    Joined:
    Mar 4, 2014
    #10
    Indeed! Amateurs at work. Or just the lack of engineers or even technicians in management. Who knows?
     
  11. adamhenry macrumors 65816

    adamhenry

    Joined:
    Jan 1, 2015
    Location:
    On the Beach
    #11
    When I turn on my MBP, I have no wifi connection. Network preferences has nothing listed in the Network name box but my network is in the network list that drops down. When I select my network, the connection is immediate. I can also connect by toggling the wifi off then on. Once connected, I have no further problems.
     
  12. jonywalker macrumors newbie

    Joined:
    Oct 14, 2014
    #12
    My MBP has also wlan problem since the update to 10.10.2. It is not only by startup, but also during the session. Sometimes it helps if I turn off the connection and then turn on it again. Sometimes i have to reboot it. There was no problem before.
    It seems the 10.10.2 fixed the wlan bugs for some routers, but introduced new bugs for other routers.
     
  13. adamhenry macrumors 65816

    adamhenry

    Joined:
    Jan 1, 2015
    Location:
    On the Beach
    #13
    My problem seems better. I haven't seen it in a few weeks.
     

Share This Page