Yosemite 10.10.4 battery drain & animation lag

Discussion in 'OS X Yosemite (10.10)' started by hemoali, Jul 7, 2015.

  1. hemoali macrumors newbie

    hemoali

    Joined:
    Jul 7, 2015
    #1
    Hi, I just bought my new macbook pro 15 inch (the newest one) 6 days ago
    the battery was great but after upgrading to yosemite 10.10.4 the battery is draining really fast (like 1% per 2 minutes) without running any heavy avtivity (like android studio or xcode or netbeans!!



    So does anybody have a suggestion for this issue?



    BTW I face some uncomfortable lags when I'm in full screen and moves the cursor to the top edge of the screen, the top bar slides down with animation but it's laggy.



    Thanks and hope to find solutions for both problems .


    MacBook Pro (Retina, 15-inch, Mid 2015), OS X Yosemite (10.10.4)
     
  2. tampageek macrumors 6502

    tampageek

    Joined:
    Jul 1, 2015
    Location:
    Florida, USA
    #2
    Same problem here on a late 2014 retina MBP 13 purchased new in Jan. I don't know what the issue is. I tried resetting the SMC and PRAM, rebooting, reinstalling and standing on my head. I would expect this from a Microsoft update but not from Apple - unless Apple is content with being called worse than MS when it comes to updates that break the computer.

    You could try reset maybe you'll have better luck than i did.
    https://support.apple.com/en-us/HT201295
     
  3. jonywalker, Jul 18, 2015
    Last edited: Jul 18, 2015

    jonywalker macrumors newbie

    Joined:
    Oct 14, 2014
    #3
    I have to report the same issue , my mac pro 15" is getting hot after upgraded to 10.10.4, and battery consumption is getting notably higher! Hope apple will release 10.10.5 to fix this big problem!
     
  4. Toutou macrumors 6502a

    Toutou

    Joined:
    Jan 6, 2015
    Location:
    Prague, Czech Republic
    #4
    My late 2013 13" rMBP's idle temps have raised by 5°C (I monitor them very closely) and the battery seems to be draining a bit faster. :(
     
  5. tampageek macrumors 6502

    tampageek

    Joined:
    Jul 1, 2015
    Location:
    Florida, USA
    #5
    I ended up having to do a clean install. That solved the problem.
     
  6. jonywalker macrumors newbie

    Joined:
    Oct 14, 2014
    #6
    Clean install, how?
    I just read a report from other forum that someone tested 10.10.5 beta, and this problem is solved.
     
  7. tampageek macrumors 6502

    tampageek

    Joined:
    Jul 1, 2015
    Location:
    Florida, USA
    #7
    you can download a fresh copy of Yosemite 10.10.4 here https://support.apple.com/kb/DL1819?locale=en_GB
    if you don't want to wait a few months for El Cap final or run a beta
     
  8. kayleee macrumors regular

    Joined:
    Nov 20, 2013
    #8
    Thats me, its super smooth and macbook is runs cool as ever, no heating and after 20-21 tabs open on safari hardly any memory consumption, but at the same time results might vary for others, simply because I think heating issue was not there for all macs on 10.10.4 either.
     
  9. ABC5S macrumors 68040

    ABC5S

    Joined:
    Sep 10, 2013
    Location:
    Florida
    #9
    10.10.4, and now 10.5 beta with no heating issues nor battery issues as well. Spec's below
     

Share This Page