Yosemite 10.10 and Java 8 problem

Discussion in 'OS X Yosemite (10.10)' started by mreg376, Oct 18, 2014.

  1. mreg376 macrumors 6502a

    Joined:
    Mar 23, 2008
    Location:
    Brooklyn, NY
    #1
    I have installed Java 8 update 20, Java 8 update 25, and even found Java 8 update 40, on my newly upgraded Yosemite 10.10 system (from 10.9.5). Everything is pretty much working perfectly, except I keep getting a message in the middle of the screen telling me something like "the web content you are trying to view needs Java installed," and asking me to go to Oracle for more info or click OK. I'm not even sure what content it is referring to.

    Can someone tell why I am getting this?
    Thanks!
     
  2. chris9771 macrumors newbie

    Joined:
    May 22, 2012
    #2
    Same here, not even sure which app is trying to use it. All i have open are Chrome and Mac mail.
     
  3. mreg376 thread starter macrumors 6502a

    Joined:
    Mar 23, 2008
    Location:
    Brooklyn, NY
    #3
    Based on advice on a similar thread installation of the Java 8 SDK (instead of the SRE) solved it.
     
  4. jacbec macrumors newbie

    Joined:
    Feb 16, 2013
    #4
    Same problem after installing jre-8u25-macosx-x64-2.
     
  5. mreg376 thread starter macrumors 6502a

    Joined:
    Mar 23, 2008
    Location:
    Brooklyn, NY
    #5
    Install the JDE instead of the JRE. That solves it.
     
  6. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #6
    I think you mean JDK yes?

    Go to Terminal and type in the line below and enter then you will get a popup about Java. Click the more info button to go the Java download page and select the JDK to DL and install.

    Code:
    java -version
    [​IMG]
     
  7. mreg376 thread starter macrumors 6502a

    Joined:
    Mar 23, 2008
    Location:
    Brooklyn, NY
    #7
    Yes, sorry. JDK.
     
  8. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #8
    Meh.... not to worry. This entire Java business is confusing as all get out! :)
     
  9. NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #9
    Odd.

    The JRE (b17: 1.8.25.17) works for me. With JDK being 400+GB, that's a last ditch solution, IMO.

    /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Info.plist to see what version of the plugin you are running.

    Only thing I can think of is maybe remnants of Apples of v6 Java is still sitting on disk?

    But, whatever gets folks up-and-running again.
     
  10. Sandman619 macrumors newbie

    Sandman619

    Joined:
    Aug 7, 2007
    Location:
    San Diego, CA
    #10
    There is a problem for some users when the 8.25 is installed. Not sure which party is responsible but here are 2 suggestions:

    Remove the following file: com.oracle.java.Java-Updater.plist
    Goto: /Library/LaunchAgents/com.oracle.java.Java-Updater.plist
    This is the Library folder outside of the System folder

    Or try this:
    http://support.apple.com/kb/DL1572?viewlocale=en_US&locale=en_US

    This is an older version of Java, which somehow works still. Then hopefully a system update or Java update will fix this issue.

    Cheers !




     

Share This Page