Yosemite Beta 3 and Apple Magic Trackpad (Bluetooth Issues)

Discussion in 'OS X Yosemite (10.10)' started by victorhooi, Sep 28, 2014.

  1. victorhooi macrumors member

    Joined:
    Mar 29, 2011
    #1
    Hi,

    I have a MBP 13", running OSX Yosemite (10.10) Beta 3.

    I'm trying to pair a Apple Magic Trackpad, and the bluetooth connection seems to be seriously patchy.

    Previously, I was able to get it to pair after many attempts. However, after around 15 minutes, OSX said "Connection Lost" for the trackpad.

    I removed it, and tried to pair it again. After a while, same message ("Connection Lost") again.

    Now, it doesn't seem to be pairing at all. It appears, but if you click Pair, it just sits in Connecting for a while.

    Is anybody else away of major issues with Yosemite and Bluetooth trackpads at the moment?

    Any known workarounds?

    Cheers,
    Victor
     
  2. awests macrumors regular

    Joined:
    Jul 24, 2014
    Location:
    Bay Area, CA
    #2
    Also on PB 3, haven't had any issues with any Apple bluetooth devices (keyboard, mouse, trackpad).

    Have you tried changing the batteries?
     
  3. verdi1987 macrumors regular

    Joined:
    Jun 19, 2010
    #3
    Starting with beta 3 and continuing with beta 4, my Magic Trackpad repeatedly disconnects from my 2012 Retina MBP. I have re-paired the trackpad and did a PRAM reset to no avail. I filed a bug report with Apple following beta 3.
     
  4. Freddio macrumors newbie

    Joined:
    Oct 17, 2014
    #4
    Yosemite / Magic Mouse still broken in GA release

    Just installed the Official Yosemite release and my magic mouse doesn't work. When it DOES connect it is lethargic and unusable, but most times the MacBookPro just loses connection to it and then it cant see it! :mad:
     
  5. Elho macrumors regular

    Joined:
    Oct 22, 2013
    Location:
    Belgium
    #5
    Urgh same issues here!! Official yosemite download on a i7 Mac mini, very lousy magic mouse and wireless keyboard connection! :-S
     

Share This Page