Yosemite Blank Screen Issue

Discussion in 'OS X Yosemite (10.10)' started by That-Guy, Oct 8, 2014.

  1. That-Guy macrumors 6502a

    That-Guy

    Joined:
    Feb 25, 2012
    Location:
    UK
    #1
    I'm having a really strange issue with Yosemite GM Candidate 1 and my Mac Mini. I leave the Mini on 24/7 and just turn the monitor off when not in use. But if I leave it a few hours and come back to it the monitor gets no signal when I turn it back on. I click the mouse or press a button on the keyboard but it makes no difference the only fix is to turn the machine off and back on again.

    What makes the above more strange is I have already disabled the following:

    - Sleep
    - Monitor Sleep
    - Hard Drive Sleep
    - Screen Saver

    The only problems I have come across is a few permission errors:


    Code:
    Group differs on “Library/Printers/InstalledPrinters.plist”; should be 80; group is 0.
    Permissions differ on “Library/Printers/InstalledPrinters.plist”; should be -rw-rw-rw- ; they are -rw-r--r-- .
    User differs on “private/var/db/displaypolicyd”; should be 0; user is 244.
    Group differs on “private/var/db/displaypolicyd”; should be 0; group is 244.
    I am wondering if the displaypolicyd permission error could be the cause of my issues, but when I fix the error it re-appears after a restart :(

    Any ideas, fixes or suggestions?

    I don't really want to do another fresh install if I can help it. This problem never occurred on Mavericks either.
     
  2. That-Guy thread starter macrumors 6502a

    That-Guy

    Joined:
    Feb 25, 2012
    Location:
    UK
    #2
    Updated to GM v2 and still have the issue, but the amount of errors with permissions has shrunk slightly to:

    Code:
    User differs on “private/var/db/displaypolicyd”; should be 0; user is 244.
    Group differs on “private/var/db/displaypolicyd”; should be 0; group is 244.
    
    Which is still showing the displaypolicyd permission error which I am guessing is causing the problem :(
     
  3. That-Guy thread starter macrumors 6502a

    That-Guy

    Joined:
    Feb 25, 2012
    Location:
    UK
    #3
    Just done a fresh install of Yosemite using the public release version and still getting the following permission problems:

    Code:
    User differs on “private/var/db/displaypolicyd”; should be 0; user is 244.
    Group differs on “private/var/db/displaypolicyd”; should be 0; group is 244.
    Can anyone just check if they are getting this error?

    Thanks
     
  4. myuserid08 macrumors 6502

    Joined:
    Mar 15, 2008
    #4
    I've got the same permissions on a fresh install today.
    Nothing to worry about I presume!
     
  5. That-Guy thread starter macrumors 6502a

    That-Guy

    Joined:
    Feb 25, 2012
    Location:
    UK
    #5
    That makes me feel a little better.

    I just hope this fresh install fixes the problem with my monitor being blank when turning it back on.
     
  6. kaans macrumors member

    kaans

    Joined:
    Nov 17, 2014
    #6
    When I first bought my macbook, it almost froze during setup, I really wish I did a fresh install at that moment, I concentrated too much on hardware issues but it seems to be a software issue (I hope?)

    Here is a related thread

    Whatever it is, it causes the Dock to behave erratically, it also caused the monitors to sleep and wake momentarily for no reason once

    Any updates on your issues?
     

Share This Page