Yosemite breaks AirPlay to AppleTV

Discussion in 'OS X Yosemite (10.10)' started by TheRealTVGuy, Oct 18, 2014.

  1. TheRealTVGuy macrumors 6502a

    TheRealTVGuy

    Joined:
    Jul 21, 2010
    Location:
    Orlando, FL
    #1
    We're running a 13-inch, early 2014 MacBook Air and a current-gen AppleTV.

    After upgrading to Yosemite Thursday night AirPlay mirroring and streaming to the AppleTV seems to be goofed up. We'll get picture on the tv, but no sound on either the TV or the MacBook. Sometimes AirPlay will auto-connect to the AppleTV and refuse to disconnect, making testing extremely difficult, and, again leaving us with no audio. Even after rebooting.

    I've gone through and worked with the sound settings through System Preferences, but to no avail.

    Are we the only ones experiencing this? Is this a known-issue, or do I need to report it to Apple?
     
  2. \-V-/, Oct 20, 2014
    Last edited: Oct 20, 2014

    \-V-/ Suspended

    \-V-/

    Joined:
    May 3, 2012
    #2
    There's also some planned obsolescence at work. They dropped support for 2010 MBPs ... of which I have two. I cannot begin to explain how much that pisses me off. I was mirroring my display flawlessly not even two months ago before I updated my AppleTV. It hasn't worked ever since and didn't know why, but now I do. Fortunately my 2011 iMac still functions with AirPlay.

    At the very least, I still have third party apps like Beamer which still allow me to push movies to the ATV. :/

    Here's the new minimum requirements:

    iMac (Mid 2011 or newer)
    Mac mini (Mid 2011 or newer)
    MacBook Air (Mid 2011 or newer)
    MacBook Pro (Early 2011 or newer)
    Mac Pro (Late 2013 or newer)


    Thanks Apple ... for pushing me further away from your hardware. I'm pretty much exclusively building Hackintoshes from now on. They're not getting another dime from me for their Mac hardware ... which they support for 5 minutes.
     
  3. tbn002 macrumors newbie

    Joined:
    Jul 10, 2011
    #3
    I'm having issues with airplay mirroring from my retina MBP (late 2014) to Apple TV (gen 3) since upgrading to yosemite as well. Its very choppy and stutters, but didn't with Mavericks. However, using airplay to stream movies from iTunes works very smoothly. I hate having to convert files (.mkv) into iTunes compatible formats (mp4) to make it work.
     
  4. mercuryjones macrumors 6502a

    Joined:
    May 31, 2005
    Location:
    College Station, TX
    #4
    TIL 5 years equals 5 minutes.
    Seriously, a 2010 Macbook can't be expected to be supported forever. Why they did this, I don't know and neither do you. You feel slighted by it, but it is what it is.
    Go ahead and build your Hackintoshes and then see what kind of support you get then.
     
  5. \-V-/ Suspended

    \-V-/

    Joined:
    May 3, 2012
    #5
    My Hackintosh works fine. In fact, mine still works with AirPlay.

    And support? Seriously? If I wanted Apple support, I wouldn't have built a Hackintosh. That's not even a valid argument. All the "support" I need is myself, because I can self-diagnose most of the issues internally and parts are easily replaceable with little downtime.

    I'm not sure why you're on Apple's side here. Did you not see the minimum requirements for the Mac Pro? Late 2013 and newer. Do you not think a Mac Pro that's a few years old can handle AirPlay? You can't possibly be seriously supporting this.

    And yes, I do know the reason ... and so do you. Planned obsolescence ... Apple forces you into purchasing new hardware by arbitrarily discontinuing support for hardware that's full capable of doing what Apple claims it can't. This isn't a hard concept to grasp. They've been doing this for ages now.
     
  6. ronswansonbaby macrumors newbie

    Joined:
    Oct 2, 2014
    #6
    Anyone have an update on this? I still don't have an airplay option on my 2013 MBA running Yosemite or my iPhone 5 running 8.0.2.
     
  7. netslacker macrumors 6502

    Joined:
    Jan 21, 2008
    #7
    A possible hint:

    Just curious, but have any of you restarted your wifi router or airplay devices? After I upgraded to Yosemite and iOS 8 all but one of my airplay devices showed up (I have several) but after a restart of the wifi router all of them returned. I did fight with it for a few days before trying the router restart which cleared whatever issue I was having. Other's have reported restarting the devices to get them back as well. Not sure if this will work for you but perhaps something to try.

    Cheers!
     
  8. twintin, Oct 28, 2014
    Last edited: Nov 3, 2014

    twintin macrumors 6502

    Joined:
    Aug 10, 2012
    Location:
    Sweden
    #8
    I have iOS 8.1 on my iPad Air and Yosemite on my MBA 2012 and face no such issue. Had no such issue with iOS 8.0.2 either when I had it.

    Not sure what the issue may be with your configuration. Have you tried to restart your devices and router as suggested above ?
     
  9. Laserducky macrumors regular

    Laserducky

    Joined:
    Dec 29, 2013
    #9
    1.) Update your ATV
    2.) Restart your router
    3.) Restart your MBA and iPhone
    4.) Check whether Airplay is enabled in your ATV.

    Try and see. Yosemite and Airplay should work together.

    Cheers !
     
  10. ronswansonbaby macrumors newbie

    Joined:
    Oct 2, 2014
    #10
    Haven't tried restarting the router. Everything else has been restarted and updated. I didn't think this would be a router issue, but I'll try that when I go home for lunch.

    ----------

    Thanks for the router tip. Trying it when I get home.
     
  11. ronswansonbaby macrumors newbie

    Joined:
    Oct 2, 2014
    #11
    Well I got home and restarted the router. That didn't do anything so I reset it. I have reset before but I never had this happen: it still showed it was transmitting a wireless signal, but none of my devices were picking it up. I had to connect my old Dell laptop to my router via ethernet because my MBA doesn't have a ethernet port. After connecting the old Dell, I had to re-download the software for the linksys E1000 router setup and start over from scratch renaming the router and setting up a password. Got that fixed finally after waiting for the Dell to install updates... :mad:... and when I got wifi working again, the airplay symbol showed up on my phone and MBA. Never had that problem before iOS 8. Just another bug they let slip by.

    Thanks for the tips!
     
  12. Laserducky macrumors regular

    Laserducky

    Joined:
    Dec 29, 2013
    #12
    Great to know that all's sorted !!!

    Sometimes, I have issues with Airplay so I generally restart my phone, imac or restart(not unplug) my ATV.

    Cheers !
     

Share This Page