Yosemite Calendar Info Panel on "wrong" screen

Discussion in 'Mac Apps and Mac App Store' started by Mactabulous, Oct 29, 2014.

  1. Mactabulous macrumors member

    Joined:
    Dec 23, 2011
    #1
    I'm using an MBA connected to a TBD. I run my Calendar app in full screen mode on the MBA screen. However, when double-clicking to edit or when adding new events to the calendar, the info pop-up is presented on the very left portion of my secondary screen (i.e. the TBD), instead of on the primary display where the Calendar app is actually displayed.

    Is there any way to make the info pop-up stay on the same display? Dragging the pop-up back to the primary screen and then closing it (hoping it will show up there next time), does not work. It keeps popping up in the very left hand portion of my secondary screen (relative to the Calendar app).

    This is so annoying. I have to spend time mousing over to my other screen to edit the information there, rather than having it pop up on top of the Calendar, which is the way it should be, in my humble opinion.

    Any help would be greatly appreciated, thanks!
     

    Attached Files:

  2. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    Not in Yosemite here but in Mavericks there's a preference (in Calendar>Preferences>Advanced) to check or uncheck..."Open events in separate windows". Is yours checked?
     
  3. Mactabulous thread starter macrumors member

    Joined:
    Dec 23, 2011
    #3
    Eureka! Thanks a bunch! Still, it's idiotic that the info panel pops up on any other screen than the one where Calendar currently resides. However, unticking the box fixed it! Thanks again!
     

Share This Page