Yosemite - Calendar not syncing Microsoft Exchange!

Discussion in 'OS X Yosemite (10.10)' started by elcidroyale, Oct 23, 2014.

  1. elcidroyale macrumors newbie

    Joined:
    Aug 25, 2014
    #1
    Something broke in Yosemite. I have an office 365 account set up on my Mac. Email is working fine but in MAc calendar, not all appointments sync. Then I see a little triangle with an exclamation point in it next to the name of this account. I have deleted and readded the account and still an issue. Help!
     
  2. Ralphalph macrumors member

    Ralphalph

    Joined:
    Mar 7, 2009
    #2
    I'm having the exact same problem with Office 365/Ecchange online. I tried removing and restoring the account, but now Mail.app fails to sync any of my older e-mails. I've had to resort to using Outlook 2011! Please fix this, Apple!
     
  3. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #3
    no problems at all here syncing to my Office 365 account with either mail or calendar
     
  4. sahnert macrumors 6502

    Joined:
    Oct 20, 2003
    Location:
    Seattle
    #4
    I had this same issue and was able to resolve it. I found that the server settings in Calendar did not match the settings in Mail.

    Specifically, go to Mail > Preferences > Accounts and look for the "internal server" for the exchange account and copy it.

    Then go to Calendar > Preferences > accounts and look for the "internal server" for the exchange account and paste the server from Mail.

    In my case Calendar was trying to use "m.outlook.com" as the server and and after I replaced with the server from Mail that had a more specific name, the Calendar started syncing again.
     
  5. Ralphalph macrumors member

    Ralphalph

    Joined:
    Mar 7, 2009
    #5
    Thanks for the reply.

    Unfortunately on my Mac the internal server and external server appear to be correctly set to outlook.office365.com for both mail.app and calendar.app and the error persists.
     
  6. Ralphalph macrumors member

    Ralphalph

    Joined:
    Mar 7, 2009
    #6
  7. elcidroyale thread starter macrumors newbie

    Joined:
    Aug 25, 2014
    #7
    Thanks for all your posts, people!

    Unfortunately NONE of them worked :/
     
  8. baummer macrumors 6502a

    Joined:
    Jan 18, 2005
    Location:
    Southern California
    #8
    I had the same problem. I fixed it by removing the account and then adding it again. That seemed to fix things and after a few minutes everything was up to date.
     
  9. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #9
    Yep, I needed to remove and re-add the Exchange account too...
     
  10. Ralphalph macrumors member

    Ralphalph

    Joined:
    Mar 7, 2009
    #10
    I removed and re-added the account this fixed the problem for a time, but it then returned. Screw it, the new Outlook app is actually pretty legit if you are an Office 365 subscriber.
     
  11. rbr747 macrumors newbie

    Joined:
    Jul 12, 2012
    #11
    Still broken

    Unfortunately switching the account off and on again didn't work. And I couldn't find the Cache file for TimeZones - although I do suspect that time zones are part of the problem.

    The main issue (Calendar.app not syncing with Exchange) started when I switched time zones on - I have now switched it off but that doesn't help.

    I also upgraded to Yosemite recently and I'm pretty sure that's when calendar invites received through Mail.app started behaving oddly - beforehand I would just click Accept and the email disappeared. Now nothing seems to happen.

    I have just installed the latest Outlook for Mac, which looks quite nice, but as far as I can tell there is a basic #fail in the UI - no swipe in the Calendar. If you want to change weeks or months you have to mouse click the left/right buttons in the banner. I'm simply not going to do that. Calendar.app lets you move really fast with two-finger swipes on the trackpad.

    So I'm still very keen to get Calendar.app working!

    Any other ideas?
     
  12. petonic macrumors newbie

    Joined:
    Apr 21, 2010
    #12
    Solution

    This situation was maddening to me, too, but the solution pointed to by the following link really works. Read on, and I posted some comments there and included a brain dead shellscript that can be used anytime to reset the cache.

    Best of luck to you. I know this problem is infuriating.

    https://discussions.apple.com/thread/6619760?start=15&tstart=0
     
  13. trevorbsmith macrumors member

    Joined:
    Dec 17, 2007
    #13
    I had the same problem recently.

    After lots of talk with tech support, we discovered that I had a recurring event set in my exchange calendar (not sure if I set it on my Mac or on a Windows machine) for the 3rd Wednesday every month, all day.

    We deleted it.

    Boom, problem solved.

    tl;dr version: delete your recurring, all day events.
     
  14. the clover macrumors newbie

    Joined:
    Jan 28, 2015
    #14
    Exchange events not showing on Mac Calendar--Problem solved!

    That fixed the problem for me too! I had a recurring event that I created on my Exchange calendar a while back. As soon as I deleted it, all of my other events that were setup by coworkers on our company Exchange server :)immediately popped up. Thank you very much Trevor!
     
  15. Lershac macrumors regular

    Joined:
    Feb 21, 2008
    Location:
    Baton Rouge, LA USA
    #15
    Thats not really a solution

    I have many recurring all day events... how is it ok to have to delete these?
     
  16. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #16
    Its offered as a workaround.

    If you have many and you are concerned perhaps you could copy the events to a different calendar, delete them from exchange, then copy them back.

    Again this is just a suggestion....
     
  17. sixxmum macrumors 6502a

    sixxmum

    Joined:
    Aug 15, 2010
    #17
    Anyone else have any ideas? I tried to delete all my recurring items etc. No dice. My Macbook says it is refreshed, but appointments I add on my other devices aren't syncing to the macbook (though they sync to each other) or the reverse. The only thing that catches it up is removing the account entirely and putting it back, and that works until the next change.
     
  18. alecksbigbag macrumors newbie

    Joined:
    Apr 14, 2015
    #18
    "/" is different than "\" !

    I have experienced the same annoying issue (triangle with question mark and dialog box with the server sync error) for few days on OS X Yosemite.

    I solved the issue by going to Calendar -> Preferences... -> Server Setting (tab)
    and changing

    Internal Server: server.name.eu
    Server Path: /EWS/Exchange.asmx

    to

    Internal Server: server.name.eu
    Server Path: \EWS\Exchange.asmx

    Once I type the server path with Windows style backslash "\", the information changed to

    Internal Server: server.name.eu\EWS\Exchange.asmx
    Server Path: /

    and since then I do not get the server sync error anymore.
    I did the same for the External server path. Hope this helps!
     
  19. Computing4girls macrumors newbie

    Joined:
    Jun 11, 2015
    #19

    Genius solution, thank you!
     
  20. Nickleics macrumors newbie

    Joined:
    Jun 26, 2015
    #20
    Yes! Finally, a solution for this amazingly frustrating problem. Thank you so much!
     
  21. anp27 macrumors regular

    Joined:
    Jan 17, 2011
    Location:
    Brooklyn, NY
    #21
    This fixed my Google/Calendar issues.
     
  22. ericworships macrumors newbie

    ericworships

    Joined:
    Nov 24, 2015
    #22
    That worked! Thanks!
     

Share This Page