Yosemite Hangs on shutdown

Discussion in 'OS X Yosemite (10.10)' started by maviso5, Dec 29, 2014.

  1. maviso5 macrumors regular

    Joined:
    Mar 25, 2009
    Location:
    Kent
    #1
    Hi,

    I'm hoping someone can help, I've been running OS X Yosemite since it came out, one problem that persists is that my iMac 27" (late 2013) hangs on shutdown. The dock disappears like normal, it goes to the black screen then I have a spinning wheel which can last for a good 1-2 minutes (feels like forever).

    Things I've tried so far:

    Reset NVRAM
    Clean install of Yosemite
    Install 10.10.2 beta

    None of the above have fixed the issue.

    Machine is: 3.2Ghz i5, 8gb RAM, 256GB Flash

    Any advice or tips much appreciated.

    Thanks in advance
     
  2. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #2
    I have noticed the same thing, albeit it doesn't happen every time. I chalked it up to either my slow stock HDD, an app or process getting hung up, or Yosemite itself. I don't recall this happening before the 10.1 update.
     
  3. maviso5 thread starter macrumors regular

    Joined:
    Mar 25, 2009
    Location:
    Kent
    #3
    Well given mine has a stock SSD I don't think it's that, nor did I have any issues on Mavericks.

    I have tried removing just about all Apps, still the same result :(
     
  4. aldoF macrumors regular

    Joined:
    Apr 16, 2011
    #4
    MacBook Pro (15-inch, Late 2011)
    OS: 10.10.1 (14B25)
    Processor: 2.2 GHz Intel Core i7
    Memory: 16 GB 1333 MHz DDR3
    HD: 250 GB Solid State SATA Drive
    Graphics: Intel HD Graphics 3000 512 MB

    Iv'e got the same problem every time I use Remote Desktop....otherwise it shuts down just fine.
     
  5. maviso5 thread starter macrumors regular

    Joined:
    Mar 25, 2009
    Location:
    Kent
    #5
    I do use apple remote desktop however as a quick sanity check I just zapped it and the issue still persists. :(
     
  6. aldoF macrumors regular

    Joined:
    Apr 16, 2011
    #6
    did you use RD at all during that session before you zapped it? all it takes for me is one single session and I'll get stuck, when I don't use it at all everything works as it should.
     
  7. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #7
    launchd-shutdown.system.log

    Console is our friend.

    /var/log/com.apple.launchd/launchd-shutdown.system.log

    /var/log/com.apple.launchd/launchd-shutdown.system.log.1
     
  8. maviso5 thread starter macrumors regular

    Joined:
    Mar 25, 2009
    Location:
    Kent
    #8
    I didn't use ARD I just have it installed.

    I gave up in the end...

    Solution: Clean install without importing my old user, then, manually copy the files I wanted back from my Time Machine backup...problem has gone...clearly something was in my setup that Yosemite didn't like....yet to figure out what
     
  9. sektor macrumors member

    Joined:
    Aug 24, 2009
    #9
    Same problem here.

    MacPro 2011 model, will not shut down, not even after hours.
     
  10. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #10
    Above

    Please see my first post above.

    What do you find logged after the shutdown failure?
     

Share This Page