Yosemite in Virtualbox guide

Discussion in 'OS X Yosemite (10.10)' started by y0semite, Jun 2, 2014.

  1. y0semite, Jun 2, 2014
    Last edited: Jun 2, 2014

    y0semite macrumors newbie

    Joined:
    Jun 2, 2014
    #1
    Edit: I haven't got this to completely work yet, but it is a good starting point. Keep watching the USB installer thread for ideas. http://forums.macrumors.com/showthread.php?t=1740384

    You can run Yosemite in Virtualbox, here's how.

    1. Download Yosemite from app store
    2. run "gem install iesd"
    3. run "iesd -i /Applications/Install\ OS\ X\ 10.10\ Developer\ Preview.app -o yosemite.dmg -t BaseSystem"
    4. add yosemite.dmg as a live cd in virtualbox
    5. change the chipset to PIIX3

    Once you boot up into the installer you will have to format the drive.

    Let me know how it works :)
     
  2. arnies macrumors newbie

    Joined:
    Feb 4, 2013
    #2
    I can't get the HD showing up as an install option
     
  3. y0semite thread starter macrumors newbie

    Joined:
    Jun 2, 2014
    #3
    I can't get past the install screen, but to get the HD to show you have to open disk utility (in the installer) and format the drive as mac os extended journaled.
     
  4. stimz macrumors newbie

    Joined:
    Jun 3, 2014
    #4
    It starts to load up the installer but can't find bluetooth so it stalls at "still waiting for root device". Any thoughts?
     
  5. lottscarson, Jun 3, 2014
    Last edited: Jun 3, 2014

    lottscarson macrumors newbie

    Joined:
    Jun 3, 2014
    Location:
    Salt Lake City
    #5
    Ok, I managed to get this working. A couple of necessary files weren't making it onto yosemite.dmg, so after running the iesd command, do this:


    1. Run "hdiutil convert yosemite.dmg -format UDSP -o yosemite.sparseimage"
    2. Run "hdiutil mount /Applications/Install\ OS\ X\ 10.10\ Developer\ Preview.app/Contents/SharedSupport/InstallESD.dmg"
    3. Run "hdiutil mount yosemite.sparseimage"
    4. Run "cp /Volumes/OS\ X\ Install\ ESD/BaseSystem.* /Volumes/OS\ X\ Base\ System/"
    5. Run "hdiutil unmount /Volumes/OS\ X\ Install\ ESD/"
    6. Run "hdiutil unmount /Volumes/OS\ X\ Base\ System/"
    7. Run "hdiutil convert yosemite.sparseimage -format UDZO -o yosemitefixed.dmg"
    8. Add yosemitefixed.dmg as a live cd in virtual box
    9. Change the chipset to PIIX3
    10. Start the VM, open disk utility within the installer and create a new HFS+ partition on the virtual disk
    11. Install it!
    12. After installing, remove yosemitefixed.dmg from the virtual drive in virtualbox
     
  6. foobarbaz macrumors 6502

    Joined:
    Nov 29, 2007
    #6
    I've got it running by simply cloning my 10.9 VM and upgrading it. However it seems to be running extremely slow inside the VM. Anyone else experiencing this?
     
  7. lottscarson macrumors newbie

    Joined:
    Jun 3, 2014
    Location:
    Salt Lake City
    #7
    Yep, slow as all hell. I tried upping the vram, enabling graphics acceleration, bumping up the system ram, using 2 processors... nothing really seemed to improve it.
     
  8. Actarus, Jun 3, 2014
    Last edited: Jun 3, 2014

    Actarus macrumors member

    Joined:
    Feb 10, 2011
    #8
    When trying this command it says these are Read Only file systems :confused:

    Edit: Ok i think i fixed it.
     
  9. Jesseee macrumors newbie

    Joined:
    Jun 3, 2014
    #9
    Could you possibly be kind enough to put "yosemitefixed.dmg" up for download?
     
  10. lottscarson macrumors newbie

    Joined:
    Jun 3, 2014
    Location:
    Salt Lake City
    #10
    That's almost certainly a violation of the NDA, so sorry, I can't put that up. I'd be happy to help you get it set up yourself, though. At what point are you having trouble?
     
  11. SHX macrumors newbie

    Joined:
    Jun 4, 2014
    #11
    Thank You.

    unmount gave me some trouble, but ejecting the images from disk utility helped.
     
  12. bankshot macrumors 65816

    bankshot

    Joined:
    Jan 23, 2003
    Location:
    Southern California
    #12
    Hmm, no good so far for me. The installer boots and attempts to install, but eventually encounters an error:

    I also noticed a ton of error messages during bootup - stuff like "Error: 107: malformed bundle" and many others. Don't know if that's normal for the installer.

    In the VirtualBox VM settings, I did do a few things that aren't mentioned above:
    • Used HDD (Parallels format) for the hard drive file; wondering if it might actually boot in Parallels once installed.
    • System memory 4 GB
    • Turned on 3D acceleration
    • Bumped video memory to the max 128 MB

    This is the latest version of VirtualBox - 4.3.12 r93733.

    I may retry with the above set to defaults later when I get time...
     

    Attached Files:

  13. lottscarson macrumors newbie

    Joined:
    Jun 3, 2014
    Location:
    Salt Lake City
    #13
    Yeah, I noticed a ton of errors (including those malformed bundle errors) during bootup, too. The installer finished just fine for me, though. Not that it did me much good, given that the VM runs so slowly... It's pretty much unusable for anything other than poking around to look at the new features. I bumped up the memory to 4GB, gave the CPU 2 cores, bumped up the video memory and turned on 3D acceleration, but none of that seemed to help much.

    I also attempted to import the VM into Parallels, but that failed pretty quickly :p
     
  14. bankshot macrumors 65816

    bankshot

    Joined:
    Jan 23, 2003
    Location:
    Southern California
    #14
    I haven't made any more attempts yet, but one other thing that occurs to me is that I'm still on Mountain Lion. Ideally, the VM would just do its thing and work with any host or guest OS, but maybe that makes a difference too.
     
  15. westsurf macrumors newbie

    Joined:
    Dec 9, 2007
    #15
    Essentials.pkg

    Mine fails constantly with an extraction of the above error.
     
  16. cjt3007 macrumors member

    cjt3007

    Joined:
    Jul 6, 2008
    Location:
    Portland, OR
    #16
    IESD command not found

    I've tried installing IESD via sudo, and no sudo but I still get the command not found issue. HELP?
     
  17. igorleandro, Jul 21, 2014
    Last edited: Jul 22, 2014

    igorleandro macrumors member

    Joined:
    Sep 19, 2008
    #17
    Edit: After many tries, all I get is stuck on "Waiting for DSMOS...". Have no idea how you guys managed to get this going.
     
  18. the_webmaestro macrumors newbie

    Joined:
    Jul 18, 2002
    Location:
    Laguna Beach
    #18
    FATAL: No bootable medium found! System halted.

    I've followed the instructions, but I get this error:

    FATAL: No bootable medium found! System halted.

    I've tried re-creating the Hard Drive in .VDI & .HDD formats. I've also tried going without a hard disk, and also by removing then re-adding the yosemitefixed.dmg file.

    Any ideas?
     
  19. MacPro2006VBox, Oct 9, 2014
    Last edited: Oct 9, 2014

    MacPro2006VBox macrumors newbie

    Joined:
    Oct 9, 2014
    #19
    if you all would like to know how to set it up...

    go to ***** and download the DP2 from the OS X betas and use Firefox to DownLoad it (unless you all have a copy of it already, but not in any disk image format yet) follow this guide in the link to create an ISO of it. and what i did was create a new VM as normal but selected Mac OS X 64 bit and didn't change anything, mounted the image, followed the steps to set it up, and i now have a working Yosemite VM. hope this helped!:apple::)
    http://pastebin.com/6pWGSB5b
     
  20. jtkboston macrumors newbie

    Joined:
    Oct 23, 2014
    #20
    crash trying to boot installer

    I'm trying this method to boot a Yosemite install image in VBox 4.3.18 r96516
    It gets into a boot/panic/reboot loop, never bringing up a GUI or installer.

    The panic is a kernel trap/page fault, the stack is a bit hard to make out from the image but looks like several stack frames in com.apple.driver.ACPI_SMC_PlatformPlugin and com.apple.driver.IOPlatformPluginLegacy.

    Any clue why it's failing?
    Host hardware is Mac mini, Mid 2011, 2.7 GHz Intel Core i7, 8GB RAM,
    OS X 10.9.5 (13F34)
     

    Attached Files:

  21. jtkboston macrumors newbie

    Joined:
    Oct 23, 2014
    #21
    This may be the problem. A thread on virtualbox.org (topic 62768: https://forums.virtualbox.org/viewtopic.php?f=8&t=62768) suggests that this variant of the Intel CPU fails on this model Mac mini, but works on Late-2012 model.
    I'm actually seeing this failure before the panic:
    Code:
    ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out
    ...
    ACPI_SMC_PlatformPlugin::registerLPCDriver - WARNING - LPC device initialization failed: C-state power management not initialized
    
     

Share This Page