Yosemite installation stuck

Discussion in 'OS X Yosemite (10.10)' started by Alejandra36, Oct 17, 2014.

  1. Alejandra36 macrumors newbie

    Joined:
    Oct 17, 2014
    #1
    I started upgrading to Yosemite from Mavericks in a macbook pro. The installation program asked me if I wanted to close all applications. This is strange as I had closed them all before starting installation. Now it is stuck.
    I got a blank screen with a spinning wagon Wheel for about four hours now.
    Is it safe to reboot at this stage with the power button.
    Help, please!
     
  2. rritterson macrumors 6502

    Joined:
    Jul 10, 2008
    Location:
    DC USA
    #2
    I can't guarantee it's safe to force a reboot, but it's 99% safe. The install doesn't happen until it reboots into the installer image. I'd power off and on again.
     
  3. informite macrumors newbie

    Joined:
    Oct 17, 2014
    #3
    I am in same situation. Left it overnight for 9-10 hours. I rebooted the machine and now its stuck at same place for 5 hours. (screenshot attached). What are my options, Can I still boot into Mavericks? I didn't took a time machine backup before starting the upgrade:(
     

    Attached Files:

  4. IeU macrumors member

    Joined:
    May 1, 2011
    #4
    Mine is stuck with 2 minutes remaining for about 3 hours now . . .
     
  5. Sgtarky macrumors regular

    Joined:
    Dec 24, 2011
    #5
    mine is halfway...been trying for 4 hours....clean install
     
  6. robkat macrumors member

    robkat

    Joined:
    Dec 22, 2008
    Location:
    Scotland
    #6
    Router solution

    I was stuck downloading to my iMac for hours. Shut down router for a couple of minutes, restarted and download picked up and took 20 minutes to finish. Might be worth trying.
     
  7. Sgtarky macrumors regular

    Joined:
    Dec 24, 2011
    #7
    what if it doesnt have to DOWNLOAD! I created the install usb.
     
  8. samsteeno macrumors newbie

    Joined:
    Oct 18, 2014
    #8

    I'm stuck at that EXACT spot on my 2012 rMBP
     
  9. HuskerGreg macrumors newbie

    Joined:
    Oct 18, 2014
    #9
    Solution:
    Press Shift during startup [Starts up in Safe Boot mode and temporarily disables login items.]

    My friend's computer got stuck for hours—several times—during the installation of Yosemite. Safe Boot mode enabled Yosemite to start; I then had him repair disk permissions using Disk Utility (something he hadn't done prior to installation), and then restart. Working fine now.
     
  10. samsteeno macrumors newbie

    Joined:
    Oct 18, 2014
    #10

    Yeah, safe mode works for me, but unusably slow, takes at least 5 minutes to render any click, or action, I can't even get past the login screen :/
     
  11. dannyg86 macrumors regular

    dannyg86

    Joined:
    Apr 11, 2014
    #11
    If you are ok with doing a fresh install....

    When the installer boots up, chose disk utility and erase your hard-drive (the one you want to install Yosemite on), and chose "Journaled" format then hit erase.

    After that is done, close disk utility and proceed with the install. The only time I have ever seen this fail (or have any issues) was when I reached the end of the Yosemite set up screen (the one after you enter your username and password etc) where it finished the "setting up your mac" screen (the one with checkboxes) and got stuck there. A reboot resulted in it booting to the desktop.

    Hope this helps
     
  12. samsteeno macrumors newbie

    Joined:
    Oct 18, 2014
    #12
    I'm re-installing Mavericks now from my bootable drive... I hope this works... Can't believe apple would release such a flawed OS. I'm going to stick to Mavericks until I'm sure Yosemite is stable.

    I had a lot of stuff I had to get done and Yosemite messed up my whole weekend!
    I guess that's my fault for just trusting that apple would release a perfect OS that would install smoothly.. Psh :p
     
  13. samsteeno macrumors newbie

    Joined:
    Oct 18, 2014
    #13
    Didn't work, can't install mavericks
    I'm totally stuck now, with no recent backup >.<
     
  14. Sgtarky macrumors regular

    Joined:
    Dec 24, 2011
    #14
    I got mine fixed, bad installer I guess. I erased my harddrive, booted from USB is where I was getting the hold up. So I did internet recovery installed Lion. from Lion I put in my usb and ran the installer, it worked a few minutes and gave an error about not being verified(i wish I could remember the exact message) but I had saved that yosemite.app on another drive , plugged it in and it did install
     
  15. fskywalker macrumors 65816

    fskywalker

    Joined:
    Nov 6, 2009
    #15
    Mine mess up the whole machine, every desktop item dissapeared. Ended up starting from ground up Mavericks again
     
  16. Djdonnie macrumors newbie

    Joined:
    Oct 22, 2014
  17. HuskerGreg macrumors newbie

    Joined:
    Oct 18, 2014
    #17
    To reiterate: my friend had the same problem—frozen installation, with the same screen as shown by Informite above. My friend fixed it by restarting (hold down the power button) and then holding down the Shift key before the startup sequence begins. His iMac started in Yosemite.

    He then used Disk Utility to repair permissions. I don't know if that was necessary, but I had him do it.

    The only oddity was that he said there was a Restart option in a dialog box--he clicked on that and everything worked perfectly. I don't know what he was talking about there because he is not great at describing what is happening onscreen (he is 2,000 miles away).

    I installed Yosemite on 2 computers without a problem, so I haven't been able to test out the fix to stuck installation. Has the shift key method worked for others?
     
  18. aryans14 macrumors newbie

    Joined:
    Oct 25, 2014
    #18
    Having same problem....

    Dear friends i am having same problem. I was having Mavericks in Virtual Machine and i updated to OS X 10.10 Yosemite after Apple released it on 16th October 2014. After download i started update of Mavericks to Yosemite. It asked for restart and after restart, apple boot logo appears that hangs at about 50% and nothing more movement occurs.

    I have tried several restarts, it stuck on same place. As well as when it gets stuck there, it takes hours, but it is not moving from 50%.

    Can anyone of you please help me.
     
  19. blairsomers macrumors newbie

    Joined:
    Jan 10, 2013
    #19
    Yes mate, it worked for me. My install was stuck as per the picture above. Followed your fix and booted straight away by itself. Restarted again and while it is considerably slower than with Mavericks, it boots up.
    Thank you :)
     
  20. cjmillsnun macrumors 68020

    Joined:
    Aug 28, 2009
    #20
    If you didn't make a backup then you are SOL.

    You may be able to install Mavericks to an external drive, boot from that and recover your data.

    ----------

    Yosemite has been perfectly stable for the majority of people. However there are always a few edge cases where software or even hardware drivers may cause an incompatibility. This has happened in every release of OS X from 10.0 to 10.10. It is nothing new at all. I note you have no recent backup. That is more than unwise. As you've learned the hard way, never install a new operating system without a backup.
     

Share This Page