Yosemite kernel panic watching video

Discussion in 'OS X Yosemite (10.10)' started by tinycg, Dec 30, 2014.

  1. tinycg macrumors member

    Joined:
    May 8, 2009
    #1
    I just upgraded to Yosemite yesterday on a 4,1 Mac Pro which also has a GTX 570 and GT 120 in it. Its been working fine except I've gotten a couple kernel panics in a few situations.

    Waking up from sleep, after a few seconds if I try to do something in an app, say "Open" a file from Photoshop, the screens lock up, go black / blue / or are just static screen noise. I have several "SystemUIServer wakeup_resource.diag" from each crash but nothing that looks like a kernel panic log I'm used to.

    It's also crashed twice playing a video in Quicktime, and in Quickview Preview, both of which I think are using core video? Because VLC seems to play these fine.

    I've seen this from an old thread:
    http://forums.macrumors.com/showthread.php?t=1583723&highlight=gtx+570+gt+120

    That seems to suggest issues with the 570/120 but I've run this combo successfully for years in Mavericks/Lion. Trying to figure out if anyone else has experienced similar issues? Contemplating downgrading to Mavericks? Or maybe a 970 if its a dual card issue?
     
  2. sharon22 macrumors regular

    Joined:
    Oct 19, 2014
    #2
    If you can MAKE a "kernal panic" happen, like, for example, if you know a certain sequence (e.g. start up a particular video, and speed through it or something), THEN what you can do is have "CONSOLE" running at the same time ("Console" is found in your Utilities folder).

    With Console running, you can see the System Messages to see exactly what is going wrong!

    Alternatively, if you can guess or estimate the EXACT TIME the Kernal Panic happened, you can search/sift through all the System Messages in Console, looking for that specific time, so you can figure out what went wrong.

    Console.... is your friend! :D
     
  3. tinycg thread starter macrumors member

    Joined:
    May 8, 2009
    #3
    Thanks, I am looking at the Console and it doesn't seem to be logging a real kernel panic log file, or at least the format I'm used to. The screen immediately goes dark/haywire etc when it happens so real time is difficult.

    In the System Log in the Console I can't find any indication from that moment beyond it booting back up minutes later. It's very odd.

    The only indication of the crash are a new "SystemUIServer_[timestamp]_[machinename].wakeups_resource.diag from that time.

    I'm trying to figure out if SystemUI is crashing because of a graphics driver issue? an extension issue? and this report doesn't seems to be of much help to me.

    I'm not familiar with what SystemUIServer is handling, and if its worth biting the bullet on a fresh Yosemite install. If its a driver issue do to the hardware I'm running and known incompatibility with Yosemite I might just go back to Mavericks for the time being.
     
  4. sharon22 macrumors regular

    Joined:
    Oct 19, 2014
    #4
    When in Console, make sure you have "All Messages" selected, so that nothing is being filtered out (so that you can see *every* message your System generates).

    Keep a stop watch that is synchronized with your Mac's clock sitting next to you on the table. The next time a Kernal Panic happens, make a note of the *exact* time, right down to the second, that it happens. THEN, search through the console messages for that exact time.

    Read the messages that lead up to that epoch.

    (ooh i used a fancy word just then LOL.)

    You'll want to look for words like 'illegal' 'failed' 'error' 'could not' 'invalid' and usually there will be some clue, albeit cryptic, that will help figure out what is wrong.

    I'll tell you what is wrong, though. You are using Yosemite! :D

    I would do all the system maintenence cleaning stuff that I could think of, if I was you... for example, download the latest build of Onyx and run it, I would do a Single-User-Startup (start up with Command-S) and then run FSCK (the one-liner disk repair), I would zap the PRAM, and then I would delete all the preferences I knew were safe to delete, e.g. your quicktime/quicklook preferences, everything!

    And, finally, just to make sure it isn't something you installed that is conflicting, I would create a Temporary new user with admin privileges, log out, log yourself back in as the New User you just created, and then see if you can cause that Kernal Panic to happen. If you CAN'T cause it to happen, then that shows that in Mac's pristine environment, everything is fine, and it's something you added/altered/changed/downloaded, and you have to figure out what it is. However, if you get kernal panics while in your system as the New User, then I would think it is Yosemite's fault.
     
  5. tinycg thread starter macrumors member

    Joined:
    May 8, 2009
    #5
    After some more looking it definitely seems to be some sort of Yosemite issue with quicklookUIhelper. Just not sure if it's related to the video card drivers or something else.

    The odd thing now is it seems inconsistent with what videos cause it to crash which makes me wonder what's different between them. One MP4 consistently crashes others seem fine and others seem to work intermittently.

    Creating a new user, clearing quicklookUIhelper containers, prefs etc all cause the same outcome.

    What's perplexing is the sys logs don't show anything out of the ordinary after the playing of the file that crashes or plays fine. Also between 3 users - 1 crashes a few seconds in. 1 locked up and played the audio for the entire clip before locking up and the last crashes immediately.
     
  6. tinycg, Jan 13, 2015
    Last edited: Jan 13, 2015

    tinycg thread starter macrumors member

    Joined:
    May 8, 2009
    #6
    Update

    This issue continues to perplex me.

    I removed the GT120 leaving the macvidcards flashed GTX570 in the system, that seemed to make the system surprisingly more unstable. Now rather than crashes under certain reasonably reproducible scenarios OS X randomly crashes after waking from sleep, fully booting etc. Often times within minutes not hours.

    Comparatively with the GT120 in the system but no monitor plugged the system ran for days, and then would randomly crash, filling out a form in chrome, diagnosing this issue searching in safari, in different users, different apps, different tasks etc.

    Here is what I've done:
    • Run Onyx as suggested
    • Reset PRAM/NVRAM
    • Run full comprehensive AHT test (and quick one) and passed both
    • Removed GT120
    • Reinstalled Yosemite (Clean install) from USB and still had random hangs
    • Clean install of Mavericks and now see the issue there for the first time.
    • Video that instantly causes Yosemite to crash plays fine with no issues in Quicklook / QT under Mavericks. Then mins later, randomly hung again causing me to rethink every assumption that this was a Yosemite driver issue.

    Is it possible that the GTX570 after Yosemite being installed has borked the card somehow? Is there any way for me to test the card?

    I doubt AHT really tests the card, but I've yet to have any random crashes running with that card in the hours I've been in AHT, Recovery mode, and multiple OS installs.

    Beyond removing the GTX570 and just putting in the GT120 does anyone else have a suggestion for anything I can do to diagnose this problem?

    Every memory test I've run, either AHT or others has come back clean.

    I'm truly scratching my head on this one. I had no issues at all with Mavericks and thought that at the very least going back to Mavericks would fix it.

    Side note: after a reinstall of Yosemite over itself the first time, and subsequent clean installs of OSes OS X isnt generating any System Diagnostic Reports for any of the crashes anymore leading me to believe that the wakeups.resources reports for earlier in this thread might have been a side effect crash and not the true source. It appears the system continues to run but I have no way of control.
     
  7. tinycg thread starter macrumors member

    Joined:
    May 8, 2009
    #7
    Kernel panic logs

    Attaching kernel panic logs from today in case they're helpful to anyone or anyone can shed light on what could be causing this.
     

    Attached Files:

  8. MacVidCards Suspended

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #8
    got your email

    try cleaning all dust from 570

    install web drivers

    run a OpenGl intensive benchmark and see if card crashes that way

    Uningine Valley is a good one
     
  9. tinycg thread starter macrumors member

    Joined:
    May 8, 2009
    #9
    Thanks MacVidCards I'll give that a try today and report back.

    When I tried running the web drivers during this ordeal I could get them to install but they would never stay checked on restart, it would always show that they defaulted back to the OSX driver.

    Is there a way to tell if they really are running and being mis-reported?
     
  10. tinycg, Jan 14, 2015
    Last edited: Jan 15, 2015

    tinycg thread starter macrumors member

    Joined:
    May 8, 2009
    #10
    Cleaned the card, reinstalled it. Immediately got a crash/reboot loop (after clearing PRAM twice).

    Seemed to settle itself after that. Ran Valley, it crashed the minute I hit run.

    Installed Web Drivers, restarted, they show as enabled successfully, Ran Valley and it crashed the minute I hit run again.

    Panic logs attached. So seems to be related to OpenGL maybe?

    UPDATE: This morning I've been able to successfully run Cinebench tests (both GPU/OpenGL and CPU) along with Novabench and both sets ran fine, no crashes and nothing in the console. So I'm at a loss again.
     

    Attached Files:

  11. dizzleBit macrumors newbie

    Joined:
    Jan 17, 2015
    #11
    Not sure what version of Yosemite you're on but I'm on (14B25) using a GTX580 and have spent some time the last few days researching a lot of quicklookUI errors in my logs as well as the system crashing when ever I tried using quick look on just about any file. Also random crashes in photoshop. I would always have to reboot.

    What worked for me? This nvidia driver: 343.02.01

    For some, the previous release worked: 343.01.02

    Hope this helps
     
  12. tinycg thread starter macrumors member

    Joined:
    May 8, 2009
    #12
    Thanks Dizzlebit, these issues started in 10.10.1 but I'm also seeing them in 10.9.5 which makes me think its related to hardware but I have no way to verify that and can't get any combination of drivers to work consistently anymore.

    The card still randomly causes a kernel_task panic. In 10.10.1 it seems more tied to QuicklookUI as you stated, in 10.9.5 I can play the files that were causing problems, but other OpenGL tasks cause panic, while others don't.

    Don't want to go buy a new card if that's not the real problem, however I'm at a loss to read the panic.log and understand if its pointing to hardware or software.

    The fact that its happening in Yosemite and Mavericks has me thinking its hardware, but the fact that it only started after installing Yosemite has me perplexed.

    P.S. - which version did you say was working for you? that wasn't clear to me in the post.
     
  13. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #13
    Getting more from kernel panics with keepsyms (address to symbol translation)

    In the meantime, the Read Error catches my eye:

    Code:
    Anonymous UUID:       1A29277B-7E8B-CC79-0C49-1B58BA0109B8
    
    Tue Jan 13 16:05:07 2015
    panic(cpu 6 caller 0xffffff7f98005bb9): NVRM[0/5:0:0]: Read Error 0x00009400: CFG 0x108610de 0x00100406 0x8a000000, BAR0 0x8a000000 0xffffff83c0ec7000 0x0c8300a1, D0, P2/3
    Backtrace (CPU 6), Frame : Return Address
    0xffffff83bee136e0 : 0xffffff8017622f79 
    0xffffff83bee13760 : 0xffffff7f98005bb9 
    0xffffff83bee13820 : 0xffffff7f980cfebe 
    0xffffff83bee13860 : 0xffffff7f983415de 
    0xffffff83bee13880 : 0xffffff7f98182273 
    0xffffff83bee138b0 : 0xffffff7f980d1103 
    0xffffff83bee138f0 : 0xffffff7f980cea7f 
    0xffffff83bee13910 : 0xffffff7f9829efb4 
    0xffffff83bee139a0 : 0xffffff7f98072f20 
    0xffffff83bee13aa0 : 0xffffff7f980723eb 
    0xffffff83bee13ad0 : 0xffffff7f98072499 
    0xffffff83bee13b10 : 0xffffff7f98072378 
    0xffffff83bee13b30 : 0xffffff7f98014e93 
    0xffffff83bee13ba0 : 0xffffff7f98014248 
    0xffffff83bee13be0 : 0xffffff7f981825f4 
    0xffffff83bee13c30 : 0xffffff7f981823fa 
    0xffffff83bee13c80 : 0xffffff7f9801412a 
    0xffffff83bee13ce0 : 0xffffff7f98011c3e 
    0xffffff83bee13d30 : 0xffffff7f9802640f 
    0xffffff83bee13d70 : 0xffffff7f98323cd7 
    0xffffff83bee13db0 : 0xffffff7f983227b5 
    0xffffff83bee13e20 : 0xffffff7f980f29e5 
    0xffffff83bee13e40 : 0xffffff7f9800c65d 
    0xffffff83bee13ef0 : 0xffffff8017ab0a20 
    0xffffff83bee13f30 : 0xffffff8017aaf4c2 
    0xffffff83bee13f80 : 0xffffff8017aaf597 
    0xffffff83bee13fb0 : 0xffffff80176d7607 
          Kernel Extensions in backtrace:
             com.apple.nvidia.driver.NVDAResman(8.2.6)[272B6397-FEDB-32FC-9035-BDD749284455]@0xffffff7f97fb5000->0xffffff7f98228fff
                dependency: com.apple.iokit.IOPCIFamily(2.9)[2852ACFE-FD28-3C37-9B39-885201BB8D25]@0xffffff7f97cbf000
                dependency: com.apple.iokit.IONDRVSupport(2.4.1)[D41125CE-69BD-32E7-9B1D-4E83431662DD]@0xffffff7f97f9f000
                dependency: com.apple.iokit.IOGraphicsFamily(2.4.1)[75D81741-64C1-3941-ADFA-9D6B6C434EE4]@0xffffff7f97f5c000
                dependency: com.apple.AppleGraphicsDeviceControl(3.6.22)[91D61DEC-2946-3790-8134-B808C016C4C9]@0xffffff7f97faf000
             com.apple.nvidia.driver.NVDAGF100Hal(8.2.6)[A70A96A4-52F6-3303-AF6D-FE537BCFDAC0]@0xffffff7f98234000->0xffffff7f98401fff
                dependency: com.apple.nvidia.driver.NVDAResman(8.2.6)[272B6397-FEDB-32FC-9035-BDD749284455]@0xffffff7f97fb5000
                dependency: com.apple.iokit.IOPCIFamily(2.9)[2852ACFE-FD28-3C37-9B39-885201BB8D25]@0xffffff7f97cbf000
    
    BSD process name corresponding to current thread: kernel_task
    
    Mac OS version:
    13F34
    
    Kernel version:
    Darwin Kernel Version 13.4.0: Sun Aug 17 19:50:11 PDT 2014; root:xnu-2422.115.4~1/RELEASE_X86_64
    Kernel UUID: 9477416E-7BCA-3679-AF97-E1EAAD3DD5A0
    Kernel slide:     0x0000000017400000
    Kernel text base: 0xffffff8017600000
    System model name: MacPro5,1 (Mac-F221BEC8)
    
    System uptime in nanoseconds: 77667974103
    last loaded kext at 8520493414: com.apple.driver.AppleHWSensor	1.9.5d0 (addr 0xffffff7f992aa000, size 36864)
     
  14. tinycg thread starter macrumors member

    Joined:
    May 8, 2009
    #14
    I've enabled the suggested bootargs and while I can still get the video noise upon running tests the system again doesn't appear to feel like it's kernel panicking and just sits there until I reboot it.

    I did get it to randomly crash on boot by re plugging in the Cinema Display to the displayport. So not sure what happened but the card doesn't seem happy anymore.

    If I get a new panic log I'll post it here.
     

    Attached Files:

  15. tinycg, Jan 22, 2015
    Last edited: Jan 22, 2015

    tinycg thread starter macrumors member

    Joined:
    May 8, 2009
    #15
    I'm updating this thread to provide 2 more kernel panic logs and images.

    I attempted with the GTX 570 installed to boot to the USB stick to do a fresh Yosemite install. I received these graphical issues in the image.

    I then took out the 570 and trying a GT120 with a unflashed 750Ti and booting to do a fresh install of Yosemite. This system wasn't happy with this. Maybe because I needed to do a NVRAM reset? I did that and still had issues. I took the 750Ti out and now only the GT120 is in the system.

    Going to try a reinstall of Yosemite with just the GT120 and then with nvidia drivers and the 750Ti to try to rule out any other system issues.

    EDIT: Fresh install running with temporary 750Ti seems to have fixed all instability issues thus far. Run and completed numerous benchmarks, no quicklookUI issues. Seems to confirm something happened to the MVC GTX570 that had up to this point been rock solid.

    Any help would be appreciated.
     

    Attached Files:

  16. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #16
    Thanks. The first of those includes the more informative backtrace:

    Code:
    0xffffff83aff0b840 : 0xffffff801593a811 mach_kernel : _panic + 0xd1
    0xffffff83aff0b8c0 : 0xffffff8015a1e80a mach_kernel : _kernel_trap + 0x84a
    0xffffff83aff0ba80 : 0xffffff8015a3a443 mach_kernel : _return_from_trap + 0xe3
    0xffffff83aff0baa0 : 0xffffff7f986e058f com.apple.nvidia.driver.NVDAResman : _NvRmDupObject + 0x162
    0xffffff83aff0bba0 : 0xffffff7f9868c505 com.apple.nvidia.driver.NVDAResman : __ZN4NVDA16enableControllerEv + 0xf7
    0xffffff83aff0bbe0 : 0xffffff7f97f478d0 com.apple.iokit.IOGraphicsFamily : __ZN13IOFramebuffer4openEv + 0x76e
    0xffffff83aff0bc70 : 0xffffff7f97f3f8ac com.apple.iokit.IOGraphicsFamily : __ZN13IOFramebuffer13newUserClientEP4taskPvjPP12IOUserClient + 0x98
    0xffffff83aff0bcb0 : 0xffffff7f9868d164 com.apple.nvidia.driver.NVDAResman : __ZN4NVDA13newUserClientEP4taskPvjPP12IOUserClient + 0xa6
    0xffffff83aff0bd00 : 0xffffff8015eb85b1 mach_kernel : __ZN9IOService13newUserClientEP4taskPvjP12OSDictionaryPP12IOUserClient + 0x31
    0xffffff83aff0bd50 : 0xffffff8015eff0b5 mach_kernel : _is_io_service_open_extended + 0x1b5
    0xffffff83aff0bdc0 : 0xffffff80159ea95e mach_kernel : _iokit_server + 0x250e
    0xffffff83aff0be10 : 0xffffff801593e91c mach_kernel : _ipc_kobject_server + 0xfc
    0xffffff83aff0be40 : 0xffffff80159235a3 mach_kernel : _ipc_kmsg_send + 0x123
    0xffffff83aff0be90 : 0xffffff8015933e8d mach_kernel : _mach_msg_overwrite_trap + 0xcd
    0xffffff83aff0bf10 : 0xffffff8015a0a142 mach_kernel : _mach_call_munger64 + 0x182
    0xffffff83aff0bfb0 : 0xffffff8015a3ac66 mach_kernel : _hndl_mach_scall64 + 0x16
    Based on past experience (not with Yosemite) I guess that the problem involves the NVIDIA hardware. Maybe a hardware combination that has not been suitably tested in an environment such as yours.

    If you had no comparable panic with Mavericks, it's reasonable to assume a bug in Yosemite.
     
  17. tinycg thread starter macrumors member

    Joined:
    May 8, 2009
    #17
    Thanks for the help. I can all but confirm it was the card. I had issues going back to Mavericks as well.

    Tonight I just put in a new GTX 970 with the fresh install of Yosemite and so far I've seen no glitches, panics or anything. Every test and place it crashed before is working with flying colors.

    Can't quite get my head around how the card was fine and then going to Yosemite seemed to break it. Literally nothing else changed or happened between the period it was working in Mavericks to pretty much instantly crashing after installing Yosemite. Odd.
     
  18. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #18
    Let's go back.

    What firmware, and from what source?

    A reset of the SMC would do no harm.

    How clean was the system when you first encountered a problem after that installation?

    Did you migrate (or otherwise put in place) any apps, user data or other data?
     
  19. tinycg thread starter macrumors member

    Joined:
    May 8, 2009
    #19
    Sure lets see.

    It is a MacVidCards flashed GTX 570 that I bought from them several years back. It's served me well and can say nothing but positive things about MVC. I don't know specifically what's flashed on the card but had no issues with it til now.

    I did do an upgrade from Mavericks to Yosemite, not clean so all user data transferred over the first time. Since then based on suggestions I've created clean new users in Yosemite, rolled back to a clean install of Mavericks running nothing else with it, run a clean install of Yosemite...

    With the card in the system in all those situations the system crashes. Things that seem to reference OpenGL whether that's quickview in Yosemite, safaris home screen when you select a recent site and it does a card flip transform, running OpenGL benchmarks and also in other seeming random situations all end with a crash.

    This is with or without other cards like the GT120 in the system.
     
  20. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #20
    Ah, OK, I misread things earlier. I wasn't familiar with MacVidCards until after I sought info, a few minutes ago, on DuckDuckGo. I misunderstood that you had performed the flash.

    Prior to that search, yesterday I bookmarked this:

    Nvidia GeForce GTX 570 in a Macintosh — Anarchyjim (2012-12-31, highlights)

    In a nutshell: I can't imagine installation of Yosemite altering anything on the card, so either:
    • you became unlucky with coincidentally failing NVIDIA hardware; or
    • something undetectable, or not yet considered, changed.

    Maybe a combination of things.

    I'd look at cabling and so on.
     
  21. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #21
    c. The firmware flashed on the card is incompatible with Yosemite in some way.
     
  22. tinycg thread starter macrumors member

    Joined:
    May 8, 2009
    #22
    Yeah I'm chalking it up to really badly timed (a) but trying to document it in case other people have issues and its more like (c).
     
  23. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #23
  24. tinycg thread starter macrumors member

    Joined:
    May 8, 2009
    #24
    Yup just compared it myself, that's not the issue. Thanks for that link I didnt realize that for some macs they were pushing a FW update.
     

Share This Page