Yosemite lags

Discussion in 'OS X Yosemite (10.10)' started by isaac3232, Nov 1, 2014.

  1. isaac3232 macrumors newbie

    Joined:
    Aug 24, 2013
    #1
    Installed OS X Yosemite on my MacBook retina 13 that I bought 2 y ago and it's very laggy!!! Almost everything lags ,is there a solution? Help?
     
  2. jffluis macrumors regular

    jffluis

    Joined:
    Aug 28, 2012
    #2
    Wait for an update or clean install (which I doubt will make any difference).
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    Your Mac should have plenty of power to run Yosemite without lag. Maybe you have a utility or something running that is conflicting with Yosemite.

    Hold the shift key when booting to boot to safe mode. That will bypass any login or startup items and eliminate that as the cause. If it works well in safe mode, that tells you there is a startup or login item you need to remove.
     
  4. Bending Pixels macrumors 65816

    Joined:
    Jul 22, 2010
    #4
    Part of it is Yosemite is reindexing everything. There may be some third party app's that need updating. Personally, I opted for a clean install (auto reflex left over from WinDoze). No lag on my late 2013 rMBP.
     
  5. shivam2255 macrumors newbie

    Joined:
    Jul 27, 2014
    Location:
    India
    #5
    Yosemite seriously lags!

    I've also seen serious lags after upgrading to Yosemite. I'm currently using Macbook Air Mid 2014 edition and the lags are pretty much measurable.

    Don't know if clean install can solve this or not ... !
     

Share This Page