Yosemite Mac Pro 5,1 Installing Windows 8.1 Error

Discussion in 'Windows, Linux & Others on the Mac' started by ggoerl, May 1, 2016.

  1. ggoerl macrumors regular

    Joined:
    Dec 18, 2007
    #1
    I am seriously at my wits end, why in the **** is it so hard to install windows 8.1 for christ’s sake?!

    I am so aggravated at both microshit and crapple for these technicalities I am experiencing.

    I have wasted a whole day trying to install this **** that microsoft calls an operating system. What happened to simplicity? I used to be able to use bootcamp to install xp no problem, but I’m about to pull my hair out. Every time I fix an error, I get a different one, I’m about ready to throw my mac pro out the window and say good riddance to computers.



    I have a 5,1 Mac Pro running yosemite, and I’m trying to install windows 8.1. First error, was after boot camp finished installing the apple support software to a usb, computer would immediately reboot to a black screen “no bootable disk found, please insert one then press a key” Okay, so then I had to modify bootcamp’s plist to make a bootable usb rather than use a disk I had burned because setup would then hang at the purple screen with the window. Please note, that i have no optical drives installed, I have replaced both opticals with SSDs. I was using an external usb disc drive.

    Still didn’t fix the problem, I had to manually at startup select the newly usb boot disk to boot into 8.1 to setup, then I was getting a MBR GPT error. I soon read up on that to fix it with GPT fdisk. That solved it only to become another problem of now being “unable to create a new partition or locate an existing one” WTF?! and supposedly the only way to fix that is disconnect any peripherals, drives, etc to the system because of microshit’s stupidity and insecurity of being pirated it states that if it finds another windows image or something on any other drive (supposedly). I’m not about to disconnect my tower, open it up, remove all my sleds, disconnect my ssd leaving the single drive for windows to find out it still doesn’t work. This is bloody ridiculous.



    Does anyone have a solution for this? I've wasted countless hours, not too mention a whole day reading crap, searching forums and googling for a solution.
     
  2. ggoerl thread starter macrumors regular

    Joined:
    Dec 18, 2007
    #2
    would upgrading to el cap maybe solve the issue (I'm assuming boot camp assistant is updated in el cap to handle win 8.1 better?) or would I be better off installing windows 7 first and then upgrade? or would I still get the same error? I need solutions, I am desperate.
     
  3. ActionableMango macrumors G3

    ActionableMango

    Joined:
    Sep 21, 2010
    #3
    I have a 5,1 MP with Windows 8.1 installed. I did not use BootCamp Assistant at all. It's a terrible utility that does weird and bad things to partitions. If you are going to install Windows to its own drive, you can skip BootCamp Assistant completely.

    Disconnect all other HDDs/SSDs first. Coincidentally this is the one thing you've said that you refuse to try, and it's actually extremely important (see here). It worked for me.

    After removing the drives, I simply inserted the W8.1 disc, selected it during startup (I think it was called "EFI boot" or something like that), and then installed it as normal with no hiccups in the process. Literally no different than installing Windows on a PC, except of course for the specific keyboard command at boot time to select the startup disk.

    A bootable USB thumbstick works exactly the same as a disc. I don't know if a USB optical drive throws any wrenches in this process or not because I use the standard SuperDrive.

    P.S. The one time I installed Windows without removing the other drives first, I had exactly that thing happen that the guy warns about. It wrecked everything, my OS X became unbootable, and I got that black screen “no bootable disk found, please insert one then press a key” you mention. Dammit Windows, when I point to a specific drive for installation, that's the ONLY drive you should be messing around with. Hopefully your other drives are okay.
     

Share This Page