Yosemite on Non-Retina displays

osx11

macrumors 6502a
Original poster
Jan 16, 2011
816
0
It seems as though OS X Yosemite is optimized for retina displays.

How do you guys like it on non-Retina displays!
 

MartinAppleGuy

macrumors 68020
Sep 27, 2013
2,243
888
I'm on a late 2013 iMac 21.5" and it looks great ! Font's are fine, there is still a few that are ok-ish but they are very rare. 99.9% of the system is amazing on my iMac :D And the other 0.1% is so small that it doesn't bother me :)

PS - I actually prefer the new font on my iMac!
 

GrumpyTrucker

macrumors 6502a
Jun 1, 2014
635
273
27" late 2012 iMac here and it seems fine so far. Text in Messages seems a little harder to read than elsewhere. Looks a tiny bit more blurry with the white on blue. Black on grey looks fine.
 

128keaton

macrumors 68020
Jan 13, 2013
2,027
401
Haven't had any problems with my late 2011 MBP and my 2006 MacPro with HDMI. Smooth and clear!
 

finbred

macrumors newbie
Jan 12, 2014
4
0
Absolutely horrible on my 10 year old 23" Cinema Display and 22" 1680x1050 Eizo. But not all of it, this text I'm writing is fine. But in Mail everything but the message list (system font) window is awful. So yes, reading messages provokes gagging. And no, not a single font works better than Helvetica, except for the system font, but I can't set that for messages. How stupid is that? The system font is also used in iTunes, except for the sidebar when visible (playlists and when an iPhone is connected).

But unfortunately the top menu font is now a washed out grey blur, including drop down menus. Also in Safari – The URLs are ok as are the favorites, but not their drop bar menus.

 

yanki01

macrumors 68040
Feb 28, 2009
3,496
1,481
Texas
mid 2009 MBP, looks and works perfect. I love the design. I'll be updating my wife's late 2011 MBP later today.
 

Quantus

macrumors regular
Apr 2, 2012
171
1
Try this:

I'm using a macbook air 13" (2014). The terminal commands below make fonts slightly more tolerable to my eyes. Enter without the quotes.

"defaults write -g AppleFontSmoothing -bool True"

Then:

"defaults write -g AppleFontSmoothing -int 2"

Confirm setting with:

"defaults read -g AppleFontSmoothing"

To return to Apple's original setting:

"defaults delete -g AppleFontSmoothing"

Make sure LCD smoothing is enable under General in System Preferences. You might need to log out or restart before the changes take effect.
 

Russell L

macrumors regular
Aug 10, 2006
220
28
San Francisco
Looks OK on my early 2011 17" MBP, but it seems that some of the system fonts got a tad smaller. The font size in Contacts, for example, looks way too small to me now, and I can't find a way to increase it. Anyone know? There used to be a specific menu option to make the text bigger, but now it's gone. :(