Yosemite, Phone handoff, and Asus RT-AC87U

Discussion in 'OS X Yosemite (10.10)' started by Allograft, Nov 7, 2014.

  1. Allograft macrumors regular

    Joined:
    Oct 19, 2014
    #1
    I've got a mid-2014 rMBP, clean install to Yosemite. iPhone 6 clean install by DFU to 8.1. Asus RT-AC87U for the router.

    All features of continuity work well except for phone calls.

    I have my router's 5 GHz and 2.4 GHz bands set to the same SSID so that the devices are able to seamlessly move between them.

    However, phone handoff only works when both rMBP and iP6 are on the same band. I have the setting in the router that prevents devices on different bands from communicating (Set AP Isolation) disabled, so my rMBP that likes 5 GHz easily talks to the 2.4 GHz printer regularly. However, the phone call thing sucks.

    If anyone has the same configuration as me but fully functional phone call handoff, would you mind sharing your router settings?
     
  2. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #2
    Are you offering different ip ranges to each band?
     
  3. DJLC macrumors 6502a

    DJLC

    Joined:
    Jul 17, 2005
    Location:
    Mooresville, NC
    #3
    Working great with my 2011 Mac Mini + 2012 MacBook Air + iPhone 5s + Asus RT-N66U. And all of those were upgrade installs.

    Router is mostly factory defaults, save the SSID and WPA2 settings. I don't bother with guest networks or any sort of client isolation at home.

    Have you tried opening FaceTime on rMBP and making an outgoing call via iPhone? I wonder if maybe it just hasn't activated or whatever.
     
  4. Allograft thread starter macrumors regular

    Joined:
    Oct 19, 2014
    #4
    I don't think so and wouldn't even know how to go about setting that up. Is that something that I should do?

    ----------

    interesting. Does the 66U do simultaneous 2.4 and 5 GHz broadcasting?
    My 87U does work for phone calls, but only when they are on the same band, if the PC is on 5GHz and the phone is on 2.4, all continuity features work great, except for phone calls. For both are on the same band, then calls work well
     
  5. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #5
    If the different bands are using different subnet ranges then Apple may be treating them as different networks and not allowing calls to handoff. You would need to check the ip of each device and if necessary look at the router settings.
     
  6. Allograft thread starter macrumors regular

    Joined:
    Oct 19, 2014
    #6
    They all seem to be on the same ip range. All 192.168.1.X
     
  7. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #7
  8. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #8
    Have you tried connecting your mb to your iPhone hotspot and seeing if you get calls then?
     
  9. Allograft thread starter macrumors regular

    Joined:
    Oct 19, 2014
    #9
    Update to all, it was a router firmware issue. I installed a new firmware on the 87u and things work much, much better now. For anyone with the AC87U, you should definitely update to the .4950 firmware
     

Share This Page