Yosemite private mode Safari script

Discussion in 'OS X Yosemite (10.10)' started by Cris65.nl, Oct 17, 2014.

  1. Cris65.nl macrumors newbie

    Joined:
    Oct 17, 2014
    #1
    who can help me? my old script isn't works anymore I have now the Dutch version of Yosemite:confused:

    the script below was the old script, but after installing Yosemite I get an error message in Dutch

    tell application "Safari"
    activate
    end tell

    tell application "System Events"
    tell process "Safari"
    tell menu bar 1
    tell menu bar item "Safari"
    tell menu "Safari"
    click menu item "Privémodus"
    end tell
    end tell
    end tell
    end tell
    end tell
     
  2. blackboxxx macrumors regular

    Joined:
    Sep 10, 2008
    #2
    There's no "Private mode" in Safari anymore, instead there are private windows, just like in Chrome.

    Because the menu items have changed, you need to update your script. I don't know what it's called in Dutch, but in English it is File > New Private Window.
     
  3. Cris65.nl thread starter macrumors newbie

    Joined:
    Oct 17, 2014
    #3
    script

    thank you very much for your quick reply blackboxxxx
    I tried to change all kind of settings but my knowledge is to small :eek: and get all kind of errors:(

    is it possible for you to send me a working example?

    thanks in advance

    Cris
     

Share This Page