Yosemite Screwed Up iCloud Keychain

Discussion in 'OS X Yosemite (10.10)' started by JSchwartz15, Jul 25, 2014.

  1. JSchwartz15 macrumors regular

    Joined:
    Mar 21, 2012
    #1
    I installed the Yosemite Public Beta on an external drive yesterday. When setting it up I tried to turn on iCloud Keychain. It resulted in turning it off across all my devices and now I can't turn it back on, I continuously get the error message that it can't communicate with iCloud. Anyone else having this issue?
     
  2. Erphern macrumors 6502

    Joined:
    Mar 6, 2013
    Location:
    UK
    #2
    Yes. It's going to be a real drag if my keychain somehow ended up being wiped.
     
  3. rainking macrumors regular

    Joined:
    Aug 12, 2011
    Location:
    Johnson City, NY
  4. matt2053 macrumors 6502a

    Joined:
    Jul 8, 2012
    #4
    I had the same problem. iCloud Keychain failed to turn on when I installed the beta. Then when I checked my iPhone, it was "off" there too! And I could not get it to turn back on.

    Finally I got my iPAD out, and it was off there too. But when I turned it on on my iPad it finally worked, and I was able to turn it on on my other devices as well.

    The one thing I will say is that once you get it on, everything will be back to normal. Nothing is erased when you turn it off. Everything stays on the device, I believe.
     
  5. Crosscreek macrumors 68030

    Crosscreek

    Joined:
    Nov 19, 2013
    Location:
    Margarittaville
    #5
    You should be able to reauthorize it through another device like a IPad or Phone if you have one. That's what I had to do.
     
  6. Erphern macrumors 6502

    Joined:
    Mar 6, 2013
    Location:
    UK
    #6
    Aha. Couldn't get that to work from my iPhone, but I have another computer running Mavericks, and I was able to switch things back on from there.

    Bit fiddly, having to mess around with approvals and whatnot, but it works now.
     
  7. jg321 macrumors 6502

    Joined:
    Aug 29, 2012
    Location:
    UK
    #7
    Just double checked, using Yosemite on two computers here, along with iCloud keychain, and everything's working as expected, i.e. still enabled on my iPhone and working on these machines.

    Wonder what caused the failures above? Hopefully you've all reported them?
     
  8. MagicBoy macrumors 68040

    MagicBoy

    Joined:
    May 28, 2006
    Location:
    Manchester, UK
    #8
    Yep. Same problem.

    Clean install into a secondary partition. Mavericks and my iPhone have stopped syncing and won't re-add.

    In case it's a factor - I've not enabled iCloud drive, as my iPhone 4 won't support iOS 8.
     
  9. scott523 macrumors 6502a

    Joined:
    Sep 8, 2006
    Location:
    Saint Charles, MO
    #9
    I had this Keychain problem early this morning but it was easily solved and reported.

    Key step is to enable Keychain by requesting approval from another device and not using the verification codes sent to your phone (if enabled).

    Be sure not to click "Reset iCloud Keychain" or it'll throw you back to the stone age. Just kidding. :rolleyes:
     
  10. IvarO, Jul 25, 2014
    Last edited: Jul 25, 2014

    IvarO macrumors newbie

    Joined:
    Jul 25, 2014
    #10
    scott532, what do you mean by this:

    I can't see any other way to enable my Keychain than by entering the PIN that the Yosemite Beta asked me to create during configuration after restart during the install of OS X Yosemite Beta (on an external HD, running on my MacBook Pro 2009), and then entering the confirmation code sent to my iPhone.

    I have tried from my iPad and iPhone (both with latest version of iOS 7), and from my MacBook Pro when running Maverics on it, but only get error messages. The problem is reported to Apple.

    By the way, is there a limit to the number of times I am allowed to try to turn the Keychain on? It seems there is not, as I have tried more than 20 times...
     
  11. scott523, Jul 25, 2014
    Last edited: Jul 25, 2014

    scott523 macrumors 6502a

    Joined:
    Sep 8, 2006
    Location:
    Saint Charles, MO
    #11
    Skip the Yosemite Keychain setup, do not use confirmation codes sent to your iPhone and certainly do not waste your time contacting Apple on this matter. Of course, do report this.

    1. Since Yosemite Keychain setup probably disabled Keychain on everything, you need to get Keychain back on your Mavericks and iOS devices by requesting approval between each other. I only have one Mac so Yosemite didn't conflict with this step, if any.

    2. Once you get them under control, you can go back to Yosemite and request approval using the devices in step 1. In my case, I approved Keychain from my iOS devices since Mavericks is not available.
     
  12. garyleecn macrumors 6502a

    Joined:
    Jul 25, 2014
    #12


    i just worked out a solution.
    you just need to DISABLE all iCloud keychains on ALL your devices, and erase those passwords on all devices EXCEPT one. (what i did is i left the passwords on my iMac). and then you re-enable iCloud keychain on the device that you have left your passwords (in my case, the iMac). then you should be able to enable iCloud keychain on yosemite. though it will say 'error loading iCloud preference panel', but when you go back there, the iCloud keychain should be successfully synced.
     
  13. SanFran95 macrumors member

    SanFran95

    Joined:
    Jul 18, 2014
    #13
    Non of those solutions works for me - I'm able to turn iCloud Keychain on in Yosemite Beta, and it's still turned on after restarting my Mac. I'm also able to turn in on on my iPhone. But after restarting my iPhone says iCloud Keychain was reset - and then I'm back were I started. Guess it's because I'm not able to request an approval from another device - I only get two options when I try to turn it on; Restore iCloud Keychain with Security Code, or Reset iCloud Keychain.
     
  14. IvarO, Jul 26, 2014
    Last edited: Jul 26, 2014

    IvarO macrumors newbie

    Joined:
    Jul 25, 2014
    #14
    scott523, thank you for your advice! I was a bit at loss how to avoid using the confirmation codes sent to my iPhone, as it seemed I didn't have any alternatives. But I finally figured it out:
    On the iPhone: Open settings --> iCloud --> account, tap Keychain at the bottom of the page, and then turn "approve with security code" on (I'm not sure that is exactly what it says, my iPhone is Norwegian, but something along those lines.)
    That way, I didn't get (and of course didn't need) the 6 digit code via SMS when activating the iCloud Keychain, but instead was asked to enter my four digit pin twice, and could approve from my MacBook. Problem solved, and no Keychains erased! After that, I could turn on iCloud Keychain in Maverics as well. I'm not at home now, so I don't have access to my iPad or the drive with Yosemite on it, but I think (or hope!) it will probably work there as well. Will have to try your step 2 tomorrow.

    SanFran95, maybe turning off the option mentioned above could help you as well. It seems the verification via SMS with security code is broken, and this is the way to bypass that. I didn't know about it, and it wasn't very obvious (to me, anyway.)
     
  15. richtea123 macrumors newbie

    richtea123

    Joined:
    Apr 26, 2012
    Location:
    Chelmsford, UK
    #15
    I had lots of problems with keychain as well after installing Yosemite. Keychain turned itself off on all my devices, and wouldn't turn back on with the security code/SMS combination. The option to authorise from another device wasn't available after setting up the security code.

    I've managed to get it working again by resetting Keychain on the Mac (in Mavericks), and choosing NOT to set up a security code. This restored the option to authorise Keychain on iOS devices from the Mac rather than using the Code/SMS method. It has re-synced my passwords from the Mac to iCloud, so hopefully I won't have lost anything.
     
  16. VirtualRain macrumors 603

    VirtualRain

    Joined:
    Aug 1, 2008
    Location:
    Vancouver, BC
    #16
    I've had a similar issue just now after installing Yosemite beta. Setting up a PIN turned off iCloud Keychain on all my other devices and trying to use the PIN code I entered during Yosemite setup would not work on my iDevices. So on my iPhone, I turned off the setting under Settings - iCloud - Account - Keychain and then went through the setup again on my iPhone to set the PIN (used the same PIN as I did setting up Yosemite) then my iPhone keychain activated, and I could use my iPhone to authorize other devices like my iPad and then had to reauthorize the Yosemite iCloud Keychain under Preferences - iCloud also using my iPhone to approve it. Crazy, but there are obviously work-arounds. :)
     
  17. superyamid macrumors newbie

    Joined:
    Jul 31, 2014
    #17
    I have the same problem :( I updated my Mavericks install to Yosemite, so I can't follow any of the instructions above. On my iPhone, the option to turn off approval with security code is blocked, I can't deactivate it...
     
  18. zorinlynx macrumors 601

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #18
    This is why I'm not touching any of the iCloud stuff in Yosemite until after release.

    I'll let other people trail blaze testing iCloud; I'll test other features and not risk my iCloud data. At least not on my main account.
     
  19. chrisidefix macrumors newbie

    Joined:
    Mar 16, 2011
    #19
    I had the exact same problem and lost access to iCloud Keychain for a while. After trying from iPhone, iPad and my MacBook, I had no luck initially to restore my keychain (the recommended authorisation from a different device didn't come up as an option).

    Eventually, I noticed that Safari still had stored all my passwords and they were not really gone, though. So, for a while I just used the build in password storage in Safari. I also managed to backup all passwords to a secure location by now and that gave me confidence to experiment a little.

    (1)
    To re-activate iCloud keychain, I eventually had to "reset" (!) it under Mac OS X 10.10 Yosemite (at least that's where I did it). Then, I temporarily re-enabled it without a pass-code as richtea123 recommended, but afterwards turned it off completely under Yosemite.

    (2)
    I then logged back into my MacBook and turned Keychain on - it asked me to setup a passcode, which I did and expected to find an empty iCloud Keychain. However, to my surprise, all passwords were actually available again and I am happily using iCloud Keychain now (leaving it turned off under Yosemite for now, though).

    (3)
    :D
     
  20. leman macrumors 604

    Joined:
    Oct 14, 2008
    #20
    I didn't remember my PIN, so I had to reset the Keychain. Well, shoot, all passwords gone #
     
  21. lindberghsjump macrumors newbie

    Joined:
    Aug 11, 2014
    #21
    Problem Solved

    Hey everyone, I was having this same issue. I tried installing Yosemite Beta on an external drive, and it suddenly signed me out of iCloud keychain on all my devices. I tried resigning in for two weeks using the texted code, but to no avail. Finally, I called Apple Support and was on the phone with them for over an hour. Still no help and no answers. I decided to just "reset" iCloud keychain under the "forgot code" prompt. Once I did that I was able to resign in and, since all my logins and passwords were already saved in keychain access, they were all reuploaded and no information was lost. What a pain! But everything is now working property again.

    To be safe, I made a backup of the "login.keychain" file before resetting just to be safe. Instructions on how to copy it are found here: http://osxdaily.com/2012/07/05/copy-keychain-login-passwords-between-macs/

    Hope this helps you guys!
     
  22. Dreadx37 macrumors newbie

    Joined:
    Aug 20, 2014
    #22
    The solution that worked for me was removing my iCloud login entirely from my Mac with Yosemite. Then with my iPhone I went to Settings > iCloud > Account (at the top where it shows your email) > Keychain > then I toggled "Approve with Security Code" off and then back on which prompted me to generate a new pin.

    The pin then worked on my iPad and Yosemite when I turned keychain back on with them.
     
  23. mediotanque macrumors member

    Joined:
    Oct 31, 2013
    Location:
    Uruguay
  24. guid0 macrumors newbie

    Joined:
    Jul 27, 2011
    #24
    I've been struggling with this for weeks now. No matter what i try I can't get the keychain back on. I can't turn Keychain off in iCloud on Yosemite, hence I can't log out of iCloud in in Yosemite. It's been permanently on "approve from another device" for ages now. If I turn it off on any of my other devices when I turn it back on it just says "authorise from another device". Everywhere.

    I even reset my Keychain from Keychain Access and had no luck.

    I've used pre-releases of the last four versions of OS X and none have come close to being such a nightmare as Yosemite!
     
  25. justingarcia macrumors newbie

    Joined:
    Apr 2, 2007
    #25
    Spoke to Apple tech support…possible solution

    I believe I was having the same issue. I spoke to Apple tech support and this was the solution:

    Turn off iCloud Keychain if it’s on on all of your devices.
    From one of your iOS devices, go to Keychain and tap Approve with Security Code.
    When prompted for the 4-digit iCloud Security code tap Forgot Code.
    Follow the prompts to reset the code (the easiest thing is to use the same code that you use for the device you’re on).
    Now this device should have iCloud Keychain enabled and working.
    Now from your other devices, enable iCloud Keychain.
    You should get a notification on the working device about this.
    Enter your iCloud password in the prompt.
    iCloud Keychain should now be enabled on this device.
    Repeat for your other devices.
     

Share This Page