Yosemite security updates

Discussion in 'OS X Yosemite (10.10)' started by FerraM2, Jul 12, 2017.

  1. FerraM2 Suspended

    Joined:
    Jun 15, 2017
    #1
    Hi all,

    I am new to this forum. I was wondering if anyone could please help me.

    My problem is I am finding it difficult to download older security system updates from the App store. It keeps stalling whenever the internet is having connectivity issues and it asks to restart computer whenever it does this several times and it does not seem to complete fully. There are several completed mini downloads of the same update each time it is restarted but it doesn’t seem to finish. In the App store here is always a message indicating there is “1 new” download. This has been going on for a few days, and I still seem stuck on the same update. I was wondering if this was the normal way this worked. The update is “OS X Update Combined 10.10.5” for Yosemite. It is 2.12 GB so thought it might take awhile since my internet speed is slow, but after hours of downloading it once fully and thinking it done, it goes back to the same update again. Will I eventually be able to complete this update?

    I downloaded iTunes update from App store just fine, but having difficulty downloading the 2015 combo software updates.

    Tried downloading it from apple website but once updates are complete downloading I cant open it. I get the warning message, “the following disk image couldn’t be opened” and “image not recognised” in it. So that does not seem to be an option either.

    I’d really appreciate some feedback or suggestions to help with the issue. Thanks for reading.
     
  2. Ebenezum macrumors 6502a

    Joined:
    Mar 31, 2015
    #2
    I suspect that your internet connection might be causing the problem. Or it might be a fault in the Mac App Store software update which is unfortunately unreliable.

    Have you tested downloading the combo update in a different location which has faster internet? (Friends house, workplace etc.)

    Alternatively you could try first rebooting Mac in safe mode by pressing shift key during the boot, release shift once you see the login screen. Safe boot deletes caches & other files which might cause the problem.

    Then you can try the update again. I'm surprised that downloading combo update didn't work, in my experience it is more reliable than Mac App Store. Are you sure you downloaded correct update?
     

Share This Page