Yosemite still downloading...I started 10 and a half hours ago

MartinAppleGuy

macrumors 68020
Original poster
Sep 27, 2013
2,243
888
Still going... On the last GB but says 4 hours remaining :/ Was anyone else's 'time remaining' figure inaccurate?
 

MartinAppleGuy

macrumors 68020
Original poster
Sep 27, 2013
2,243
888
Try changing your DNS, for example http://pcsupport.about.com/od/tipstricks/a/free-public-dns-servers.htm to

Comodo Secure DNS8.26.56.26

It helped me. Plus, I contacted Apple about it and got an email couple hours ago telling me that they've fixed it. I guess not.
I'm back to four hours -_- My internet should take around 1 hour per GB (around 3Mbps) but it seems to be taking forever. If I pause the download then restart the router, will the download still be fine?
 

gbailey141

macrumors member
Aug 13, 2013
90
27
Hampshire UK
Yes it definately does. I have just paused mine and when you re-start it says zero and then clicks back to how far you were in the download.
 

Prabas

macrumors 6502a
Sep 14, 2010
987
606
Europe
Yosemite still downloading...I started 10 and a half hours ago

Sure, but it's not that. Their CDN servers are fine, as I had 100Mbps download speed at the peak hours. It has something to do with DNS. Because when you change it, download speed will hike after trying to re-download something.
 

exoriare

macrumors member
Oct 25, 2006
64
0
London
My download time was over 2 days! I paused the download, waited for 5 minutes and then resumed. The DL speed has picked up and it's now on 44 minutes.
 

frank4

macrumors regular
Oct 17, 2011
171
25
I too have a VERY SLOW Yosemite download that might take 2 days. AFAIK my Mac is otherwise running perfectly and my network is fast and I think the download should take less than an hour. I'm averaging 40 KB/sec Yosemite download while the rate should be able to reach 2 MB/sec as indicated by speedtest.net and torrents performance. So I'm only getting one percent of the maximum possible rate.

Network connection to Apple's servers for Apple TV videos like Thursday's keynote is excellent.

I have tried the following:
- quit all common Mac apps except Activity Monitor
- reboot VDSL modem/router
- reboot Mac
- pause/resume Yosemite download many times
- try wired connection to Mac as well as Wi-Fi. Both are working fine and capable of 2 MB/sec
- reset Safari (someone said it helped him but I'm not sure why)
- Force Quit process "storeagent" (which does the downloading)

Any ideas?? I am thinking there is a problem at Apple's end, but only a few people seem to be having the slow download issue.


***UPDATE*** ***IT IS WORKING***
The problem has something to do with DNS. My previous DNS settings (on the Mac, not in router) might have been somehow connecting through a part of the internet in Western USA that has a problem (Comcast??), I am in west Canada near Vancouver. I reset the DNS to the public Google DNS settings 8.8.8.8 and 8.8.4.4 and the download is now running about the expected 2 MB/sec. HURRAY!!!!
 
Last edited: