Resolved Yosemite Stuck at Boot Screen

Discussion in 'OS X Yosemite (10.10)' started by MacDev1337, Jun 21, 2014.

  1. MacDev1337, Jun 21, 2014
    Last edited: Jun 21, 2014

    MacDev1337 macrumors newbie

    Joined:
    Jun 21, 2014
    #1
    I was working on my laptop all night. When I was done I shut it down and went to bed. Whenever I got up this morning though and turned on my MacBook Pro it loaded the progress bar to 50% (as usual) and paused. I wasn't surprised it paused, but after I went to get something to eat and I came back, it was still at the boot screen with the progress bar at 50%. So I thought "I'll hard shutdown and see if it boots this time", after doing so I get the same result, this time I just thought to myself patience would be the key, so I sat and waited, and then my cursor came up on the boot screen.
    I can move the cursor around and about, but nothing is happening.
    Yes, I know Yosemite is beta, and you shouldn't install it on work machines, but I needed Xcode6-beta and that was the only way to get it. I have a lot of important files on this computer and restoring isn't going to be an option I'll be fond of.

    [​IMG]
     
  2. w0lf macrumors 65816

    w0lf

    Joined:
    Feb 16, 2013
    Location:
    USA
    #2
    :) < your face when you realize restoring doesn't remove user files
     
  3. MacDev1337 thread starter macrumors newbie

    Joined:
    Jun 21, 2014
    #3
    Are you serious?
    I can honestly say I've never had to restore a Mac (thank goodness) so I'm used to the Windows "clear the problem as well as your files" sort of method.
    How would I go about restoring from the boot screen then?
     
  4. MacDev1337 thread starter macrumors newbie

    Joined:
    Jun 21, 2014
    #4
    I just attempted to boot into the Recovery disk and reinstall OS X, but it says I need to contact Apple Care because my computer information couldn't be verified.
    What do I do now?
     
  5. kyelewis macrumors newbie

    Joined:
    Jun 13, 2014
    #5
    I had this issue in the first beta... I was auto-booting in to the Guest account, and it turned out that in the background a dialogue box had popped up asking for access to the 'login' keychain.

    Pressing escape many many times got me back in to the OS.
     
  6. HighFlyingBirds macrumors regular

    HighFlyingBirds

    Joined:
    Dec 2, 2011
    #6
  7. MacDev1337 thread starter macrumors newbie

    Joined:
    Jun 21, 2014
    #7
    Coming back to my computer after about the fifth attempt to recover my MacBook and it turns on. I have no idea why this happened but here's my note to everyone who finds this post via a search engine.

    SOLUTION TO FIX:
    Just keep booting. I did nothing different between each boot except the amount of time I let it sit.

    Replace swim with boot.
    https://www.youtube.com/watch?v=0Hkn-LSh7es
     
  8. Fimeg macrumors regular

    Joined:
    Jun 12, 2013
    #8
    This also happened to me... but my issue was self inflicted. I changed the System Version to 10.9 so I could install a few apps that I "knew" would work. Well, it turns out when I quit Terminal after changing the version, I couldn't launch it again because It was designed for 10.10.... whoops. I struggled to get Finder to work, succeeded, but then couldn't launch TextEdit. Next I tried Safari to download Text Wrangler.... Safari crashed before finishing the download... so no safari. Ended up rebooting and getting hung up. Fixed it with Firewire Target Disk Mode.


    My point ^ is.... If you do get completely locked out, use Firewire Target Disk Mode to retrieve your files. It's simple.
     
  9. ilikecorn500 macrumors member

    ilikecorn500

    Joined:
    May 16, 2011
    #9
    Okay, I have the same problem. I'm using the Public Beta, on my Early 2009 iMac. Before, when I booted it, it would freeze about halfway. Now, the bar advances about a quarter of the way, then the computer shuts off. Any advice?

    ----------

    The installation should be on my 32GB Flash Drive, but when I press option on boot, the "OS X Installer" shows up instead of my Mavericks "Macintosh HD". Is this normal? It doesn't seem like it.

    ----------

    More info, sorry about the fast updates. I'm managed to boot into that "OS X Installer". It looks like in Disk Utility, my Macintosh HD is still fine, but there are installer disks listed there as well. I tried to install Yosemite a second time on the Flash Drive, without formatting it. It showed an error, so I changed the startup disk to my Macintosh HD and restarted. I guess I'm calling it quits for now. My computer is fine, but any help to get Yosemite on the Flash Drive would be appreciated.
     
  10. sk1wbw Suspended

    sk1wbw

    Joined:
    May 28, 2011
    Location:
    Williamsburg, Virginia
    #10
    Try booting an resetting the pram. I had this issue and that worked.
     
  11. dmckinneysr macrumors newbie

    Joined:
    Apr 19, 2009
    #11
    Original Issue Not Resolved Yet


    I'm having same issue. I'm using a 32gb 2.0 thumb drive, with a 6gb partition (for Yosemite Install Bootable) and 26gb partition to install it on. First of all the install took FOREVER. Then when finally done it restarts and I have same issue above. I have restarted it a couple of times, and I have rebooted back to option screen and selected the "Yosemite Install" as I read in another forum, NO DICE so far!! Any thought or ideas
     
  12. bachozeus macrumors newbie

    Joined:
    Sep 8, 2014
    #12
    yosemite stuck at loading OS X

    I installed Yosemite on two other macbook (macbook pro 2012 and macbook air 2012) everything went well, and I tried to install it on my macbook pro core duo, it stuck/freeze when i try to boot from usb that contain the dmg file. so try to switch back to original hard drive hope it solve the problem, it stuck/freeze on the circle wheel. try to do PRAM rest, and drain the battery, still the same thing. I thought the RAM failed, change the ram still the same thing.. can't believe of what happened, I grab another macbook pro core duo do exactly something with the exact result... INSANITY IS DOING SOMETHING OVER AND OVER AGAIN EXPECTING DIFFERENT RESULT. any help??
     
  13. fishym macrumors newbie

    Joined:
    Oct 22, 2014
    #13
    Same issue, tried just about everything

    I too had a successful install on another machine but my MacBook Pro will not boot and always gets stuck at a black screen with a circle with a cross through it. When I go into single use verbose mode it says it is waiting on the disk (or something to that effect). Disk Utility when I Cmd-R shows the drive is fine and it even makes corrections to permissions so I know it is seeing the drive just fine. I originally installed 10.10 as an upgrade but that failed. So now I tried to boot it off a USB and installed it that way and still same issue. I of course have tried to reset NVRAM/PRAM to no avail too...

     
  14. ray.lol macrumors newbie

    Joined:
    Oct 23, 2014
    #14
    I have the exact same issues after installing Yosemite.

    Whenever I boot the system hangs at various stages. So far I have been able to boot up but in order to do so, I have to force shutdown, (holding the PWR button)

    I then hold the shift & reboot until I see the apple logo, then I release the shift. The system boots into the safe mode. At this point, I restart the system (click the apple logo & select restart). The system now restarts normally but takes from 2 - 5 minutes but generally it does restart.

    At this point, I am going to try reinstalling Yosemite to see if this repairs my boot up issue.
     
  15. ray.lol macrumors newbie

    Joined:
    Oct 23, 2014
    #15
    Yosemite Hangs on Bootup (RESOLVED)

    Ok, so just to follow up from my last post.

    After using the Shift option during reboot and restarting normally, as a mentioned earlier, I downloaded and reinstalled Yosemite. The installation did have 1 hiccup; during the reboot, it hung once more, so I had to use the PWR button to power down, rebooted with the shift option and once online, I restarted normally and all was well. I've just rebooted 5 times normally (without the shift option) and each time my mac mini came up and was ready to duty
    : - )))

    Hope this helps you...
     
  16. Teyla macrumors newbie

    Teyla

    Joined:
    Jun 15, 2010
    #16
    I too have experienced this problem on a few of my iMacs in my computer lab. The safe mode boot, followed by a restart usually fixes the problem.

    I wish we could find out the cause of this problem and report it back to Apple.
     
  17. thecount99 macrumors newbie

    Joined:
    Oct 25, 2014
    #17
    This is a serious bug....I hope Apple is listening!

    Same thing happened to me one day after upgrading from 10.9.5 to Yosemite. All of a sudden my screen just showed the crossed out circle icon. Nothing to do other than reboot, and then the progress bar and the same symbol. Tried this several times. In the end I decided to use my emergency boot backup which was done just before upgrading. Did a repair disk on the other drive, and it checked out OK but after a new reboot same problem. Just reformatted the drive and copying everything back from the backup. This is a terrible bug for any user not experiences with these types of problems. Actually not acceptable and Apple is silent.
     
  18. Sangoma macrumors member

    Joined:
    Dec 27, 2012
    #18
    I've had the same issue. Sometimes it does not wake properly from sleep, and then does not boot either. Once the PRAM reset worked, but in a really bad case even a reinstall did not help, but oddly a restore from time machine from the day before brought it back to life.
     
  19. SulaimanK macrumors newbie

    Joined:
    Sep 23, 2014
    #19
    Well, If you switch to Safe Boot and load it from there, It will complete the installation. To load into safe boot, Simply press Shift button immediately after you heard the boot noise and keep it hold until you get attended into login screen. Once you're in the safe boot you can restart the computer it will automatically switch to regular boot.

    Thereabout the loading will be completed soon as you switched into regular boot, Just be patient!
     
  20. Sangoma macrumors member

    Joined:
    Dec 27, 2012
    #20
    Well, it did it again today. So I have tried the safe start and it is running again. Let's see what happens next:)
     
  21. thecount99, Oct 26, 2014
    Last edited: Oct 28, 2014

    thecount99 macrumors newbie

    Joined:
    Oct 25, 2014
    #21
    Possible culprit and cure

    after more research it appears that the trim enabler might (as in maybe, not sure) be the cause of this....

    and a possible solution could be (not verified) booting into safe mode and then reboot normally. I did another Yosemite installation but removed the Trim enabler and also did a permission repair first. So far so good, let see what happens in the next couple days.

    hope this helps anybody about to lose their sanity ;-)

    Update:
    DAY 2 after second install. Computer was strangely sluggish in the morning after being on for 24 hours (went to sleep mode during the night). Rebooted and got the weird text all over the screen problem and then rebooted again but into the desktop...(I was already seeing a huge problem coming)...

    Apple is becoming more like MS now it seems where you have to wait for the X.1 release to be on the safe side.
     
  22. murilo macrumors newbie

    Joined:
    Oct 27, 2014
    Location:
    brazil
    #22
    Did any of you guys had the problem with the kernel_task before? After installing the Yosemite that problem came back and I had the impression that fixing it under the safe mode resolved the boot problem.
     
  23. fishym macrumors newbie

    Joined:
    Oct 22, 2014
    #23
    Resolved for a few hours...

    So after many attempts of reinstalling and reformatting, etc. I could not get the damn thing to boot. So I gave in and went to the Apple Genius. They said they hadn't seen this problem, though the lady sitting next to me had the exact same issue!

    Both of our laptops ran through diagnostics and basically crapped out waiting for the SD card (so said the Genius). So he went into repair mode, changed the disk format from logical volume (which Yosemite changes it to) to GUID and then put a 10.9.6 image on and it booted just fine. He told me to go home and install Yosemite... So I did the Yosemite install, no problems, it rebooted fine. Then I went to restore my data and after waiting 2 hours the machine rebooted back to the circle of death. I wanted get in the fetal position... Anyhow, now booted repair mode and made the disk GUID like the Genius did and am now waiting for the 3 hours to see if restore to 10.9. (whatevs was last) will work. I can't mess around with Yosemite on this laptop anymore, I will wait for Apple to issue a fix or maybe they will just pretend this problem is not epidemic...and chipping away at the Apple trust.

    Yosemite is great when it works, like it does on my MacPro tower, but this MBP with Yosemite makes me want to go buy a PC or something, this is making me lose faith in Apple not being frustrating as Winblows.
     
  24. Sgtarky macrumors regular

    Joined:
    Dec 24, 2011
    #24
    I too have the same issue. clean install of lion followed by install of Yosemite. unfortunately my power button is inop, so I have to take the bottom off and unplug my battery and restart..sooooo annoying
     
  25. Sangoma macrumors member

    Joined:
    Dec 27, 2012
    #25
    Looks like it's becomming a daily thing. I will have to shut down at nights. Normally I just sleep.
     

Share This Page