Yosemite takes forever to connect to internet after sleep

Discussion in 'OS X Yosemite (10.10)' started by MoodyM, May 16, 2015.

  1. MoodyM macrumors 6502a

    MoodyM

    Joined:
    Aug 14, 2008
    #1
    Every time I wake my late-2013 rMBP from sleep (whether by opening the lid after being shut for a long time or by pressing the keyboard after it's shut off after a short time) it take FOREVER to connect to the internet.

    The WiFi itself usually connects quickly, but it takes an age for the internet to become available.

    I have a BT Home Hub 5 router and I've tried having separate SSIDs for he 5GHz band and 2.4GHz as well as having a single SSID for both, the problem happens either way. It also happens at my mum's house, she has a Linksys X3500 router.

    The length of time it can take to find the internet after wake from sleep varies from 10-15 seconds to 5 or 6 minutes.

    No other device in the house (iPads, iPhones, Windows laptop) exhibits this issue.

    I've tried turning Bluetooth off, didn't help. I've tried deleting the Bluetooth PAN in Network Settings, didn't help.

    I've removed all known WiFi networks except mine, didn't help.

    This happened a few months ago too, and I wiped my Mac back to factory settings and started fresh - this fixed it for a few weeks, but now it's doing it again.

    OS X 10.10.3

    Any ideas?
     
  2. Beavix macrumors 6502a

    Beavix

    Joined:
    Dec 1, 2010
    Location:
    Romania
    #2
    I had the same problem on my Late 2013 rMBP.
    Here is how I fixed it: go to /Library/Preferences/SystemConfiguration and delete the following files:

    - com.apple.airport.preferences.plist
    - com.apple.network.eapolclient.configuration.plist
    - com.apple.wifi.message-tracer.plist
    - NetworkInterfaces.plist
    - preferences.plist

    Some of them may be missing from your system. Just delete the ones you can find. Then restart.
     
  3. MoodyM thread starter macrumors 6502a

    MoodyM

    Joined:
    Aug 14, 2008
    #3
    Thank you. I'll try that (although it's only a few weeks since I did a clean install of Yosemite...)
     
  4. MontyC macrumors member

    MontyC

    Joined:
    Jun 17, 2009
    Location:
    London Uk
    #4
    Same problem here

    On 13" rMBP 10.10.4 (had problem with 10.10.3 and 2). Same issue even if trying to connect on Ethernet with Wi-Fi off.

    EtreCheck:

    EtreCheck version: 2.2 (132)
    Report generated 5/16/15, 2:09 PM
    Download EtreCheck from http://etresoft.com/etrecheck

    Click the [Click for support] links for help with non-Apple products.
    Click the [Click for details] links for more information about that line.

    Hardware Information: ℹ️
    MacBook Pro (Retina, 13-inch, Early 2015) (Verified)
    MacBook Pro - model: MacBookPro12,1
    1 2.9 GHz Intel Core i5 CPU: 2-core
    8 GB RAM Not upgradeable
    BANK 0/DIMM0
    4 GB DDR3 1867 MHz ok
    BANK 1/DIMM0
    4 GB DDR3 1867 MHz ok
    Bluetooth: Good - Handoff/Airdrop2 supported
    Wireless: en0: 802.11 a/b/g/n/ac
    Battery: Health = Normal - Cycle count = 16 - SN = D865062W6GJFY5G4E

    Video Information: ℹ️
    Intel Iris Graphics 6100
    Color LCD 2560 x 1600

    System Software: ℹ️
    OS X 10.10.4 (14E17e) - Time since boot: 0:47:17

    Disk Information: ℹ️
    APPLE SSD SM0512G disk0 : (500.28 GB)
    EFI (disk0s1) <not mounted> : 210 MB
    Recovery HD (disk0s3) <not mounted> [Recovery]: 650 MB
    Macintosh HD (disk1) / : 499.07 GB (190.09 GB free)
    Encrypted AES-XTS Unlocked
    Core Storage: disk0s2 499.42 GB Online

    USB Information: ℹ️
    Apple Internal Memory Card Reader
    Broadcom Corp. Bluetooth USB Host Controller

    Thunderbolt Information: ℹ️
    Apple Inc. thunderbolt_bus

    Gatekeeper: ℹ️
    Mac App Store and identified developers

    Kernel Extensions: ℹ️
    /Applications/VMware Fusion.app
    [not loaded] com.vmware.kext.vmci (90.5.7) [Click for support]
    [not loaded] com.vmware.kext.vmioplug.12.1.19 (12.1.19) [Click for support]
    [not loaded] com.vmware.kext.vmnet (0268.43.43) [Click for support]
    [not loaded] com.vmware.kext.vmx86 (0268.43.43) [Click for support]
    [not loaded] com.vmware.kext.vsockets (90.5.7) [Click for support]

    /Library/Extensions
    [not loaded] com.Belkin.ExpressDockChargingSupport (1 - SDK 10.9) [Click for support]

    Launch Daemons: ℹ️
    [loaded] com.adobe.fpsaud.plist [Click for support]
    [running] com.bombich.ccchelper.plist [Click for support]
    [loaded] com.microsoft.office.licensing.helper.plist [Click for support]

    User Launch Agents: ℹ️
    [loaded] com.citrixonline.GoToMeeting.G2MUpdate.plist [Click for support]

    User Login Items: ℹ️
    PopClip Application (/Applications/PopClip.app)
    iTunesHelper Application (/Applications/iTunes.app/Contents/MacOS/iTunesHelper.app)
    BetterTouchTool Application (/Applications/BetterTouchTool.app)

    Internet Plug-ins: ℹ️
    SharePointBrowserPlugin: Version: 14.5.0 - SDK 10.6 [Click for support]
    FlashPlayer-10.6: Version: 17.0.0.188 - SDK 10.6 [Click for support]
    Flash Player: Version: 17.0.0.188 - SDK 10.6 [Click for support]
    QuickTime Plugin: Version: 7.7.3
    Silverlight: Version: 5.1.30514.0 - SDK 10.6 [Click for support]
    Default Browser: Version: 600 - SDK 10.10

    User internet Plug-ins: ℹ️
    CitrixOnlineWebDeploymentPlugin: Version: 1.0.105 [Click for support]
    WebEx64: Version: 1.0 - SDK 10.6 [Click for support]

    3rd Party Preference Panes: ℹ️
    Flash Player [Click for support]
    MenuMeters [Click for support]

    Time Machine: ℹ️
    Skip System Files: NO
    Mobile backups: ON
    Auto backup: YES
    Volumes being backed up:
    Macintosh HD: Disk size: 499.07 GB Disk used: 308.98 GB
    Destinations:
    Data [Network]
    Total size: 3.00 TB
    Total number of backups: 76
    Oldest backup: 2014-04-21 13:41:14 +0000
    Last backup: 2015-05-16 06:47:51 +0000
    Size of backup disk: Excellent
    Backup size 3.00 TB > (Disk size 499.07 GB X 3)

    Top Processes by CPU: ℹ️
    4% WindowServer
    2% fontd
    1% com.apple.WebKit.Plugin.64
    0% OneDrive
    0% nsurlstoraged(2)

    Top Processes by Memory: ℹ️
    779 MB kernel_task
    451 MB com.apple.WebKit.WebContent(4)
    180 MB Mail
    164 MB mds_stores
    164 MB Safari

    Virtual Memory Information: ℹ️
    2.12 GB Free RAM
    5.88 GB Used RAM
    0 B Swap Used

    Diagnostics Information: ℹ️
    May 16, 2015, 01:22:23 PM Self test - passed
    May 15, 2015, 03:11:40 PM /Users/[redacted]/Library/Logs/DiagnosticReports/callservicesd_2015-05-15-151140_[redacted].crash
    May 15, 2015, 02:12:47 PM /Users/[redacted]/Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2015-05-15-141247_[redacted].crash
    May 15, 2015, 02:12:15 PM /Users/[redacted]/Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2015-05-15-141215_[redacted].crash
    May 15, 2015, 02:04:15 PM /Users/[redacted]/Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2015-05-15-140415_[redacted].crash
    May 15, 2015, 01:09:03 PM /Users/[redacted]/Library/Logs/DiagnosticReports/com.apple.WebKit.Plugin.64_2015-05-15-130903_[redacted].crash
    May 15, 2015, 10:54:28 AM /Library/Logs/DiagnosticReports/Microsoft AutoUpdate_2015-05-15-105428_[redacted].cpu_resource.diag [Click for details]
    May 14, 2015, 04:55:52 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Mail_2015-05-14-165552_[redacted].crash
    May 14, 2015, 04:55:50 PM /Users/[redacted]/Library/Logs/DiagnosticReports/CharacterPalette_2015-05-14-165550_[redacted].crash
    May 13, 2015, 06:14:45 PM /Library/Logs/DiagnosticReports/OneDrive_2015-05-13-181445_[redacted].cpu_resource.diag [Click for details]
     
  5. abhibeckert, Jun 23, 2015
    Last edited: Jun 23, 2015

    abhibeckert macrumors regular

    abhibeckert

    Joined:
    Jun 2, 2007
    Location:
    Cairns, Australia
    #5
    I'm having this issue also and haven't found any fix.

    I've discovered my mac is connected to the internet but DNS doesn't work. I can ping any IP address but trying to ping a domain name just hangs for a couple of minutes after establishing a network connection.

    Doesn't matter what internet connection, wifi ethernet, bluetooth phone hotspot, usb phone hotspot, etc.

    It's not just wake from sleep, if you disconnect from the internet and reconnect (eg unplug ethernet then plug it in right away) DNS lookups will hang for a few minutes after. It's not related to the remote DNS server as even localhost and anything in /etc/hosts cannot be connected to.

    I wonder if anybody has tried upgrading to the 10.10.4 beta?
     

Share This Page