Yosemite turned my IMac into an expensive paper weight

Discussion in 'OS X Yosemite (10.10)' started by StephanAR, Feb 18, 2015.

  1. StephanAR, Feb 18, 2015
    Last edited: Feb 18, 2015

    StephanAR macrumors newbie

    Joined:
    Feb 18, 2015
    #1
    Hello guys, new member here! Registered myself because I hope someone here can help me with what happened.
    I have a mid 2011 iMac 21".
    I've been using yosemite since the end of last year (november maybe) without any issues, besides some lag that I thought it was the system wanting more memory. I did every update released until now.
    I never turned my mac off, only did that when I was going to be out for more than a week. It always woke up fine until this monday. I hit a key and it wouldn't wake up. Clicked the mouse and nothing. Pressed the power button and it woke up. My wired keyboard and mouse were irresponsive. Bluetooth trackpad also dead.
    After a long research (and looks like a lot of people are having this issue), trying numerous things and spending some time on the phone with the support, nothing worked. Here's what I tried so far:

    - turned on and off a lot, with the keyboard and mouse plugged, or plugging them when the mac reached login screen;
    - removed power cable, waited some time, turned it on, with cables plugged or plugging at login screen;
    - connected keyboard and mouse to another computer, they work fine, but not on my imac;
    - tried a generic keyboard, still nothing;
    - connected some usb device (card reader, pendrive, external hd) on my keyboard usb slot;
    - connected my keyboard and mouse through an extension cord and/or powered usb hub;

    And maybe I've tried some stuff that I don't remember, the thing is the keyboard and mouse don't work.
    Other details that may help diagnosis:

    - the light on the mouse (generic, optical) don't turn on;
    - if I plug a card reader or external hd or usb hub on the mac usb port they light up;
    - plugging my ipad on the usb slot on mac doesn't charge;
    - the mac charges a small bluetooth speaker.

    Apple care expired in the end of last year, but the biggest problem is that I don't have an authorized apple repair near me. The only thing I want is to put the keyboard to work for a little time, enough to factory reset it an go back to lion. Or if anyone knows how to do this without a keyboard...
    Hope someone can give me some light! Looks like apple really screwed it up with this release...

    ----------

    Btw, I can't reset pram because keyboard doesn't work.
     
  2. chabig macrumors 68040

    Joined:
    Sep 6, 2002
    #2
    That sounds like hardware failure to me--probably the logic board, if I had to guess.
     
  3. StephanAR thread starter macrumors newbie

    Joined:
    Feb 18, 2015
    #3
    If that's the issue, is it an expensive repair?
     
  4. w0lf macrumors 65816

    w0lf

    Joined:
    Feb 16, 2013
    Location:
    USA
    #4
    Could also be a loose connection.

    Does using a usb keyboard & mouse work?
     
  5. StephanAR thread starter macrumors newbie

    Joined:
    Feb 18, 2015
    #5
    No, it doesn't. I've always used apple's USB keyboard + generic mouse connected to the keyboard port. Also have an apple trackpad. They always worked fine until now, nothing works anymore.
     
  6. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #6
    Sounds internal USB hub-related to me so possible logic board.

    Reference to Yosemite seems a complete red herring seeing as it was several months ago you upgraded before this problem occurred.
     
  7. StephanAR thread starter macrumors newbie

    Joined:
    Feb 18, 2015
    #7
    Ok, maybe I'm wrong about that and should change the title.
    I assumed yosemite was the cause because when searching for info, I've bumped into a lot of threads where people claimed yosemite killed usb on external displays, on mac itself, killed bluetooth, and other sort of issues (although people could find a fix, or at least a workaround). Besides that, when I updated to mavericks or mountain lion, can't remember exactly, the update killed my wifi. It was adressed in another update.
    Apple released small updates for yosemite, one of them I installed last week. Can't remember the day, but I went on a trip on friday, returned on sunday and there was the problem. Maybe the last update did it?
    But let's assume the problem is the logic board. Is it worth to repair it?
    As I said, I live on a small town that doesn't have have an apple repair shop. I'm trying to figure out what happened and what would be the cost to repair it, to help decide if it's worth the time and hassle to fix it or I'm better buying a new computer, although I can't afford another mac right now.

    Editing to add that I tried to change the title to "(maybe) yosemite turned my imac into an expensive paper weight", but I couldn't find the tool to do that.
     
  8. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #8
    If you think it may be related to one of the updates then Time Machine restore to before the update to confirm it or rule it out.

    Also try booting into Safe Mode and see if it still occurs, creating a separate user account and see if it still occurs.
     
  9. Traverse macrumors 603

    Traverse

    Joined:
    Mar 11, 2013
    Location:
    Here
    #9
    If it isn't a hardware failure, you can go back to Mavericks. Boot into the recovery partition if possible (if you have your data backed up).
     
  10. StephanAR thread starter macrumors newbie

    Joined:
    Feb 18, 2015
    #10
    Traverse and Simonsi,
    I'm not able to do that because I can't get the keyboard nor the mouse to work. It isn't a intermittent problem.
    I asked apple support if there's a way to do that without a keyboard, but that's not possible.
     
  11. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #11
    Screenshare in? Try booting without the mouse and then without the keyboard and see if the other then responds?

    Failing that remove the HDD, mount it on another Mac and rollback/reinstall OS X from there?
     
  12. StephanAR thread starter macrumors newbie

    Joined:
    Feb 18, 2015
    #12
    No screenshare. Booting with just one of them doesn't work. The third option looks complicated, not something I would try.
    Did a search about replacing the logic board an looks like a really expensive fix.
    Found this thread about logic board failures.
    https://www.ifixit.com/Answers/View/6127/How+can+I+tell+if+my+iMac+logic+board+is+dead
    The last post suggested op to remove power cord, wait, attach power cord while holding power button, release, then press it again. Did that, but it started with the fans spinning really fast. It got to login screen, usb ports still doesn't work. But it still powers external hd, card readers, and that's puzzling me...
     
  13. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #13
    USB power and data are different, it may well power/charge stuff but it would seem to me the USB hub logic may be fried.

    Needs to go to service.
     

Share This Page