Yosemite UI Lag - Spinning Beach Ball - General Sluggishness

Discussion in 'OS X Yosemite (10.10)' started by MrDuric, Oct 30, 2014.

  1. MrDuric macrumors newbie

    Joined:
    Aug 4, 2010
    #1
    Hey everyone,

    So just to state right off the bad; I have done a clean install of Yosemite after experiencing the same problems when upgrading directly from Mavericks.

    The thing is, Yosemite on my rMBP 2013 (8gb 256gb SSD) feels incredibly sluggish. Switching to mission control is painstakingly laggy and scrolling through PDF files in viewer has become a real hassle. Also, opening and closing tabs in Safari takes a second or two.

    I dont know what to do about it, I mean I paid good money for this machine and its not even a year old but running this slow on Yosemite. Any suggestions, I'm getting desperate here?
     
  2. alecava macrumors newbie

    Joined:
    Aug 29, 2013
    #2
    Hi, I also have the same problem with my rMBP and I noticed that forcing osx to use the nvidia graphics card makes things go smoother
     
  3. smellalot macrumors 6502

    Joined:
    Dec 6, 2011
    #3
    On my MacBook retina 2012 there is a time machine rollback running right now. The sluggishness was simply unbearable.

    I'm fairly certain that there is nothing you can do about this except wait and hope that apple improves the performance in the future with an update.
     
  4. baummer macrumors 6502a

    Joined:
    Jan 18, 2005
    Location:
    Southern California
    #4
    I'm running a mid-2012 cMBP and I actually think it's running a lot faster and smoother than Mavericks. Maybe there's something that's impacting the rMBPs and not the cMBPs?
     
  5. ijha, Oct 30, 2014
    Last edited: Oct 31, 2014

    ijha macrumors regular

    ijha

    Joined:
    Aug 20, 2009
    #5
    Same here. I have a 2013 rMBP (i5, 8GB ram, 256GB SSD). I once opened a 40mb pdf file and the preview was acting like crazy. Of course, the file under Mavericks had never gave me the same type of trouble. Overall, I can feel that Yosemite is more sluggish than Mavericks.
     
  6. Blue Sun macrumors 6502a

    Joined:
    Feb 11, 2009
    Location:
    Australia
    #6
    Future updates will fix the UI stuttering (on new machines, at least).
     
  7. MrDuric thread starter macrumors newbie

    Joined:
    Aug 4, 2010
    #7
    Yeah its strange really, I've even read that people with brand new maxed out 5k retina iMacs have similar issues. I guess there is not much to do but just wait for an update. Has anyone checked if the rMBP's in the apple stores run Yosemite smoothly?
     
  8. BrianColgate macrumors newbie

    Joined:
    Feb 9, 2013
    #8
    Same with mid-2011 iMac 27 12GB

    I had the same sluggishness with my mid-2011 iMac 27 with 12 GB RAM.
    Last night it was so bad I gave up and shut it down.
    This morning it booted only as far as showing me the wall with an off-centred wallpaper image, then froze. No icons, no mouse response, no keyboard response.
    I shut down, waited a while and booted up again. This time I got as far as a blank white screen with no further response.
    I rebooted while holding Control-R and selected a re-install via the Internet.
    It took over 5-1/2 hours to download and has now rebooted and is installing ... or at least it says it is. There is no sign of progress on the time bar, and beneath it shows "About 22 minutes remaining"
    That has not changed in the now several minutes since the reboot.
    If this reinstall works but does not help, I'll be making the 1-hour drive to the nearest Genius Bar location and asking them to take me back to Mavericks, which worked fine.
    As it turns out, my mid-2011 iMac is not Continuity capable anyway :-(
     
  9. BrianColgate macrumors newbie

    Joined:
    Feb 9, 2013
    #9
    Reinstall failed ... 6 hours wasted

    After 6 hours the re-install finally completed and initiated a reboot which has brought me right back to a plain white screen.
    There is no response to the keyboard,
    I can move the icon around the screen and from the small size of the arrowhead, it seems to be set to maximum resolution.
    :apple:FAIL
     
  10. KoolAid-Drink macrumors 65816

    Joined:
    Sep 18, 2013
    Location:
    California
    #10
    Weird. For me, so far *knock on wood* Yosemite has been smooth as butter on my late-2011 cMBP (13 inch), save a few small system effects that were a bit jerky, but that occurred in SL, Lion, ML, and Mavericks, too.

    Just a FYI, if you have 'purchased' Mavericks, you can go to the App Store, press option while clicking Purchases, then re-download Mavericks, put it on an USB drive, then fire off the installer and reinstall Mavericks.
     
  11. navarretemarce macrumors newbie

    Joined:
    Jan 23, 2012
    Location:
    The end of the world (for real)
    #11
    +1 I am having the very same experience on my rMBP 2013 (8gb 256gb SSD).
    Same behaviour after "upgrading" my 2013 iMAC and my mid2013 MBA.
    After reinstalling Mavericks on my rMBP everything went back to normal. A roll back is going on on my iMAC and MBA right now;).
    I think we need to wait till Yosemite bugs are ironed.
     
  12. unobtainium macrumors 68000

    Joined:
    Mar 27, 2011
    #12
    People have been recommending PRAM resets and apparently having success with that.
     
  13. trevorbsmith macrumors member

    Joined:
    Dec 17, 2007
    #13
    +1 from me too.

    I had the beta and then release version running on my home, mid-2011 Mac Mini. That machine has 8 GIG of RAM and a 1 Terabyte SSD.

    The UI feels and has always felt sluggish on it.

    I finally gave in and installed Yosemite on my work mid- 2013 11" Macbook Air. This machine has 4 Gig RAM and 128 Gig SSD.

    Yosemite UI is also super sluggish here compared to Mavericks (which was slick).

    I'm going to try resetting PRAM as someone else suggested.
     
  14. entropi macrumors 6502

    Joined:
    May 20, 2008
    #14
    Like always! If it's about "retina" it's always about the magical "future updates" that will solve everything... Sounds familiar! (Never seen any update on the first gen rMBP - did the lag actually got updated away, at last?)

    It's weirdly n e v e r the fact that the machines push bloated eyecandy stuff around for no real use and of course, in 2018 I'm shure it will run better (but then the new machines & OS will choke because of 16K-craze or something...)

    (I'm usually not against "technological development", but with some recent features - extreme hi-res, 3D - isn't it getting a bit... not really that needed nowadays...?)
     
  15. WeetaBiXie macrumors regular

    WeetaBiXie

    Joined:
    May 9, 2011
    Location:
    In a little box, under the stairs
    #15
    My MBP 2011 had this problem too, after Yosemite. Resetting the PRAM, solved the problem.
     

Share This Page