Yosemite user interface crashes but OS continues to run?

Discussion in 'OS X Yosemite (10.10)' started by aliensporebomb, Nov 2, 2014.

  1. aliensporebomb, Nov 2, 2014
    Last edited: Nov 3, 2014

    aliensporebomb macrumors 68000

    aliensporebomb

    Joined:
    Jun 19, 2005
    Location:
    Minneapolis, MN, USA, Urth
    #1
    Has anyone seen with yosemite running safari that the entire system "seems" to freeze up at times?

    I get a vertical mouse pointer (the I beam) when this occurs instead of an actual pointer but the system is otherwise motionless.

    The entire interface just sits as if nothing is happening, the system clock in the right hand corner freezes.

    However, the system is actually running in the background. I found this out by playing my guitar thru the system and sure enough it was working fine.

    If anyone else has encountered this and figured a fix I'd love to know it. I'm on the verge of shutting this thing down until they come up with the first update since this just isn't stable enough to use reliably.
     
  2. aliensporebomb thread starter macrumors 68000

    aliensporebomb

    Joined:
    Jun 19, 2005
    Location:
    Minneapolis, MN, USA, Urth
    #2
    Update - It's not what it appears to be.

    It appears to be the user interface has crashed not the system itself.

    I was able to use PuTTY on a PC to ssh into my own machine and a number of things are still running.

    Processes: 214 total, 2 running, 9 stuck, 203 sleeping, 1033 threads.

    Top shows me that one task "com.apple.Wea" is stuck as is "mds".

    In the end I tried killing stuck tasks but it appears only rebooting would fix.

    So it's definetely some kind of weird OS thing.

    Anyone else encounter this?
     
  3. Morpheo macrumors 65816

    Morpheo

    Joined:
    Feb 26, 2014
    Location:
    Paris/Montreal
    #3
    I don't but it looks like it could be related to spotlight (having trouble) indexing your drive(s). Do you have external drives connected? I would start by preventing from searching/indexing them and see how it goes.
     
  4. aliensporebomb thread starter macrumors 68000

    aliensporebomb

    Joined:
    Jun 19, 2005
    Location:
    Minneapolis, MN, USA, Urth
    #4
    Ugh

    Well it usually only indexes it once at the beginning of install but not since so far as I can tell.

    I do have a lot of external drives. I'll see if I can disable that on external drives.
     
  5. aliensporebomb thread starter macrumors 68000

    aliensporebomb

    Joined:
    Jun 19, 2005
    Location:
    Minneapolis, MN, USA, Urth
    #5
    Sigh

    Keeps happening whether drives external are on or off. Worst performance of any Mac OS since pre 10.1 IMO.
     
  6. poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #6
    Add drives to privacy list to prevent Spotlight from indexing.

    I think spotlight should not index any external devices by default (except the boot drive if it is external).
     
  7. nilnova macrumors member

    nilnova

    Joined:
    Oct 30, 2013
    #7
    I am having this problem too! It really freaked out because my rMBP just went out of warranty and I was afraid it might be a hardware problem, like the dGPU dying.

    One time I was surfing the web with Safari and listening to music with iTunes and everything seemed to freeze. Actually I could move my mouse pointer, but clicking anything would illicit no response. Trying to use the keyboard to taskswitch or force quit also illicited no response. The music from iTunes continued to play, however!

    A different time I had popped up Mission Control via hot corner and it froze mid-animation.

    Each time I had to power off the system and restart it. I tried looking through the Console logs but I didn't really know what to look for. If it happens again I will check the time so that I can look up that timestamp in the logs and see if there is anything relevant.
     
  8. aliensporebomb thread starter macrumors 68000

    aliensporebomb

    Joined:
    Jun 19, 2005
    Location:
    Minneapolis, MN, USA, Urth
    #8
    Thoughts

    I think I may have figured it out.

    I tried using Opera for a day instead of Safari and I didn't seem to see this happening.

    But I noticed this seems to happen most often when (1) I've connected my iPhone 6+ to my computer and it's transferring information or (2) attempting to produce a notification on my screen either from safari or from some other application or (3) attempting to transfer data off of my iPhone to iPhoto.

    I can ssh in and the system is still running. So what's the deal?

    User interface crash? Very sloppy. I sure hope we get an update soon.
     
  9. aliensporebomb thread starter macrumors 68000

    aliensporebomb

    Joined:
    Jun 19, 2005
    Location:
    Minneapolis, MN, USA, Urth
    #9
    Hmmm....

    Update:

    I've been 200 miles away from my system and it appears it hung up again while sitting running no apps, just Apache and Air Video HD plus Dyndns updater. Pondering.
     
  10. aliensporebomb thread starter macrumors 68000

    aliensporebomb

    Joined:
    Jun 19, 2005
    Location:
    Minneapolis, MN, USA, Urth
    #10
    Update

    I may have a handle on why this is happening. I'm going to run my system for 24 hours without the offending app and will see if it has any hangs or crashes in that time. It's a pretty well known payware app too.
     
  11. nilnova macrumors member

    nilnova

    Joined:
    Oct 30, 2013
    #11
    Hmm, interesting. As for me, I haven't had it happen again since doing the following: Stopped using Safari, removed my external drive from Spotlight indexing, and disabled Handoff. I have no idea if any of it is related, just saying it hasn't happened since.
     
  12. aliensporebomb thread starter macrumors 68000

    aliensporebomb

    Joined:
    Jun 19, 2005
    Location:
    Minneapolis, MN, USA, Urth
    #12
    Okay

    Now that my system has been running for one day and 13 hours I'm going to spill the beans: anecdotally it seems iStat Menus may be a potential cause.

    I deinstalled this latest version and haven't been running it at all and have been running nearly everything else I've needed to run.

    I've emailed the developer to see if they have any suggestions. I had 15 UI crashes in a less than 12 hour period and had five in just a few hours when that was installed.

    When it was deinstalled the system seemed to operate fine. Fingers crossed. Too bad, I really liked the app.
     
  13. nilnova macrumors member

    nilnova

    Joined:
    Oct 30, 2013
    #13
    Hmm, well it couldn't have been the cause of my problems because I don't have iStat Menus. Maybe there are multiple things that can trigger the issue.
     
  14. aliensporebomb, Nov 13, 2014
    Last edited: Nov 13, 2014

    aliensporebomb thread starter macrumors 68000

    aliensporebomb

    Joined:
    Jun 19, 2005
    Location:
    Minneapolis, MN, USA, Urth
    #14
    Grumble

    I did have one crash today that reads "Possible memory corruption".
    This is the first crash that might indicate hardware related issues:

    However, this is the first in 107 crashes since installing Yosemite that is memory related.

    Anonymous UUID: 97008A70-06D8-2A92-F457-021C98329A4F

    Thu Nov 13 13:54:48 2014

    *** Panic Report ***
    panic(cpu 4 caller 0xffffff801ce05eb2): "Possible memory corruption: pmap_pv_remove(0xffffff805ebb8248,0x7f954af73000,0x4, 0x4000, 0xffffff82e372bcc4, 0xfffffe96f16e6b98): null pv_list!"@/SourceCache/xnu/xnu-2782.1.97/osfmk/i386/pmap_internal.h:768
    Backtrace (CPU 4), Frame : Return Address
    0xffffff82e372bb80 : 0xffffff801cd3a811
    0xffffff82e372bc00 : 0xffffff801ce05eb2
    0xffffff82e372bcf0 : 0xffffff801ce065e5
    0xffffff82e372bd50 : 0xffffff801cdb6b4a
    0xffffff82e372be60 : 0xffffff801cdacd2c
    0xffffff82e372be90 : 0xffffff801cd5c747
    0xffffff82e372bed0 : 0xffffff801d1c45ff
    0xffffff82e372bf40 : 0xffffff801d1c425c
    0xffffff82e372bf50 : 0xffffff801d24dcb2
    0xffffff82e372bfb0 : 0xffffff801ce3ac46

    BSD process name corresponding to current thread: uptime

    Mac OS version:
    14A389

    Kernel version:
    Darwin Kernel Version 14.0.0: Fri Sep 19 00:26:44 PDT 2014; root:xnu-2782.1.97~2/RELEASE_X86_64
    Kernel UUID: 89E10306-BC78-3A3B-955C-7C4922577E61
    Kernel slide: 0x000000001ca00000
    Kernel text base: 0xffffff801cc00000
    __HIB text base: 0xffffff801cb00000
    System model name: iMac11,1 (Mac-F2268DAE)

    System uptime in nanoseconds: 149897586940332
    last loaded kext at 99227940499099: com.apple.driver.AppleUSBCDC 4.2.2b5 (addr 0xffffff7f9f360000, size 20480)
    last unloaded kext at 99532711862079: com.apple.driver.AppleUSBCDC 4.2.2b5 (addr 0xffffff7f9f360000, size 16384)
    loaded kexts:
    com.apple.filesystems.smbfs 3.0.0
    com.apple.driver.AppleBluetoothMultitouch 85.3
    com.apple.driver.AGPM 100.14.37
    com.apple.filesystems.autofs 3.0
    com.apple.iokit.IOBluetoothSerialManager 4.3.0f10
    com.apple.driver.AppleOSXWatchdog 1
    com.apple.driver.AppleMikeyHIDDriver 124
    com.apple.driver.AppleMikeyDriver 266.5
    com.apple.driver.AppleHWSensor 1.9.5d0
    com.apple.driver.AppleUpstreamUserClient 3.6.1
    com.apple.kext.AMDFramebuffer 1.2.8
    com.apple.driver.AppleHDA 266.5
    com.apple.iokit.IOUserEthernet 1.0.1
    com.apple.ATIRadeonX2000 10.0.0
    com.apple.Dont_Steal_Mac_OS_X 7.0.0
    com.apple.driver.AudioAUUC 1.70
    com.apple.driver.ACPI_SMC_PlatformPlugin 1.0.0
    com.apple.driver.AppleLPC 1.7.3
    com.apple.kext.AMD4800Controller 1.2.8
    com.apple.driver.AppleHWAccess 1
    com.apple.driver.AppleHV 1
    com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport 4.3.0f10
    com.apple.driver.AppleBacklight 170.4.12
    com.apple.driver.AppleMCCSControl 1.2.10
    com.apple.driver.Oxford_Semi 3.5.0
    com.apple.driver.AppleUSBCardReader 3.5.0
    com.apple.driver.AppleIRController 327.5
    com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1
    com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0d1
    com.apple.BootCache 35
    com.apple.iokit.SCSITaskUserClient 3.7.0
    com.apple.driver.XsanFilter 404
    com.apple.iokit.IOAHCIBlockStorage 2.6.5
    com.apple.driver.AppleFWOHCI 5.5.2
    com.apple.driver.AppleUSBHub 705.4.1
    com.apple.driver.AirPort.Atheros40 700.74.5
    com.apple.iokit.AppleBCM5701Ethernet 10.1.2b3
    com.apple.driver.AppleAHCIPort 3.0.7
    com.apple.driver.AppleUSBEHCI 705.4.14
    com.apple.driver.AppleACPIButtons 3.1
    com.apple.driver.AppleRTC 2.0
    com.apple.driver.AppleHPET 1.8
    com.apple.driver.AppleSMBIOS 2.1
    com.apple.driver.AppleACPIEC 3.1
    com.apple.driver.AppleAPIC 1.7
    com.apple.driver.AppleIntelCPUPowerManagementClient 218.0.0
    com.apple.nke.applicationfirewall 161
    com.apple.security.quarantine 3
    com.apple.security.TMSafetyNet 8
    com.apple.driver.AppleIntelCPUPowerManagement 218.0.0
    com.apple.driver.AppleMultitouchDriver 260.30
    com.apple.kext.triggers 1.0
    com.apple.driver.AppleBluetoothHIDKeyboard 175.5
    com.apple.driver.IOBluetoothHIDDriver 4.3.0f10
    com.apple.driver.AppleHIDKeyboard 175.5
    com.apple.iokit.IOSerialFamily 11
    com.apple.driver.DspFuncLib 266.5
    com.apple.kext.OSvKernDSPLib 1.15
    com.apple.iokit.IOSurface 97
    com.apple.iokit.IOFireWireIP 2.2.6
    com.apple.driver.IOPlatformPluginLegacy 1.0.0
    com.apple.driver.IOPlatformPluginFamily 5.8.0d49
    com.apple.kext.AMDSupport 1.2.8
    com.apple.AppleGraphicsDeviceControl 3.7.21
    com.apple.iokit.IOUSBUserClient 705.4.0
    com.apple.driver.AppleSMC 3.1.9
    com.apple.driver.AppleHDAController 266.5
    com.apple.iokit.IOHDAFamily 266.5
    com.apple.driver.AppleSMBusPCI 1.0.12d1
    com.apple.iokit.IOBluetoothHostControllerUSBTransport 4.3.0f10
    com.apple.iokit.IOBluetoothFamily 4.3.0f10
    com.apple.driver.AppleBacklightExpert 1.1.0
    com.apple.iokit.IONDRVSupport 2.4.1
    com.apple.driver.AppleSMBusController 1.0.13d1
    com.apple.iokit.IOGraphicsFamily 2.4.1
    com.apple.iokit.IOFireWireSerialBusProtocolTransport 2.5.1
    com.apple.iokit.IOFireWireSBP2 4.2.5
    com.apple.driver.AppleUSBAudio 295.22
    com.apple.iokit.IOAudioFamily 200.6
    com.apple.vecLib.kext 1.2.0
    com.apple.iokit.IOSCSIBlockCommandsDevice 3.7.0
    com.apple.iokit.IOUSBMassStorageClass 3.7.0
    com.apple.iokit.IOUSBHIDDriver 705.4.0
    com.apple.driver.AppleUSBMergeNub 705.4.0
    com.apple.driver.AppleUSBComposite 705.4.9
    com.apple.iokit.IOSCSIMultimediaCommandsDevice 3.7.0
    com.apple.iokit.IOBDStorageFamily 1.7
    com.apple.iokit.IODVDStorageFamily 1.7.1
    com.apple.iokit.IOCDStorageFamily 1.7.1
    com.apple.iokit.IOAHCISerialATAPI 2.6.1
    com.apple.iokit.IOSCSIArchitectureModelFamily 3.7.0
    com.apple.iokit.IOFireWireFamily 4.5.6
    com.apple.iokit.IO80211Family 700.52
    com.apple.iokit.IOEthernetAVBController 1.0.3b3
    com.apple.driver.mDNSOffloadUserClient 1.0.1b8
    com.apple.iokit.IONetworkingFamily 3.2
    com.apple.iokit.IOAHCIFamily 2.7.0
    com.apple.iokit.IOUSBFamily 705.4.14
    com.apple.driver.AppleEFINVRAM 2.0
    com.apple.iokit.IOHIDFamily 2.0.0
    com.apple.driver.AppleEFIRuntime 2.0
    com.apple.iokit.IOSMBusFamily 1.1
    com.apple.security.sandbox 300.0
    com.apple.kext.AppleMatch 1.0.0d1
    com.apple.driver.AppleKeyStore 2
    com.apple.driver.AppleMobileFileIntegrity 1.0.5
    com.apple.driver.AppleCredentialManager 1.0
    com.apple.driver.DiskImages 389.1
    com.apple.iokit.IOStorageFamily 2.0
    com.apple.iokit.IOReportFamily 31
    com.apple.driver.AppleFDEKeyStore 28.30
    com.apple.driver.AppleACPIPlatform 3.1
    com.apple.iokit.IOPCIFamily 2.9
    com.apple.iokit.IOACPIFamily 1.4
    com.apple.kec.Libm 1
    com.apple.kec.pthread 1
    com.apple.kec.corecrypto 1.0
    Model: iMac11,1, BootROM IM111.0034.B02, 4 processors, Intel Core i7, 2.8 GHz, 24 GB, SMC 1.54f36
    Graphics: ATI Radeon HD 4850, ATI Radeon HD 4850, PCIe, 512 MB
    Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1333 MHz, 0x04CD, 0x46332D3130363636434C392D344742535100
    Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1333 MHz, 0x04CD, 0x46332D3130363636434C392D344742535100
    Memory Module: BANK 0/DIMM1, 8 GB, DDR3, 1333 MHz, 0x01BA, 0x202020202020202020202020202020202020
    Memory Module: BANK 1/DIMM1, 8 GB, DDR3, 1333 MHz, 0x01BA, 0x202020202020202020202020202020202020
    AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x8F), Atheros 9280: 4.0.74.0-P2P
    Bluetooth: Version 4.3.0f10 14890, 3 services, 27 devices, 1 incoming serial ports
    Network Service: Ethernet, Ethernet, en0
    Network Service: Wi-Fi, AirPort, en1
    Serial ATA Device: ST31000528AS, 1 TB
    Serial ATA Device: OPTIARC DVD RW AD-5670SC
    USB Device: Hub
    USB Device: Hub
    USB Device: USB DISK 2.0
    USB Device: Logitech Extreme 3D
    USB Device: Hub
    USB Device: Fast Track
    USB Device: Vendor-Specific Device
    USB Device: Internal Memory Card Reader
    USB Device: BRCM2046 Hub
    USB Device: Bluetooth USB Host Controller
    USB Device: Hub
    USB Device: Built-in iSight
    USB Device: IR Receiver
    FireWire Device: d2 Quadra v3C, LaCie, Up to 800 Mb/sec
    Thunderbolt Bus:
     
  15. aliensporebomb thread starter macrumors 68000

    aliensporebomb

    Joined:
    Jun 19, 2005
    Location:
    Minneapolis, MN, USA, Urth
    #15
    Update

    Appears related to aftermarket ram I bought and installed a week prior to Yosemite. Now after restoring the original configuration all is well.
     
  16. shrx macrumors newbie

    Joined:
    Jul 23, 2011
    #16

Share This Page