Yosemite using incredible amounts of RAM

Discussion in 'OS X Yosemite (10.10)' started by patrickgc, Sep 15, 2014.

  1. patrickgc macrumors newbie

    Joined:
    Sep 15, 2014
    #1
    Hello guys.

    Some days ago i decided to download OSX yosemite, and it worked really well for a couple of days, no problems at all, running smooth. But now i have come to a problem. OSX Yosemite is REALLY slow and unresponsive, a simple task can take from 0,5 second to 20 seconds. Sometimes the computer just go unresponsive, and everything takes ages.

    It's really a problem when the computer is trying to manage new tasks, but when im for example is watching a movie, there is no problem at all. Often just to open a new tab or writing text in word can take ages.

    I tried launching the Activity monitor, and i often use 3,99 GB of my 4 GB ram, and minimum always running with 3 GB usage.

    I really want this problem solved, as i like Yosemite, and im not a quitter, just havent been able to find a solution my self yet. Tried repairing discpermissions, uninstalling Parallels Access via terminal and other things.

    I have a 2010 Macbook Pro 15,4 inch 2,53 GHz i5
     
  2. ABC5S Suspended

    ABC5S

    Joined:
    Sep 10, 2013
    Location:
    Florida
    #2
    Check your memory pressure shown below in Activity Monitor. If its green your memory is not the issue. Memory is being used differently than on older OS's. Yosemite is still in Beta so one will have to allow for some hick-ups until its released..
     

    Attached Files:

  3. patrickgc thread starter macrumors newbie

    Joined:
    Sep 15, 2014
    #3

    Well, the graph is totally green, so that might not be the cause then, any suggestions?
     
  4. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #4
    No doubt Apple still needs to tighten up Yo's memory usage.

    [​IMG]

    [​IMG]
     
  5. jimmyco2008 macrumors regular

    Joined:
    Jan 8, 2014
    #5
    When you first boot into Yosemite, with NO applications open, you should be using about 950MB of Memory (Wired). Generally, though, OS X uses ALL the available RAM, or just about, for things like App Memory and File Cache.

    There's a reason Apple upped the minimum RAM amount in rMBPs recently to 8GB, though, so to a degree I'm sure you'll have to be "careful" about how many apps you have open.
     
  6. dndandrea macrumors 6502

    Joined:
    Feb 10, 2010
    #6
    Wow. I have mail, safari, and iMessages running...

    and I'm using 7.49GB of ram????

    8GB-16GB used to be overkill, now it's starting to become the minimum.
     
  7. Paradoxally macrumors 65816

    Joined:
    Feb 4, 2011
    #7
    Do you have an SSD? I have 8 GB and with a ton of programs open I still have about 3.65 GB free. With my old Mac that had an HDD it would frequently use up all the RAM even with not many programs open.
     
  8. dndandrea macrumors 6502

    Joined:
    Feb 10, 2010
    #8
    Yes, I have the original 15" MBP retina. It's fluctuating between 7.49GB and 7.97GB. This is insane.

    Might be a stupid question, but does using up all your ram have any toll on the ram's lifespan or other affects on the computer?
     
  9. crjackson2134 macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #9
    Are you saying the OS uses memory differently based on the type of storage attached? Just curious.
     
  10. dndandrea macrumors 6502

    Joined:
    Feb 10, 2010
    #10
    Is this normal? (see attachment)
     

    Attached Files:

  11. dndandrea macrumors 6502

    Joined:
    Feb 10, 2010
    #11
    It's still around 6.5GB after I close all of my applications (mail, safari, iMessages). Something's not right.

    edit: restarted computer. Now it's steady around 5.75GB with Mail, Safari, and iMessages open. Seems better, still slightly high though.
     
  12. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
  13. deadmantyping macrumors newbie

    Joined:
    Nov 19, 2010
    #13
    I had a similar problem right after upgrading to PB2 where every application would take forever to launch and it felt like I was running out of memory even though the memory pressure was low.

    For me, it actually turned out to be coreduetd. It doesn't use a lot of cpu or memory, but it was very I/O intensive.

    In my case, /var/db/CoreDuet/coreduetd.db was huge (~9GB when I caught it iirc). I deleted all of the files inside /var/db/CoreDuet and restarted and haven't had the problem since. I have never really found a satisfactory explanation for what it was doing. From some searching, I believe it is somehow related to Notifications, which all seemed to continue to work fine after I emptied that folder. It has been about a month now and my coreduetd.db is still under 1MB. It also seems to continue to work fine after yesterday's upgrade to PB3.
     
  14. nickskaar macrumors newbie

    Joined:
    Oct 16, 2014
    #14
    wow..
     
  15. jonobin macrumors regular

    Joined:
    Sep 3, 2014
    #15
    take a look @ kernel task memory, that's a huge waste of memory
     
  16. cjmillsnun macrumors 68020

    Joined:
    Aug 28, 2009
    #16
    Guys, this is normal behaviour.

    It's how the OS is designed to work, and something that was in Mavericks.

    You will find open applications and the OS will use almost all the available RAM. Don't worry about.

    Opening more apps will result in that memory being reallocated so the app that needs the most, gets it. What you need to worry about is memory pressure.

    When that is green, everything is fine.
     
  17. thisaintrbight macrumors newbie

    thisaintrbight

    Joined:
    Oct 7, 2015
    #17
    1. In the Finder menu choose Go -> Go to Folder…
    2. Type: “/var/db/coreduet
    3. Delete everything in that folder
    4. Restart
    This will solve it. Easy fix.
    I have same model and it worked for me after using 97% of my CPU.
    Just delete the whole folder and restart your computer.
     
  18. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland

Share This Page