Yosemite won't boot - stuck on black screen

Discussion in 'OS X Yosemite (10.10)' started by delebreaub, Jul 27, 2014.

  1. delebreaub macrumors newbie

    Joined:
    Jul 27, 2014
    #1
    My Yosemite disk won't boot up. When I turn on my rMPB, the screen turns on and the boot sound plays, but then it gets stuck on a blank, black screen. It was running fine earlier today. Any suggestions?
     

    Attached Files:

  2. Kennyyoli macrumors newbie

    Joined:
    Mar 24, 2010
  3. delebreaub thread starter macrumors newbie

    Joined:
    Jul 27, 2014
  4. mackenzie143 macrumors newbie

    Joined:
    Jul 27, 2014
    #4
    Had the same thing happen. After you hear the boot tone, hold command-R and you will bypass and get to the boot screen. Here I suggest you downgrade back to Mavericks or reinstall Yosemite.
     
  5. delebreaub thread starter macrumors newbie

    Joined:
    Jul 27, 2014
    #5
    How long should I have to hold command-R? Nothing seems to be happening.
     
  6. mackenzie143 macrumors newbie

    Joined:
    Jul 27, 2014
    #6
    At least until the screen turns back on. (Took me about a minute) then reinstall max OS X Mavericks and wipe the drive. Better to start fresh.
     
  7. Armin T, Aug 1, 2014
    Last edited: Jun 21, 2015

    Armin T macrumors newbie

    Joined:
    Aug 1, 2014
    #7
    *** solution: Yosemite black boot screen ***

    Hi i found a solution ! i had the same problem I tried searching the web but I couldn't find anything so I tried random things till I found this fix , You have to reset the NVRAM, You can do so by pressing the Combination after you hear the boot sound : COMMAND+OPTION+P+R
    There you have it ! your mac boots up and everything is back to normal ! I emailed apple, macrumors, redmondpie about it and still nothing..... They should at least give this issue a topic...
    GO TO THREAD #26 ON NEXT PAGE FOR YOSEMITE RESTORE AND DOWNGRADE

    :apple:Armin
     
  8. scy0846 macrumors newbie

    Joined:
    Aug 22, 2014
    #8
    So mine does this too. It boots, but nothing will show up on the screen. I cannot get into recovery mode, internet recovery mode and the cmd+option+p+r does not work either. I have literally tried everything I can. I just want Mavericks back, but I can't get to recovery. Nothing shows on boot and I cannot hook it up to an external screen with any hdmi or displayport...help!
     
  9. mikecwest macrumors 6502a

    mikecwest

    Joined:
    Jul 7, 2013
    #9
  10. Christian Sigel macrumors newbie

    Joined:
    Sep 21, 2014
    #10
    Possible solution

    Hi,

    I seem to have had the same issue (black but illuminated screen after startup sound). I did the SMC and NVRAM reset a couple of times and eventually, this brought my screen back or a while, but then it disappeared again. (The rest seemed to continue to run, there was audio and a backup still going on.)

    Anyway, I found out that when you *disable sleep*, the system remains stable. (I did this with the SmartSleep app that I had already installed, it uses a kernel extension. I don't know what happens when you turn off sleep via System Preferences.) So disabling sleep should give you enough time to backup all data in order to revert to Mavericks. Note that the Mavericks installer will not import anything from a Yosemite backup, so you have to copy the data by hand.

    Christian
     
  11. VvCompHelpvV macrumors member

    Joined:
    Apr 26, 2009
    #11
    GAHH! Thank you! I literally logged in for the first time in YEARS just to reply to this post.

    I super appreciate it. My air was down for a few days, and already had a genius appt. scheduled.
     
  12. jdkaaaa macrumors newbie

    Joined:
    Oct 14, 2014
    #12
    black screen, no startup sound help!!!

    Hi,

    This morning I have installed yosmite beta 6 on my macbook air.
    I have used it today but now its all black and it won't boot.
    No startup sound. Can someone help me?

    Thanks!
     
  13. ahmednm1996 macrumors newbie

    Joined:
    Jan 20, 2014
    #13
    Amazing it actually worked

    This worked for me as well thank you very much but just to add you have to hold them down until you hear the second boot sound then let go. So happy its fixed.
     
  14. Thorjung macrumors newbie

    Joined:
    Oct 4, 2010
    Location:
    San Francisco
    #14
    Fiexed

    Thank you!! This worked for my friend!
     
  15. Armin T, Nov 1, 2014
    Last edited: Jun 23, 2015

    Armin T macrumors newbie

    Joined:
    Aug 1, 2014
    #15
    Letter of appreciation ;-)

    First of all Thanks to the person who opened this topic!
    To those whom this worked for them You're Welcome , I'm really happy to know that I have solved an issue .


    Thanks

    Armin
     
  16. Christian Sigel macrumors newbie

    Joined:
    Sep 21, 2014
    #16
    What Genius Bar says

    I took my MacBook to the Apple store and they said it is probably a hardware issue that only shows up after upgrading to Yosemite. They changed the way in which video memory is handled. As a consequence, if the screen had an unnoticed issue, upgrading to Yosemite can trigger the thing where it randomly goes black. So the solution, in my case, seems to be to either downgrade to Mavericks or change the display.
     
  17. Armin T, Nov 7, 2014
    Last edited: Nov 7, 2014

    Armin T macrumors newbie

    Joined:
    Aug 1, 2014
    #17
    Hi christian have you tried the method I provided ?? It has nothing to do with your screen its a bug that will cause Yosemite to crash and prevent your mac from booting up please before you try anything do what i recommended in previous posts
    This issue has spread among macbook users so if it somehow was a display issue it would only effect a few people , but I see many people complaining about it !

    Armin
     
  18. Christian Sigel macrumors newbie

    Joined:
    Sep 21, 2014
    #18
    I tried everything suggested above, and it sometimes seemed to work, but more often did not. The problem would come back anyway. I agree that there might be other causes for the same symptoms; and it still remains to be seen whether replacing the display fixes it.
     
  19. kaoska macrumors newbie

    Joined:
    Nov 22, 2014
    #19
    the solution

    What solved the same problem for me is to safe boot (holding shift while poweron), waking the black screen by shift or caps lock, then typing the first letter of the login username and hit enter. Type your password and hit enter, then space bar.
     
  20. rezwits macrumors 6502a

    rezwits

    Joined:
    Jul 10, 2007
    Location:
    Las Vegas
    #20
    Same bug kinda

    I am having this issue with Yosemite 10.10.1 and MacBook 17 2011.

    Thing is I don't know if you are getting this but, during "just chilling" the screen will go black, but just like sleep tho. So I do a restart and then it restarts in black and it get's all the way to the login screen (I only know this cause I have seen it flicker before in 10.10.0). I don't do that anymore tho.

    Now I get this error (10.10.1) and the screen sleeps. I restart hold down Apple-Option-P-R for the old pram zap, do it twice then hold down Apple-R for recovery. I have to boot into recovery to fully reset the screen sleep setting somewhere. Once I get into the disk utility menu, I just do a repair since I am there, then restart.

    Then it just restarts no problem and I login and am back to work. SUCKS I was hoping the 10.10.1 update would fix this but it got WORSE. Cause before I would just force shutdown and reboot and it got right back in. BUMMER!

    It's all good tho cause the good out weighs the bad this time around.
    I love Yosemite! but I can't wait for 10.10.2 :p

    Laters...
     
  21. Christian Sigel macrumors newbie

    Joined:
    Sep 21, 2014
    #21
    UPDATE: After getting it back with the screen replaced, everything is fine for more than two weeks now. At least in my case, the issue was apparently that Yosemite could not deal with my slightly malfunctioning screen, where Mavericks had coped fine.
     
  22. R1North macrumors newbie

    Joined:
    Jan 29, 2015
    #22
    Hi guys

    My screen died on Monday but with the start up chimes...the solution in #7 worked for me.

    Took a couple of goes to do it, you literally have to press all the buttons when it chimes not after etc, but thats saved me a load of time in my day tomorrow for my genius bar appt...cheers!
     
  23. alivi5 macrumors newbie

    Joined:
    May 9, 2015
    #23
    Hi All, the Command Option P R worked for me too after the chime. I then used the torch to see my account icon and then the login box. Who knew that Apple would release a dodgy operating system upgrade. This is now 6 months after the original post and it's still not been fixed.

    We expect more from you Apple!
     
  24. JDLang macrumors newbie

    Joined:
    Aug 4, 2011
    #24
    Had the same problem this morning on my Mac Pro (Late 2013) running Yosemite 10.10.3

    The cmd + opt + P + R after hearing the boot sound worked for me. It chimed twice and then booted fine.

    Apple should know about this issue by now?!?!
     
  25. howardc64, Jun 18, 2015
    Last edited: Jun 18, 2015

    howardc64 macrumors newbie

    Joined:
    Mar 14, 2011
    #25
    Hi same issue here on 2013 MBA

    My son shutsdown his MBA every night. Within the last few weeks, it wouldn't boot the next day a few times now. Each time just chimes but screen is blank (backlight on, LCD shows nothing). cmd + opt + P + R would bring it back only to happen again a few days later.

    Anyone having repeated failures like this?

    UPDATE: He is on 10.10.4 public beta which was installed on 5/27/15. Roughly the time that this problem started. Perhaps beta software is the issue. Will see if can go back to 10.10.3 or goes away with 10.10.4 comes out
     

Share This Page