"You can only read", even though all privileges are set to Read & Write

Discussion in 'macOS' started by Andra, May 16, 2010.

  1. Andra macrumors newbie

    Joined:
    Nov 7, 2006
    #1
    I was trying to write xmp data to my photo's, when I got errors on photo's in certain folders.

    ‘Writing XMP Metadata’ did not complete successfully

    It seems all jpegs in a few particular folders have generate this error. I then noticed all those files were lacking a creation date. When trying to copy the "image taken on" date to the "creation date", using A Better Attributes, I didn't appear to have the right permissions.
    Now this is, to me at least, the weirdest part: when I open Get Info on any of the images, it says "You can only read", even though all privileges are set to Read & Write (screenshot attached). The folder itself says "You can read and write".

    So far I've only seen this on files/folders on an external hard drive, formatted Mac OS Extended (Journaled). It's a WD My Book, connected via USB through a hub.

    Anyone ever seen this before? Is there anything I could try to fix this? :confused:

    Thanks in advance!

    Yours,
    Andra
     

    Attached Files:

  2. t0mat0 macrumors 603

    t0mat0

    Joined:
    Aug 29, 2006
    Location:
    Home
    #2
    Click on the cogwheel down arrow - You need to set permissions for the folder *and all the enclosed files*.

    "Apply to enclosed items" is the setting you want.
     
  3. Andra thread starter macrumors newbie

    Joined:
    Nov 7, 2006
    #3
    Solved: "Locked" was checked for these files

    It turned out it wasn't caused by permissions, but by the locked checkmark (the one at the *top* of the Get Info window). :rolleyes:

    Apparently I locked these files, probably to secure them against removal. I probably did this when the files still lived on a PC. When they were copied, OSX wasn't able to write a Creation Date, so it was left blank.

    Anyways: thank you t0mat0 for your suggestion.

    Lesson learned.
     

Share This Page