You can't edit Quicktime X's Screen Recordings in FCE!

Discussion in 'macOS' started by FSMBP, Aug 31, 2009.

  1. FSMBP macrumors 68020

    FSMBP

    Joined:
    Jan 22, 2009
    #1
    So, I realized you can't edit Quicktime's Screen recordings in anything but Quicktime (with it's AMAZING trim feature).

    If you plan on splicing a bunch of separate videos and wanting to add narration later, you'll need a new screen capture app.
     
  2. J the Ninja macrumors 68000

    Joined:
    Jul 14, 2008
    #2
    This pissed me off to no end. Does iMovie 09 even open them?
     
  3. LittleBob68 macrumors member

    Joined:
    Dec 20, 2008
    #3
    I just saw this thread and opened FCE4 and Imovie9. I was able to import a screen capture from Quicktime into imovie but not into FCE4. That sucks and doesnt make any sense to me.
     
  4. t0mat0 macrumors 603

    t0mat0

    Joined:
    Aug 29, 2006
    Location:
    Home
    #4
    Is the QT X issues due to the Quicktime Player and the QT X API? Just looking at the Ars Technica review article, it seems the issues are through the changes Apple's been making.
     
  5. localoid macrumors 68020

    localoid

    Joined:
    Feb 20, 2007
    Location:
    America's Third World
    #5
    After you've finished your screen recording, from Quicktime X's menu, select:
    File > Save as > Format = HD 480p, HD 720p, or HD 1080p

    Then import into FCE.

    Some of other formats may also work in FCE... experiment.
     
  6. J the Ninja macrumors 68000

    Joined:
    Jul 14, 2008
    #6
    AH! That's how. I figured it was an issue of FC barfing on the video being your screen res and not a normal video res.
     
  7. adamk77 macrumors 6502

    Joined:
    Jan 6, 2008
    #7
    I tried every single format. None of them work for me (in Final Cut Pro).
    Had to convert it into something else in Compressor.
     
  8. Captain Slocum macrumors newbie

    Joined:
    Sep 8, 2011
    #8
    I was having the same problem yesterday, spent much of the day experimenting, poor quality video when QT screen recording taken into FCPX.

    This morning I did a software update and there were two, both QT/FCP related, including a codec update. (new iMac running Lion)

    It seems to have made a difference (or I didn't do things right yesterday!)

    Record High Qual in QT then import into FCPX and put into timeline
    Scrub the clip and it looks fine. Play the clip and it looks blurred BUT
    Export the clip from FCPX to YouTube (which is what I want to do to share training videos with my customers) using Large 540p and the result is very good - more than acceptable quality.

    There may be other settings that work, I have only tried that one.
     

Share This Page