"you don't have permission to write to the folder" (Text edit)

Discussion in 'Mac Apps and Mac App Store' started by macstatic, Jun 15, 2014.

  1. macstatic macrumors 65816

    Joined:
    Oct 21, 2005
    Location:
    Norway
    #1
    I've just bought a new 13" Macbook Pro which came with OSX 10.9 Mavericks (I've still been using OSX 10.6 on my Mac Pro for several reasons, so I don't have much previous experience with Mavericks).
    The problem is that I ran Text Edit to create a couple of documents and keep getting the following error now and again:

    You don't have permission to write to the folder that the file "name of file" is in.
    Your changes will not be saved until the problem is resolved.

    This doesn't make sense, because I'm saving the files to the Finder desktop, and I've logged in as usual. I only recently (yesterday) received the computer, so I can't have messed it up this much already ;)
    What's the reason for this and is there a solution?
     
  2. hologram macrumors 6502

    Joined:
    May 12, 2007
    #2
    Have you tried repairing permissions?

    Do a "Get Info" on the Finder, and see if you have permission to write to it. If not, you can change permissions there.

    If those don't work, what happens when you save these documents to another folder and drag them to the desktop?
     
  3. dianeoforegon macrumors 6502a

    dianeoforegon

    Joined:
    Apr 26, 2011
    Location:
    Oregon
    #3
    You qualify for free support from Apple. I would give them a call. It might be the quickest way to get this resolved.
     
  4. Sitaifun macrumors newbie

    Joined:
    Aug 28, 2014
    #5
    Try this simple fix

    I think the problem might be with the sandbox security feature in OSX rather than actual permissions. Closing and reopening TextEdit may work, but first disable the OSX general preference to "Close windows when quitting an application". That way when you reopen TextEdit, your unsaved content will still be intact, and any other documents will also reopen automatically. It's a good idea to enable the General preference to "Ask to keep changes when closing documents" so that you don't accidentally close a file without saving it. However, in this scenario when TextEdit refuses to save your files, do NOT close the individual file; actually quit TextEdit and then reopen it. Here is the article where I learned this: http://www.macworld.com/article/2038430/bugs-and-fixes-when-textedit-won-t-save.html
     
  5. macstatic thread starter macrumors 65816

    Joined:
    Oct 21, 2005
    Location:
    Norway
    #6
    Thanks for your suggestions. I'll try them out when I get the time.
     
  6. Brien macrumors 68020

    Brien

    Joined:
    Aug 11, 2008
    #7
    I know bumping ancient threads is taboo, but I'm having this exact issue. Doesn't matter where I save, permissions and trashing plists doesn't help. Ideas?
     
  7. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #8
    If you have recently restored your drive, or transferred files to a new computer (as in the OP for this thread), then
    maybe you don't yet have proper ownership of the files in your user folder.

    Try this in your terminal.
    Code:
    sudo chown -R useraccount /Users/useraccount/
    change "useraccount" to your actual account name.
    When you press enter, you will be asked for your password. You will NOT see your password as you type it.
    Just type it blind, then press enter again. Should take a few seconds (maybe 30 seconds, just wait!), but the text prompt should return.
    RESTART your Mac. If the problem is ownership (permissions), then that should help.
     

Share This Page