"you must restart your computer" and "no airport card installed" issues...

Discussion in 'MacBook Pro' started by jacksmash, Mar 21, 2011.

  1. jacksmash macrumors newbie

    Joined:
    Mar 21, 2011
    #1
    I've been dealing with these two intermittent issues for months now. I've read many forum discussions, but have yet to be able to find a solution. I'm not sure whether the two issues are related or not.

    Specs: MAC OSX 10.6.6, 2.6 GHz Intel Core 2 Duo, 4 GB 667 MHz DDR2 SDRAM. MacBook Pro 2008 version.

    1. "You must restart your computer"

    This happens often. I thought maybe it was a RAM problem. I've done the hardware test (both short and long) and I've removed both RAM cards individually, but no solution. I've done the clear-the-PRAM thing and still no bones. I just have to keep restarting the computer and eventually it works.

    2. "No airport card installed"

    This one I really don't get. I've purchased a new wireless router to see if that would change anything, but nope. Every now and then I just lose the wireless (and it really doesn't matter what I'm doing online), and then the airport won't turn back on. The thing is, this ONLY happens at home. Never when I'm at school (where I use wireless much more than at home!). I was thinking that maybe there are too many routers around me and that somehow the airport card is getting confused, but I have no idea.

    At this point I'm really just stuck. I've done lots of Googling and searching these forums, and I'm just not sure what else to try. If it's a hardware problem, the hardware test is doing me absolutely no good.
     
  2. jacksmash thread starter macrumors newbie

    Joined:
    Mar 21, 2011
    #2
    One more thing to add...

    This entire weekend, at home, I could not get the Macbook to start up even once. It always came to the same screen that tells you to restart the machine.

    I must have tried it about 10 times throughout the weekend.

    This morning, I come to school and fire it up, and it works the first time!

    What the heck?!?
     
  3. Penguissimo macrumors 6502a

    Penguissimo

    Joined:
    Nov 17, 2009
    Location:
    Michigan
    #3
    This unfortunately sounds like it could be a hardware issue. Do you have AppleCare?
     
  4. mulo macrumors 68020

    mulo

    Joined:
    Aug 22, 2010
    Location:
    Behind you
    #4
    Post the panic log and ill tell you if it's something you can fix on your own.
     
  5. jacksmash thread starter macrumors newbie

    Joined:
    Mar 21, 2011
    #5
    Thanks! Here it is:

    Code:
    Mon Mar 21 09:23:07 2011
    panic(cpu 0 caller 0x2aab55): Kernel trap at 0x00eeeccc, type 14=page fault, registers:
    CR0: 0x8001003b, CR2: 0x18000000, CR3: 0x00100000, CR4: 0x00000660
    EAX: 0x00000000, EBX: 0x086e5700, ECX: 0x00000000, EDX: 0x00000000
    CR2: 0x18000000, EBP: 0x5d23bc08, ESI: 0x086f0800, EDI: 0x18000000
    EFL: 0x00010256, EIP: 0x00eeeccc, CS:  0x00000008, DS:  0x085b0010
    Error code: 0x00000000
    
    Backtrace (CPU 0), Frame : Return Address (4 potential args on stack)
    0x5d23b9c8 : 0x21b50c (0x5d4438 0x5d23b9fc 0x223974 0x0) 
    0x5d23ba18 : 0x2aab55 (0x59623c 0xeeeccc 0xe 0x596406) 
    0x5d23baf8 : 0x2a09a8 (0x5d23bb10 0x0 0x5d23bc08 0xeeeccc) 
    0x5d23bb08 : 0xeeeccc (0xe 0x85d0048 0x5d230010 0x10f0010) 
    0x5d23bc08 : 0xeef44b (0x5d2c9000 0x0 0x0 0x4824f774) 
    0x5d23bc48 : 0xfaa215 (0xffff 0x86e5700 0x5d2c9000 0x1) 
    0x5d23bce8 : 0xf6e22f (0x4824f000 0xffff 0xffff 0x0) 
    0x5d23bd68 : 0xee27b2 (0x86ecc00 0xffff 0xffff 0x0) 
    0x5d23bdf8 : 0xee425d (0x86ecc00 0x86ecc00 0x0 0x86e8580) 
    0x5d23be18 : 0x53cb6e (0x86ecc00 0x86cc680 0x1 0x4ffaa6) 
    0x5d23be78 : 0x53ada3 (0x86cc680 0x86ecc00 0x86ebe60 0x98) 
    0x5d23bf28 : 0x53b334 (0x86cc680 0x86ca740 0x0 0xffffffff) 
    0x5d23bf78 : 0x53cfe3 (0x86cc680 0x0 0x5d23bfac 0x1) 
    0x5d23bfc8 : 0x2a06cc (0x86cb1d0 0x0 0x2a06db 0x85e6000) 
          Kernel Extensions in backtrace (with dependencies):
             com.apple.driver.AirPortBrcm43xx(423.91.27)@0xed7000->0x10a6fff
                dependency: com.apple.iokit.IOPCIFamily(2.6)@0x927000
                dependency: com.apple.iokit.IO80211Family(312)@0xd3d000
                dependency: com.apple.iokit.IONetworkingFamily(1.10)@0xd26000
    
    BSD process name corresponding to current thread: kernel_task
    
    Mac OS version:
    Not yet set
    
    Kernel version:
    Darwin Kernel Version 10.6.0: Wed Nov 10 18:13:17 PST 2010; root:xnu-1504.9.26~3/RELEASE_I386
    System model name: MacBookPro4,1 (Mac-F42C86C8)
    
    System uptime in nanoseconds: 313187579
    unloaded kexts:
    (none)
    loaded kexts:
    com.apple.driver.AirPortBrcm43xx	423.91.27 - last loaded 303423387
    com.apple.driver.AirPortBrcm43224	426.36.1
    com.apple.iokit.AppleYukon2	3.2.1b1
    com.apple.driver.AppleSmartBatteryManager	160.0.0
    com.apple.BootCache	31
    com.apple.AppleFSCompression.AppleFSCompressionTypeZlib	1.0.0d1
    com.apple.driver.AppleFWOHCI	4.7.1
    com.apple.driver.AppleUSBHub	4.1.7
    com.apple.driver.AppleIntelPIIXATA	2.5.1
    com.apple.driver.AppleUSBEHCI	4.1.7
    com.apple.driver.AppleUSBUHCI	4.1.5
    com.apple.iokit.IOAHCIBlockStorage	1.6.3
    com.apple.driver.AppleEFINVRAM	1.4.0
    com.apple.driver.AppleRTC	1.3.1
    com.apple.driver.AppleHPET	1.5
    com.apple.driver.AppleAHCIPort	2.1.5
    com.apple.driver.AppleACPIButtons	1.3.5
    com.apple.driver.AppleSMBIOS	1.6
    com.apple.driver.AppleACPIEC	1.3.5
    com.apple.driver.AppleAPIC	1.4
    com.apple.driver.AppleIntelCPUPowerManagementClient	105.13.0
    com.apple.security.sandbox	1
    com.apple.security.quarantine	0
    com.apple.nke.applicationfirewall	2.1.11
    com.apple.driver.AppleIntelCPUPowerManagement	105.13.0
    com.apple.iokit.IO80211Family	312
    com.apple.driver.AppleFileSystemDriver	2.0
    com.apple.iokit.IONetworkingFamily	1.10
    com.apple.driver.XsanFilter	402.1
    com.apple.iokit.IOFireWireFamily	4.2.6
    com.apple.iokit.IOUSBUserClient	4.1.5
    com.apple.iokit.IOATAFamily	2.5.1
    com.apple.iokit.IOUSBFamily	4.1.7
    com.apple.driver.AppleEFIRuntime	1.4.0
    com.apple.iokit.IOAHCIFamily	2.0.4
    com.apple.iokit.IOHIDFamily	1.6.5
    com.apple.iokit.IOSMBusFamily	1.1
    com.apple.kext.AppleMatch	1.0.0d1
    com.apple.security.TMSafetyNet	6
    com.apple.driver.DiskImages	289
    com.apple.iokit.IOStorageFamily	1.6.2
    com.apple.driver.AppleACPIPlatform	1.3.5
    com.apple.iokit.IOPCIFamily	2.6
    com.apple.iokit.IOACPIFamily	1.3.0
     
     
  6. Naimfan macrumors 68040

    Naimfan

    Joined:
    Jan 15, 2003
  7. jacksmash thread starter macrumors newbie

    Joined:
    Mar 21, 2011
    #7
    Not sure. Right now the machine is booting fine, so I haven't bothered trying.
     
  8. Naimfan macrumors 68040

    Naimfan

    Joined:
    Jan 15, 2003
    #8
    Try it.

    And make a complete backup of your drive immediately--your hard drive may be failing.
     
  9. mulo macrumors 68020

    mulo

    Joined:
    Aug 22, 2010
    Location:
    Behind you
    #9
    so first off its the driver for your airport card that is causing the panic. As your computer is an older model and i'm presuming it has been running stably for years, more importantly I have never seen a bad airport card driver so I'm thinking your airport card is toast.

    but since its your airport card i can also tell you that shutting off your airport will stop further panics (from this issue anyway)


    just a note, your computer doesn't know what version of OS X its running, you might want to reinstall as that could cause issues at any time.
     
  10. jacksmash thread starter macrumors newbie

    Joined:
    Mar 21, 2011
    #10
    Thanks. I've backed it up. I'll try booting from my SL disk when I get home.
     
  11. jacksmash thread starter macrumors newbie

    Joined:
    Mar 21, 2011
    #11
    Thanks so much for that! I had a feeling it may be the wireless card. I will try a reinstall and go from there, although I'm guessing I really do need a new airport card.
     
  12. MacTech68 macrumors 68000

    MacTech68

    Joined:
    Mar 16, 2008
    Location:
    Australia, Perth
    #12
    Airport cards with poor connectivity in earlier machines would cause kernel panics.

    Although given that you're having a different experience at home and have tried a different wireless base station might indicate that the airport card is getting hotter at your home environment. If it's sitting on your bed or other 'soft furnishings' at home that would explain the additional heat.

    The question remains, does the airport card simply need reseating or is the card itself faulty?

    The airport card in the Late 2008 MBP 15" (Unibody) is located in the display housing and isn't terribly easy to access. However, the cable that connects it to the logic board is relatively easy to reseat on the logicboard end.

    See step 6 here to see how to detach the cable. Simply plug it back in. Take note, as the instructions say, that the connector moves parallel to the surface of the logic board. Do NOT pull it upwards.

    If you have the Early 2008 MBP 15" (which I believe is your model) the airport card is in the body of the machine and is relatively easy to reseat. See here for instructions.

    Note that for both you will need the correct screw drivers. See page 1 of each repair procedure which will list the correct screw drivers.

    Just a guess... hopefully it helps. :)
     
  13. jacksmash thread starter macrumors newbie

    Joined:
    Mar 21, 2011
    #13
    Thanks! I'll check those links out. Does the fact that I have a 17" change anything?
     
  14. MacTech68, Mar 22, 2011
    Last edited: Mar 22, 2011

    MacTech68 macrumors 68000

    MacTech68

    Joined:
    Mar 16, 2008
    Location:
    Australia, Perth
    #14
    Awww... crap.... yeah....

    If it's a 2008, then the 17" "Early 2008" and "Late 2008" are both the same (and aren't Unibody).

    This then makes the take apart this one, and the airport card is contained within the body of the machine.

    Be very careful with the small keyboard connector. A plastic tool is far better than a screw driver for removing the keyboard connector. Plastic tools for prying the top case off also means that the plastic tool deforms instead of your aluminum deforming. :eek:
     
  15. jacksmash thread starter macrumors newbie

    Joined:
    Mar 21, 2011
    #15
    Thanks!

    Ok, so here's the deal. I followed the instructions and removed the airport card, and then put it back in. I'm assuming that's what "reseating" means :)

    If not... then it was good practice anyhow!

    So, we'll see how things go from here. In response to one thing that was said earlier, whether at home or at school my MacBook is always on a table. I don't set it on my lap.

    Anyways, not sure what else to do at this point. I'll keep in touch with how things go.
     
  16. MacTech68 macrumors 68000

    MacTech68

    Joined:
    Mar 16, 2008
    Location:
    Australia, Perth
    #16
    Yep... that's what reseating means. Sometimes you may need to clean the gold edge contacts (especially if you can see dark "splodges" on them). Methods vary.

    Odd that the machine is placed on a table in both locations but only produces the problem at home. Maybe it is still ambient temperature or time running or even CPU load differences generating more heat at home.

    Time will tell whether it's worked or not.

    I look forward to an update in a week or two. :)
     
  17. jacksmash thread starter macrumors newbie

    Joined:
    Mar 21, 2011
    #17
    Yeah... unlikely. I have it doing much more computationally expensive stuff at school then at home.

    One thing I've wondered though, and this may sound really silly, but at home it detects like 7 or 8 networks (my neighbors), and at school there is only 2 to choose from. So I've often wondered if a neighbors router is causing some kind of trouble (or even my own router!). I'm not an engineer though, and so that may just be a worthless muse.
     
  18. MacTech68 macrumors 68000

    MacTech68

    Joined:
    Mar 16, 2008
    Location:
    Australia, Perth
    #18
    If that were the case, I'd expect to see more reports of the problem. That's not to say it's impossible.

    The problem could also be software related. What I've offered is the first hardware troubleshooting step. It just rang a bell for me when I saw the thread title. :)
     
  19. jacksmash thread starter macrumors newbie

    Joined:
    Mar 21, 2011
    #19
    Well, it finally happened again. I haven't been using my MacBook as intensely as usual lately, but the other day I was streaming some video and down went the airport card. :(

    I cleared the PRAM and restarted many times, but no luck. So I turned off my router, cleared the PRAM again, and back up it came!

    It's been working fine since. We'll see how long till it crashes again.
     

Share This Page