your computer needs to be restarted

Discussion in 'iMac' started by themespot, Sep 3, 2007.

  1. themespot macrumors newbie

    Joined:
    Sep 3, 2007
    #1
    every time i boot my computer, i get the apple sound, then a message saying that my computer needs to be restarted.. I have checked to voltage on the wall outlet, secured my power cable, unplugged all peripherals, and tried to reset the SMC *dont know if that worked* since the computer was not on to power off from the apple menu... I am thinking this could be an internal power supply issue but i was looking for some other opinions
     
  2. CanadaRAM macrumors G5

    CanadaRAM

    Joined:
    Oct 11, 2004
    Location:
    On the Left Coast - Victoria BC Canada
    #2
    Does the machine boot from the OSX DVD if you restart with the DVD in and the C key held down?
    Have you removed any third-party RAM
     
  3. themespot thread starter macrumors newbie

    Joined:
    Sep 3, 2007
    #3
    thanks for your reply. I have not installed and new ram, nor has the machine been moved in anyway that could explain a ram chip being out of place.. I tried restarting with the Install DVD holding the "c" key like you suggested, but the problem persists
     
  4. speakerwizard macrumors 68000

    speakerwizard

    Joined:
    Aug 8, 2006
    Location:
    London
    #4
    you could try booting and holding down alt/command/p/r but i doubt that will help :s anything is worth a try
     
  5. oduinnin macrumors regular

    Joined:
    Aug 3, 2007
    Location:
    Planet Earth
    #5
    I doubt that your problem is software related since you weren't able to boot using the install DVD.

    One other thing you could try, if it's a software issue, is booting up in "Single User Mode". Do this by holding down the "S" key when you boot. If it boots, it'll be in a Unix command line window, white characters on a black background.

    Before you do the above, I suggest you read the following and other articles available on the Apple Support web site. This article will give you instructions on what to do once you are in single user mode.

    http://docs.info.apple.com/article.html?artnum=106214

    Let us know how it goes.
     
  6. themespot thread starter macrumors newbie

    Joined:
    Sep 3, 2007
    #6
    alt-cmd-pr seemed to do a forced restart, but the grey screen still appeared and holding down s to enter single user mode had no success either, alas.. always on holidays... I'm off to the apple store in the a.m.

    thanks for all your help and suggestions
     

Share This Page