Your Photo Stream is empty message

Discussion in 'Apple TV and Home Theater' started by chunter1001, Nov 3, 2015.

  1. chunter1001 macrumors member

    Joined:
    Jun 23, 2012
    #1
    With the new Apple TV, it states my Photo Stream is empty. When I look on my phone or MacBook, there are plenty of pictures.

    Under accounts, if I enable iCloud Photo Sharing, I can see folders of photos that I've shared and are shared with me.

    I do not use iCloud Photo Library. Any ideas what is happening?
     
  2. brandscill macrumors 6502

    Joined:
    Jul 10, 2008
    #2
    After I turned it on for the first time it took 3 hours to work. How long have you been waiting?
     
  3. chunter1001 thread starter macrumors member

    Joined:
    Jun 23, 2012
  4. TrueBlou macrumors demi-god

    TrueBlou

    Joined:
    Sep 16, 2014
    Location:
    Scotland
    #4
    The Photos app only works (annoyingly) with albums you have set as shared.

    Maybe worth setting a couple of shared albums and see if they show up.


    Scratch that, somehow I managed to miss the bit in your post where you mentioned shared photos :rolleyes:
     
  5. chunter1001 thread starter macrumors member

    Joined:
    Jun 23, 2012
    #5
    Ok. Thanks! So I've seen shared photos, just not my regular photo stream like on the older ATV models.

    Not sure why it's an option to enable regular photo stream under Account>iCloud if it doesn't work. Sigh.
     
  6. TrueBlou macrumors demi-god

    TrueBlou

    Joined:
    Sep 16, 2014
    Location:
    Scotland
    #6
    I've had issues in the past where my photo stream haven't shown old photos, but started showing new ones.

    Have you tried snapping a couple of photos since you set the ATV up, just to see if they show?
     
  7. chunter1001 thread starter macrumors member

    Joined:
    Jun 23, 2012
    #7
    Yep! I tried this. Interestingly my Photo Stream on my MacBook stopped updating last Friday (the day I got ATV4). On iPhone, the photo stream looks up to date

    For good measure, I've turned Photo Stream off on all devices and re-enabled. Made sure my camera app was closed on phone. Still no updates on MBP or ATV4.
     
  8. TrueBlou macrumors demi-god

    TrueBlou

    Joined:
    Sep 16, 2014
    Location:
    Scotland
    #8
    That's very odd. There seem to be some random weirdness happening with some people for some reason. I've not had any issues with my photos showing up so far but I'm going to keep a close eye on it to see what happens.
     
  9. pr0jects macrumors newbie

    Joined:
    Nov 4, 2015
    #9
    I had the same issue. The solution was to change the network-connection from Lan to Wlan. As soon as the ATV4 was connected via Wlan the photos appear.
     
  10. FatherOfTwo macrumors member

    FatherOfTwo

    Joined:
    Jun 9, 2015
    #10
    Same issue for me. Photo stream works fine my all other devices ( iPad / iPhone / mac ) but on new apple TV it only shows 5 photos. The shared photos appear but the actual photo stream does not update.

    I've tried the usually logging out and back in, turning off photo stream and then back on.

    If anyone has a solution please post! THANKS.

    P.S didn't really understand the previous update going for LAN to WLAN
     
  11. TrueBlou macrumors demi-god

    TrueBlou

    Joined:
    Sep 16, 2014
    Location:
    Scotland
    #11

    He's just saying if you are connected with an Ethernet cable, take it out and set up a WiFi connection from the settings menu.

    At this point, it's worth a try, nothing else has been helping so far.
     
  12. machpost macrumors 6502

    machpost

    Joined:
    Jan 28, 2010
    Location:
    Washington, DC
    #12
    I'm also having issues with photos. I got the "your photo stream is empty" message too. Turning photo stream and shared photos off, then on again, initially helped, but the problem still shows up at random. It's also not downloading more than a few dozen photos, even though my iCloud photo stream should be maxed out.
     
  13. FatherOfTwo macrumors member

    FatherOfTwo

    Joined:
    Jun 9, 2015
    #13
    I've tried wireless, wired connection. I've double checked photos on my MAC, IPhone IPad and they are sync up nicely but ATV4 only shows 5 photos. Ahhhhhhhh.

    Along with my network drop off issue I might do a complete system restore and start again.
     

Share This Page