Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.


macrumors newbie
Original poster
Jun 11, 2013

I have a 2010 Mac Pro with 12 core (2 x 2.66) with 64 gigs of ram. I've never run of memory before.

I only seem to get this message when trying to start Calendar for some reason. It never actually starts now.. it merely never opens, followed by that message.


Not sure if what the issue is. I googled for it but was unable to find anything on it, most likely given the age of OS X Mavericks 10.9 DP1


macrumors newbie
Original poster
Jun 11, 2013
It's most likely the fact that you're using TextMate, which hasn't seen an update since 2011 I think. That and Chrome.

Actually Textmate is rock solid, it's Calendar that causes the issue.

I agree Chrome eats memory, but it's a better browser than Safari at least from what I have seen/used.

The only time I see the memory issue is with Apple's stock Calendar app.

Apple's Calendar just flat out will not start. It merely flashes as if it's opening, then I get the oh noes ram msg. If I go into the activity monitor I can watch Calendar eat it's way up to 63.99 gigs of memory used without it opening. 100% of energy impact used as well on the energy tab

I have busycal installed and have been using this as my default calendar, so my guess is that Apple goes to start the default thinking it'll be it's own program - hits a wall and hangs.

currently looking to reverse this to test it and see if that was the issue.

edit - nope, that wasn't it. making calendar my default did zero. it still won't open.
Last edited:


macrumors Haswell
May 3, 2009
Perhaps because calendar is part of the beta and there's a bug there.


macrumors 6502
Jun 6, 2008
Im getting the same error, App Store, Safari, and Linotype FontExplorer are the only things open. Acivity Monitor is showing the kernel taking up 9.26GB of my 16GB RAM. Uhh, I don't remember ML taking that much. And it's taken me twice as long to type the post, because the OS keeps pausing Safari to save memory. I might be hitting the Time Machine backup and resorting to ML in the morning.


macrumors newbie
Oct 25, 2013
Maverick and Your System message

I've updated my Macbook Pro and my iMac with Maverick, updating the various apps (Pages, Aperture, iPhoto, Numbers & iMovie, too) in the process.

On my Macbook, everything functions perfectly. On my iMac, I get the Your System has Run out of Application Memory message. But it's not Calendar, it's Mail that not only won't open, but when it does now, it takes the entire system out with it.

I open Safari, and it works. I open Firefox, and it works and Safari still works. I open Calendar and it works, Safari and Firefox continue to work. I open Reminders, and everything still works.

I open Aperture, and it opens Finder instead, showing the 3.5 update that was installed two days ago (and Aperture has functioned), but doesn't seem to update the app; after about 20 seconds the update disappears and I can now open Aperture and it shows I'm now opening the updated Aperture, which it didn't show before.

I click on Mail, and the cursor spins for ten minutes. The mail window finally opens, but the cursor spins and does not connect to upload new mail, and I finally Force Quit Mail. Since the Maverick update, even though Mail was not updated (and maybe because Mail was not updated), I have been able to receive emails twice, and then the program crashed.

Besides the Aperture app, Pages didn't fully update on the iMac, and I had to remove the old Pages icon from the dock after the new program loaded up from Applications.

Any ideas?


macrumors newbie
Oct 30, 2013
On the phone with apple now for the third time. Reinstalled but that did not help either. Doesn't matter what program. My finder uses 11 gb without any other program loaded. Apple is bumping me up now to engineer level.


macrumors regular
Oct 14, 2011
Los Angeles
Same thing just happened to me on a new maxed out rMBP 15.
I haven't put very many programs on it as it only arrived last night, but I had safari, adium, messages, mail, teamviewer, dropbox open at the time it locked up.


macrumors newbie
Nov 12, 2010
Hello Everyone, I found this and it worked for me on Mavericks, hope this helps.

" Your system has run out of application memory "
CalendarAgent process is out of control - delegation may be causing problems?

Thank you bonzabuy

I've had the same problem,
I spent over an hour on the phone with Apple support. They tried a number of things - from disk permissions, disk repair, start up items, login items, new user account.

The thing that seemed to do the trick instantly:

Delete the Calendar cache.

A rough procedure:
Open iCal
Full back up all calendars (full archive I think it's called)
Close iCal.

Go to Finder
'Go" menu
Hold down option key
Go to Library
In Library go to Calendar.
Delete Calendar Cache.

Restart machine.
Start iCal.

If all is well & all reminders / appointments restored then you can delete the backup.

Best Regards,



macrumors member
Mar 4, 2012
Application memory low

Ive started getting this message too and there is a ' kernel _ task ' using 1.09gb of memory on my late 2012 Mac Mini Server with 16gb of RAM . Its very difficult too , to find out what's going wrong because of the terrible lag when Screen Sharing into it :(

Never had any of this before Mavericks , I could do with proper new user guide !



macrumors 6502a
May 23, 2008
I deleted the cache for iCal and it helped for awhile, but now it is back. Do you have any other suggestions? thanks!


macrumors newbie
Jan 23, 2014
Sacramento Valley
Here we are in December 2014 well past Yosemite update on my MBP... And I just started getting this same error. Mail, Chrome and Calendar all stopped responding. I could restart all but mail - that I had to force quit. And now... at least temporarily... works fine. I've of course never received this error while using memory intensive processes. Only while sitting here basically idle reading my email.


macrumors newbie
Dec 19, 2014
Yes. Dec 2014. Me too just started getting this error after running maverick with no problems since they first released it. It keeps showing the memory message no matter how I start up or what I have running. Is there any fix to this?
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.