iPod touch Youtube advice

Lost4Daze

macrumors newbie
Original poster
Nov 27, 2009
7
0
I just bought my ipod touch and I'm trying to view videos on youtube but they keep freezing up...it's like they play for a few seconds and freeze then play and freeze...I was really excited about youtube but it kinda feels useless now:( Is there anything I should do to help with this problem...thanks

By the way the wi-fi connection is strong and I got a good router
 

LDuffey4

macrumors newbie
Nov 27, 2009
5
0
mine did that at first too. you might have to let it buffer. it'll get easier as it goes. soon it'll just play like normal.
 

Lost4Daze

macrumors newbie
Original poster
Nov 27, 2009
7
0
mine did that at first too. you might have to let it buffer. it'll get easier as it goes. soon it'll just play like normal.
Thanks for the quick reply...so I should just keep trying to play videos and keep hitting the play button again when it freezes?
 

LDuffey4

macrumors newbie
Nov 27, 2009
5
0
yeah just when the loading bar (the white one i think) gets about halfway play it and it should play until the end.
 

pilotrtc

macrumors regular
Dec 4, 2008
242
0
yeah just when the loading bar (the white one i think) gets about halfway play it and it should play until the end.
I agree. As soon as I see the video is slow to start, either because the white bar is slow or the video stops almost immediately, I pause the playback and wait for the video to load at least 1/2 way before continuing playback.

I've found that buffering speed varies on YouTube. I haven't discovered a pattern but I have experienced fast and slow buffering times.
 

Lost4Daze

macrumors newbie
Original poster
Nov 27, 2009
7
0
Alright I'm trying what you guys said...it seems like the white loading bar takes forever to load...up to 10 minutes which kinda sucks, do you think it's just the videos I'm looking at? and will some other videos load quicker like you said "pilotrtc"?
 

pilotrtc

macrumors regular
Dec 4, 2008
242
0
I find it varies widely. I also noticed that when it's stuck at buffering the playback pauses too. Even on my MacBook (purchased 10/2008) running Firefox 3.
 

rjphoto

macrumors 6502a
Mar 7, 2005
822
0
Let's Play 20 questions! (Okay, maybe not 20.)

Are you clicking play or is starting to play on it's own?

IIRC it calculates the down load speed and the size of the video and starts playing when it reaches a point in the download that it thinks it can play with out running out of buffer. It doesn't always work though.

You say you have a good signal and a good router, but what is your internet speed?

You can search for a bandwidth speed check. The one I use is Flash based so you may want to test on a computer, not the iPod. (I'm sure there are some, I just don't know any off the top of my head.)

How many other computers are on the network?

We typically have 2 MacBooks, an eMac and an iPod Touch or 2 running at any given time and YouTube can choked the bandwidth from all of the other devices when you are playing a video and that's on a 3mb network.
 

Lost4Daze

macrumors newbie
Original poster
Nov 27, 2009
7
0
Ummm...

Q1. I'm not clicking play, I'm letting the load bar load as much as possible
Q2. I'm not sure if this is the right answer but i think it runs @ 10 megabytes
Q3 There are currently 3 computer running on the system...my moms PC and laptob and my ibook, my mom rarely gets on her laptop and right now I'm the only one on the computer so at any given time there's usually 1-2 computers running
 

rjphoto

macrumors 6502a
Mar 7, 2005
822
0
Ummm...

Q1. I'm not clicking play, I'm letting the load bar load as much as possible
Cool.

Try this.

Start downloading a video, let it load until it starts to play and click pause. Now let it finish loading, then click play.

Does it play smoothly now?

Also, have you updated the software on it?
 

Lost4Daze

macrumors newbie
Original poster
Nov 27, 2009
7
0
Cool.

Try this.

Start downloading a video, let it load until it starts to play and click pause. Now let it finish loading, then click play.

Does it play smoothly now?

Also, have you updated the software on it?
Ok I'll try that, and No I havent updated the software yet, I just got it like 2 days ago, I guess I should do that pretty soon, I'll let you know how it goes after I try your method
 

Lost4Daze

macrumors newbie
Original poster
Nov 27, 2009
7
0
geez its taking forever...i see the load bar creeping along but i dont think it'll play unless i push play, it must be my internet speed, i'm going to go to starbucks or the library tomorrow to see if its just my internet, i just dont think i should be waiting 10+ minutes to load a darn video....

But it does play smoothly up until it hits where the load bar is, it's just the video is faster than the loading i guess
 

rjphoto

macrumors 6502a
Mar 7, 2005
822
0
Find an iPod internet speed checker.

I use InternetFrog for computers. It's flash based I think, so that won't work on the iPod.

Search...
 

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.