YouTube audio lag in full screen

Discussion in 'MacBook Pro' started by NYR99, Sep 30, 2010.

  1. NYR99 macrumors 6502a

    Joined:
    Dec 30, 2007
    #1
    Hello,

    I am having a problem when viewing some 720p HD YouTube videos in full screen mode. The video will start off fine, but then the video will start to develop an annoying audio lag after around 20 seconds (if the video has options for either 720p or 1080p, the 720p will lag and the 1080p will play fine). I know it isn't the video, because when it starts to lag, I can click on the progress bar to around where the video is currently at, and the video will refresh I guess, and the audio and video will be in sync again (for a little while at least).

    I am not really sure if this is a hardware or software problem. My MBP specs are in my signature, and has these graphics: Intel HD Graphics / NVIDIA GeForce GT 330M graphics processor with 256MB GDDR3 memory. I use Firefox 3.6.10 (and I also tested this with Safari). I also have all available updates for Snow Leopard and Adobe Flash.

    The weird thing is that this only occurs on certain (but a lot) of videos.

    Remember, it only lags when in 720p and in full screen.

    These videos will play fine in 720p full screen mode with zero audio lag:
    Sample Video 1
    Sample Video 2

    These videos will have an audio lag after around 20 seconds or so and viewed in 720p fulls screen:
    Sample Video 3
    Sample Video 4

    This has been bugging me for a while. Any one else experience the same problems and/or have a solution?

    Thanks.
     
  2. NYR99 thread starter macrumors 6502a

    Joined:
    Dec 30, 2007
    #2
    I think it may only happen with more recently uploaded videos.

    Anyone, anyone? Buhler? Anyone?
     
  3. DadofThree macrumors newbie

    Joined:
    Apr 13, 2010
    #3
    Just tried sample videos #3 and #4. I only watched about 60 seconds, but everything seemed to play just fine and stay in sync. Sorry - probably not helpful, but at least it's a data point. I have a 2010 Core i7 MBP.
     
  4. NYR99 thread starter macrumors 6502a

    Joined:
    Dec 30, 2007
    #4
    Hmmmmmm. Ok. Thanks for the info. I think I might take a trip to the Apple Store to try the video on a MBP with the same specs as mine.
     
  5. HLdan macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #5
    I have the same specs as yours and mine plays perfectly on those videos you linked. You might need to reset your PRAM and also make sure that your video card is switched to the Nvidia side and not the Intel HD graphics.
     
  6. NYR99 thread starter macrumors 6502a

    Joined:
    Dec 30, 2007
    #6
    I just tried those videos again, and now they are not lagging at all. I am on a different WiFi network though. At my girlfriends house, where it was lagging, is a wireless G network. Here at my house, I have a wireless N network. Now I have no lag. Next time I go to my girlfriends house, I will try out the videos again.

    Also, How do I make sure the video card is switching?

    Thanks guys.
     
  7. Raggy macrumors newbie

    Joined:
    Sep 1, 2010
    Location:
    London, UK
    #7
    Hi guys - its not so much an audio lag for me. Its everything i watch in full screen, either youtube or any other flash videos the picture jumps and doesn't run smoothly. Only does it in full screen? Anyone else ever had this? :confused:
     
  8. HLdan macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #8
    You can turn off automatic switching and just use the Nvidia card by going into System Preferences-Energy Saver and uncheck Automatic Graphics Switching. It will for the Nvidia card to run only.
    You can also control which card you want to use by installing
    GFXcardstatus. You can download this for free.

    I've noticed full screen videos not being smooth when running the Intel HD graphics. If you have a Core i5/i7 Macbook Pro then you should also switch to the Nvidia card. It's a complete 180. The Intel HD card sucks for full screen videos.
     
  9. Raggy macrumors newbie

    Joined:
    Sep 1, 2010
    Location:
    London, UK
    #9
    Thanks so much HLdan - this seems to have helped a lot. It's still a tiny bit glitchy when it is loading but I think that may be more my internet connection. Its a 15" i7. Should I just leave it on this setting, with the automatic graphics switching turned off?
     
  10. HLdan macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #10
    Glad it helped. If battery life isn't your first priority then yes, you can leave it with the Graphics Switching unchecked. If you need to manage battery life and use your Nvidia card then download and install that free program I recommended earlier.

    GFXcardstatus.http://codykrieger.com/gfxCardStatus/
     
  11. Raggy macrumors newbie

    Joined:
    Sep 1, 2010
    Location:
    London, UK
  12. NYR99 thread starter macrumors 6502a

    Joined:
    Dec 30, 2007
    #12
    Thanks for the help, HLdan.

    Much appreciated.
     
  13. NYR99 thread starter macrumors 6502a

    Joined:
    Dec 30, 2007
    #13
    OK, so I downloaded and installed gfxCardSatus as suggested by HLdan.

    I have found out that when I have dynamic switching enabled, 720p videos will stay on the Intel graphics, thus causing the audio lag. If I choose a 1080p video, it will switch over, automatically, to the NVIDIA card.
    If I choose the "NVIDIA only" option on gfxCardStatus, then play that same 720p YouTube clip, it will play flawlessly.

    Is there a way I can change the parameters of when the dynamic switching occurs? I want to lower the sensitivity this way 720p videos will automatically cause the graphics to switch over to the NVIDIA card.

    Thanks
     

Share This Page