Youtube HD movies

Discussion in 'macOS' started by powerbuddy, Jul 1, 2009.

  1. powerbuddy macrumors 6502

    Joined:
    Jun 20, 2006
    #1
    Why do Youtube HD movies jerk and pause on OS X? I never seem to have this problem with windows! I have the latest drivers, and watching HD on youtube is a pain. :mad:
     
  2. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
  3. jason221 macrumors 6502

    Joined:
    Jun 26, 2009
    #3
    Most likely it is because your computer cannot handle what it takes to watch HD movies on YouTube. Unless the Windows you are referring to is on the same computer accessed via Boot Camp.. then I can't be sure. Try updating to the latest version of Flash.
     
  4. 11800506 macrumors 65816

    11800506

    Joined:
    Oct 31, 2007
    Location:
    Washington D.C. Area
    #4
    Flash is horribly optimized in OS X. It just uses a lot of resources for no reason.
     
  5. NathanCH macrumors 65816

    NathanCH

    Joined:
    Oct 5, 2007
    Location:
    Stockholm, Sweden
    #5
    Unlikely are hardware issue. Any computer bought in the last 3 years should easily be able to handle Youtube's "HD" video. I think it's more of an issue of OS X playing back Flash. I remember watching the US President video in HD and it was jittery. Seems like it was dropping a lot of frames even though I was using a brand new iMac. But it hasn't happened since
     
  6. martynmc7 macrumors regular

    Joined:
    Dec 30, 2008
    #6
    This isn't a hardware issue, it's just that flash really really sucks on OS X. For some reason Adobe has taken it upon themselves not to bother optimising flash for macs, if you have iStat Pro installed check the CPU readings during youtube playback and you'll see it can take up to 100% of the CPU.

    I was actually looking this up the other day because youtube was getting choppy and using about 70% of my CPU, turns out this is a common problem. What I would say is make sure your flash player is up-to-date. I downloaded 10 and my CPU usage went down to 50% and the videos weren't choppy anymore, I guess I must have been on 9 without realising.

    Still, 50% CPU useage for a youtube video is pretty unacceptable in 2009, come on Adobe, pull your finger out!
     

Share This Page